aboutsummaryrefslogtreecommitdiffstats
path: root/main/cups
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-01-25 09:33:23 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-01-25 09:33:29 +0000
commit784f0d491fa0ba9e0872e6b6a825dffec5aab2ed (patch)
treea41f6f6754336f5121bb7b6d2024d0b6080dd1a0 /main/cups
parente22073c1c7f7b8ce3fb8e8fa956153fad93501d4 (diff)
downloadaports-784f0d491fa0ba9e0872e6b6a825dffec5aab2ed.tar.bz2
aports-784f0d491fa0ba9e0872e6b6a825dffec5aab2ed.tar.xz
main/cups: fix default config to work without GSSAPI support - fixes #6706
Diffstat (limited to 'main/cups')
-rw-r--r--main/cups/APKBUILD12
-rw-r--r--main/cups/default-config-no-gssapi.patch26
2 files changed, 34 insertions, 4 deletions
diff --git a/main/cups/APKBUILD b/main/cups/APKBUILD
index d259ad3ef4..2e18efe1ab 100644
--- a/main/cups/APKBUILD
+++ b/main/cups/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cups
pkgver=2.2.2
-pkgrel=0
+pkgrel=1
pkgdesc="The CUPS Printing System"
url="http://www.cups.org/"
arch="all"
@@ -20,6 +20,7 @@ source="https://github.com/apple/cups/releases/download/v$pkgver/cups-$pkgver-so
$pkgname.logrotate
cupsd.initd
cups-no-export-ssllibs.patch
+ default-config-no-gssapi.patch
"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -122,12 +123,15 @@ client() {
md5sums="036f6bda6202ae3e280ac00c710b5ca4 cups-2.2.2-source.tar.gz
f861b18f4446c43918c8643dcbbd7f6d cups.logrotate
17ff6d91fdf976def038ce0464cfb74d cupsd.initd
-3ba9e3410df1dc3015463d615ef91b3b cups-no-export-ssllibs.patch"
+3ba9e3410df1dc3015463d615ef91b3b cups-no-export-ssllibs.patch
+ba695fa44511a2c70b72ea9d4137bb08 default-config-no-gssapi.patch"
sha256sums="f589bb7d5d1dc3aa0915d7cf2b808571ef2e1530cd1a6ebe76ae8f9f4994e4f6 cups-2.2.2-source.tar.gz
b3308353504bc1cc0d5203ad3609bc98639ad9655b52e8ec8257286877532796 cups.logrotate
e819e8e08248495f110370e5f0cfe954a9e5a49959e9a49487e5686a1aaa1caa cupsd.initd
-ff3eb0782af0405f5dafe89e04b1b4ea7a49afc5496860d724343bd04f375832 cups-no-export-ssllibs.patch"
+ff3eb0782af0405f5dafe89e04b1b4ea7a49afc5496860d724343bd04f375832 cups-no-export-ssllibs.patch
+8e7d1814f3ba556612e56464ad4c39adb14ca497e643268083a5cfb9a358b101 default-config-no-gssapi.patch"
sha512sums="c78156eddfbae5b5ac9963082763f2a8e0e297cc93fce9e12707ba3606164dc674f127819db972b00699587628ec35002da206691fed2e03578912c613150eac cups-2.2.2-source.tar.gz
162fe69ee46962f7ce07a9a2a75154682088895c4749c9bcfc54bb2aa861f48d7d1a8e3223f78a197319a3a405626ffe996615f6eb23168afcefabab343d5be0 cups.logrotate
b5c6cec757457773904d47b06fb3a3d70c316e5abac7e35164261f9d98d7275140c6f14337a848eb4c15034d91e4c859af93865531f26bd97defe3ec21ca90a8 cupsd.initd
-7a8cd9ac33b0dd4627c72df4275db8ccd7cf8e201bce3833719b42f532f526bb347b842e3ea1ef0d61855b5c6e1088b5d20b68942f2c2c0acf504d8d9728efd3 cups-no-export-ssllibs.patch"
+7a8cd9ac33b0dd4627c72df4275db8ccd7cf8e201bce3833719b42f532f526bb347b842e3ea1ef0d61855b5c6e1088b5d20b68942f2c2c0acf504d8d9728efd3 cups-no-export-ssllibs.patch
+98bb97f4af69ea286fc3d398b8e57c32440e6b2d49fb7f79b418a4fe7f13441f3a610f65d3433d10d971ade808233c0b29b4d66160623ccaae919179384be918 default-config-no-gssapi.patch"
diff --git a/main/cups/default-config-no-gssapi.patch b/main/cups/default-config-no-gssapi.patch
new file mode 100644
index 0000000000..b12c55ddf8
--- /dev/null
+++ b/main/cups/default-config-no-gssapi.patch
@@ -0,0 +1,26 @@
+--- a/conf/cupsd.conf.in
++++ b/conf/cupsd.conf.in
+@@ -145,12 +145,12 @@
+
+ # Job-related operations must be done by the owner or an administrator...
+ <Limit Create-Job Print-Job Print-URI Validate-Job>
+- AuthType Negotiate
++ AuthType Default
+ Order deny,allow
+ </Limit>
+
+ <Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job Cancel-My-Jobs Close-Job CUPS-Move-Job CUPS-Get-Document>
+- AuthType Negotiate
++ AuthType Default
+ Require user @OWNER @SYSTEM
+ Order deny,allow
+ </Limit>
+@@ -171,7 +171,7 @@
+
+ # Only the owner or an administrator can cancel or authenticate a job...
+ <Limit Cancel-Job CUPS-Authenticate-Job>
+- AuthType Negotiate
++ AuthType Default
+ Require user @OWNER @CUPS_DEFAULT_PRINTOPERATOR_AUTH@
+ Order deny,allow
+ </Limit>