aboutsummaryrefslogtreecommitdiffstats
path: root/main/cups
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-06-27 21:00:20 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-06-27 21:07:45 +0200
commitdb0a0d6a6a85307625cfa634d1785c659f252566 (patch)
tree87ffa16de295f3aa7078233c3529c83a2d1d0a3b /main/cups
parent97a6e2b5a62f2ce7a7380ff56c4bc7ae5e192c65 (diff)
downloadaports-db0a0d6a6a85307625cfa634d1785c659f252566.tar.bz2
aports-db0a0d6a6a85307625cfa634d1785c659f252566.tar.xz
main/cups: remove obsolete options, fix /run path, perms etc.
Diffstat (limited to 'main/cups')
-rw-r--r--main/cups/APKBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/main/cups/APKBUILD b/main/cups/APKBUILD
index 3055984b66..9a676bd9f7 100644
--- a/main/cups/APKBUILD
+++ b/main/cups/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cups
pkgver=2.2.3
-pkgrel=0
+pkgrel=1
pkgdesc="The CUPS Printing System"
url="http://www.cups.org/"
arch="all"
@@ -15,7 +15,6 @@ depends="cups-client poppler-utils libressl dbus"
install="cups.pre-install"
pkggroups="lp lpadmin"
pkgusers="lp"
-replaces="cups-doc"
source="https://github.com/apple/cups/releases/download/v$pkgver/cups-$pkgver-source.tar.gz
$pkgname.logrotate
cupsd.initd
@@ -31,24 +30,27 @@ build() {
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
+ --libdir=/usr/lib \
--sysconfdir=/etc \
--localstatedir=/var \
--with-logdir=/var/log/cups \
--with-docdir=/usr/share/cups \
+ --with-rundir=/run/cups \
+ --with-cupsd-file-perm=0755 \
--with-cups-user=lp \
--with-cups-group=lp \
--with-system-groups=lpadmin \
+ --with-domainsocket=/run/cups/cups.sock \
+ --without-rcdir \
--without-php \
--disable-pam \
- --disable-ldap \
- --libdir=/usr/lib \
--enable-raw-printing \
--enable-dbus \
--with-dbusdir=/etc/dbus-1 \
--enable-libpaper \
--enable-ssl=yes \
--enable-gnutls \
- --with-pdftops=pdftops \
+ --disable-launchd \
--with-optim="$CFLAGS"
make
}
@@ -60,9 +62,8 @@ package() {
cd "$pkgdir"
- rm -rf etc/init.d \
- etc/rc* \
- usr/share/cups/banners \
+ # These no longer works since CUPS >= 1.6 (http://www.cups.org/str.php?L4120).
+ rm -rf usr/share/cups/banners/* \
usr/share/cups/data/testprint
install -D -m 644 "$srcdir"/cups.logrotate etc/logrotate.d/cups
@@ -86,7 +87,7 @@ libs() {
}
ipptool() {
- pkgdesc=""
+ pkgdesc="Perform internet printing protocol requests"
depends=""
cd "$pkgdir"
@@ -95,7 +96,7 @@ ipptool() {
}
client() {
- pkgdesc="CUPS client"
+ pkgdesc="CUPS command-line client programs"
depends=""
cd "$pkgdir"