aboutsummaryrefslogtreecommitdiffstats
path: root/main/curl
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-25 14:29:31 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-04-29 20:56:46 +0000
commit0528182576472cb3b4f561f37c1dccfa64974ee0 (patch)
treeb599aabcdbda8fa4c5f70f65e6f6d8ac9b6dbddd /main/curl
parent32345c1db2d5994dc6c8a78998d24e740b2b9ad3 (diff)
downloadaports-0528182576472cb3b4f561f37c1dccfa64974ee0.tar.bz2
aports-0528182576472cb3b4f561f37c1dccfa64974ee0.tar.xz
main/curl: disable SSH support via libssh2
fixes #10222 See: https://bugs.alpinelinux.org/issues/10222 for more info
Diffstat (limited to 'main/curl')
-rw-r--r--main/curl/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/main/curl/APKBUILD b/main/curl/APKBUILD
index afd821a014..ec737b9078 100644
--- a/main/curl/APKBUILD
+++ b/main/curl/APKBUILD
@@ -4,13 +4,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=curl
pkgver=7.64.1
-pkgrel=1
+pkgrel=2
pkgdesc="URL retrival utility and library"
url="https://curl.haxx.se/"
arch="all"
license="MIT"
depends="ca-certificates"
-depends_dev="openssl-dev libssh2-dev nghttp2-dev zlib-dev"
+depends_dev="openssl-dev nghttp2-dev zlib-dev"
checkdepends="python2"
makedepends="$depends_dev autoconf automake groff libtool perl"
subpackages="$pkgname-dbg $pkgname-doc $pkgname-dev libcurl"
@@ -90,10 +90,10 @@ build() {
--enable-unix-sockets \
--without-libidn \
--without-libidn2 \
- --with-libssh2 \
--with-nghttp2 \
--disable-ldap \
- --with-pic
+ --with-pic \
+ --without-libssh2 # https://bugs.alpinelinux.org/issues/10222
make
}