aboutsummaryrefslogtreecommitdiffstats
path: root/main/curl
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-05-16 14:51:21 +0000
committerJakub Jirutka <jakub@jirutka.cz>2018-05-20 21:32:54 +0200
commit0a8c160f5bfb61a52f6baa67dd5ce1e6b72038ae (patch)
treefda49878c43447bc20939f4cff27e2186f2b4a03 /main/curl
parentc278dba3ceabc01db14be79605ae4ae2ce617eb8 (diff)
downloadaports-0a8c160f5bfb61a52f6baa67dd5ce1e6b72038ae.tar.bz2
aports-0a8c160f5bfb61a52f6baa67dd5ce1e6b72038ae.tar.xz
main/curl: upgrade to 7.60.0
Diffstat (limited to 'main/curl')
-rw-r--r--main/curl/0001-openssl-fix-build-with-libressl-2.7.patch4
-rw-r--r--main/curl/APKBUILD11
2 files changed, 9 insertions, 6 deletions
diff --git a/main/curl/0001-openssl-fix-build-with-libressl-2.7.patch b/main/curl/0001-openssl-fix-build-with-libressl-2.7.patch
index d8fd5c7315..407357bd94 100644
--- a/main/curl/0001-openssl-fix-build-with-libressl-2.7.patch
+++ b/main/curl/0001-openssl-fix-build-with-libressl-2.7.patch
@@ -15,7 +15,7 @@ diff --git a/configure.ac b/configure.ac
index 798fa5f1e..9033165c1 100755
--- a/configure.ac
+++ b/configure.ac
-@@ -1791,6 +1791,7 @@ if test -z "$ssl_backends" -o "x$OPT_SSL" != xno &&
+@@ -1789,6 +1789,7 @@ if test -z "$ssl_backends" -o "x$OPT_SSL" != xno &&
AC_MSG_RESULT([no])
])
@@ -27,7 +27,7 @@ diff --git a/lib/vtls/openssl.c b/lib/vtls/openssl.c
index 2a6b3cfac..9ae5313e1 100644
--- a/lib/vtls/openssl.c
+++ b/lib/vtls/openssl.c
-@@ -117,7 +117,7 @@
+@@ -126,7 +126,7 @@
#define X509_get0_notBefore(x) X509_get_notBefore(x)
#define X509_get0_notAfter(x) X509_get_notAfter(x)
#define CONST_EXTS /* nope */
diff --git a/main/curl/APKBUILD b/main/curl/APKBUILD
index ec4650532c..bab6aa18fd 100644
--- a/main/curl/APKBUILD
+++ b/main/curl/APKBUILD
@@ -3,8 +3,8 @@
# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=curl
-pkgver=7.59.0
-pkgrel=1
+pkgver=7.60.0
+pkgrel=0
pkgdesc="URL retrival utility and library"
url="http://curl.haxx.se"
arch="all"
@@ -18,6 +18,9 @@ source="http://curl.haxx.se/download/$pkgname-$pkgver.tar.xz
"
# secfixes:
+# 7.60.0-r0:
+# - CVE-2018-1000300
+# - CVE-2018-1000301
# 7.59.0-r0:
# - CVE-2018-1000120
# - CVE-2018-1000121
@@ -100,5 +103,5 @@ libcurl() {
mv "$pkgdir"/usr/lib "$subpkgdir"/usr
}
-sha512sums="6982a5950b564d6b2a4f4b96296b6db3db24a096acc68aa96966821b57f66362f5a69d9f2da762b5d2b1011a4a47478ebacaf05e26604f78bb013098749dd8a6 curl-7.59.0.tar.xz
-20bc877c17824fe4886b10c2b90f7dd3f597968801e2f856acc5ea474b60fc3de0367e810b8593f01b5e08968499b5d7aa7e7967ddef260b86e920dccf00e21a 0001-openssl-fix-build-with-libressl-2.7.patch"
+sha512sums="96a0c32ca846a76bba75e9e560ad4c15df79540992ed1a83713095be94ddba039f289bda9678762fd79fb9691fe810735178fb9dc970c37012dff96b8ce08abf curl-7.60.0.tar.xz
+16c9b54cfa996a61278c0a899840be9e42477661ff6d69d6a772671aeb50a597e9de9328ba3c0a5cb71fa073e4a58db5f3962aab7636a9f1327cad343ff05ae9 0001-openssl-fix-build-with-libressl-2.7.patch"