aboutsummaryrefslogtreecommitdiffstats
path: root/main/curl
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-04-12 10:06:06 +0200
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-04-12 09:57:27 +0000
commit603fbfdc266c3ca43c0d9c78d87d2222eb94019a (patch)
treed13f2ad3af36f5097004cfe09845acfd57db0862 /main/curl
parentee43ff043bbe380b1070603146e8da09b08b6116 (diff)
downloadaports-603fbfdc266c3ca43c0d9c78d87d2222eb94019a.tar.bz2
aports-603fbfdc266c3ca43c0d9c78d87d2222eb94019a.tar.xz
main/curl: upgrade to 7.64.1
Diffstat (limited to 'main/curl')
-rw-r--r--main/curl/APKBUILD12
-rw-r--r--main/curl/url-fix-7.64.patch10
2 files changed, 5 insertions, 17 deletions
diff --git a/main/curl/APKBUILD b/main/curl/APKBUILD
index e993cc802a..264a567a49 100644
--- a/main/curl/APKBUILD
+++ b/main/curl/APKBUILD
@@ -3,10 +3,10 @@
# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=curl
-pkgver=7.64.0
-pkgrel=1
+pkgver=7.64.1
+pkgrel=0
pkgdesc="URL retrival utility and library"
-url="https://curl.haxx.se"
+url="https://curl.haxx.se/"
arch="all"
license="MIT"
depends="ca-certificates"
@@ -14,8 +14,7 @@ depends_dev="openssl-dev libssh2-dev nghttp2-dev zlib-dev"
checkdepends="python2"
makedepends="$depends_dev autoconf automake groff libtool perl"
subpackages="$pkgname-dbg $pkgname-doc $pkgname-dev libcurl"
-source="https://curl.haxx.se/download/$pkgname-$pkgver.tar.xz
- url-fix-7.64.patch"
+source="https://curl.haxx.se/download/$pkgname-$pkgver.tar.xz"
options="!check" # sftp tests failing
builddir="$srcdir/$pkgname-$pkgver"
@@ -116,5 +115,4 @@ libcurl() {
mv "$pkgdir"/usr/lib "$subpkgdir"/usr
}
-sha512sums="953f1f5336ce5dfd1b9f933624432d401552d91ee02d39ecde6f023c956f99ec6aae8d7746d7c34b6eb2d6452f114e67da4e64d9c8dd90b7644b7844e7b9b423 curl-7.64.0.tar.xz
-9b0cd3bfb705e804f21b3c87929ec5c3bbd6f17748e82cda75c3edbca5ea66cbcb0260c666635a2cbdaa6d4081008a9c445b4f266e9b970d3deaed21f9b352a1 url-fix-7.64.patch"
+sha512sums="1629ba154691bf9d936e0bce69ec8fb54991a40d34bc16ffdfb117f91e3faa93164154fc9ae9043e963955862e69515018673b7239f2fd625684a59cdd1db81c curl-7.64.1.tar.xz"
diff --git a/main/curl/url-fix-7.64.patch b/main/curl/url-fix-7.64.patch
deleted file mode 100644
index ed63f90092..0000000000
--- a/main/curl/url-fix-7.64.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/lib/url.c
-+++ b/lib/url.c
-@@ -965,6 +965,7 @@
- /* The protocol has a special method for checking the state of the
- connection. Use it to check if the connection is dead. */
- unsigned int state;
-+ conn->data = data; /* use this transfer for now */
- state = conn->handler->connection_check(conn, CONNCHECK_ISDEAD);
- dead = (state & CONNRESULT_DEAD);
- }