aboutsummaryrefslogtreecommitdiffstats
path: root/main/curl
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-02 21:07:48 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-06 05:19:20 +0000
commita9e0e06d9e5116e23271a7052798a39abcf4c5b8 (patch)
treee87ee6fe4340f9732cefaeedc91c2d849306ca14 /main/curl
parent27a4975926f9bf5374b52e1e62280c0438c84e1c (diff)
downloadaports-a9e0e06d9e5116e23271a7052798a39abcf4c5b8.tar.bz2
aports-a9e0e06d9e5116e23271a7052798a39abcf4c5b8.tar.xz
main/curl: rebuild against libressl 2.7
Diffstat (limited to 'main/curl')
-rw-r--r--main/curl/0001-openssl-fix-build-with-libressl-2.7.patch41
-rw-r--r--main/curl/APKBUILD13
2 files changed, 50 insertions, 4 deletions
diff --git a/main/curl/0001-openssl-fix-build-with-libressl-2.7.patch b/main/curl/0001-openssl-fix-build-with-libressl-2.7.patch
new file mode 100644
index 0000000000..d8fd5c7315
--- /dev/null
+++ b/main/curl/0001-openssl-fix-build-with-libressl-2.7.patch
@@ -0,0 +1,41 @@
+From 0941757feba839f22f26985ae1a23dc02a878f50 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Mon, 2 Apr 2018 20:55:52 +0000
+Subject: [PATCH] openssl: fix build with libressl 2.7
+
+LibreSSL 2.7 introduced some of the OpenSSL 1.1 API.
+
+Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
+---
+ configure.ac | 1 +
+ lib/vtls/openssl.c | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 798fa5f1e..9033165c1 100755
+--- a/configure.ac
++++ b/configure.ac
+@@ -1791,6 +1791,7 @@ if test -z "$ssl_backends" -o "x$OPT_SSL" != xno &&
+ AC_MSG_RESULT([no])
+ ])
+
++ AC_CHECK_FUNCS( OpenSSL_version_num )
+ AC_MSG_CHECKING([for libressl])
+ AC_COMPILE_IFELSE([
+ AC_LANG_PROGRAM([[
+diff --git a/lib/vtls/openssl.c b/lib/vtls/openssl.c
+index 2a6b3cfac..9ae5313e1 100644
+--- a/lib/vtls/openssl.c
++++ b/lib/vtls/openssl.c
+@@ -117,7 +117,7 @@
+ #define X509_get0_notBefore(x) X509_get_notBefore(x)
+ #define X509_get0_notAfter(x) X509_get_notAfter(x)
+ #define CONST_EXTS /* nope */
+-#ifdef LIBRESSL_VERSION_NUMBER
++#ifndef HAVE_OPENSSL_VERSION_NUM && defined(LIBRESSL_VERSION_NUMBER)
+ static unsigned long OpenSSL_version_num(void)
+ {
+ return LIBRESSL_VERSION_NUMBER;
+--
+2.16.3
+
diff --git a/main/curl/APKBUILD b/main/curl/APKBUILD
index 861bfae4b7..ec4650532c 100644
--- a/main/curl/APKBUILD
+++ b/main/curl/APKBUILD
@@ -4,15 +4,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=curl
pkgver=7.59.0
-pkgrel=0
+pkgrel=1
pkgdesc="URL retrival utility and library"
url="http://curl.haxx.se"
arch="all"
license="MIT"
depends="ca-certificates"
-makedepends="zlib-dev libressl-dev libssh2-dev groff perl nghttp2-dev"
+depends_dev="zlib-dev libressl-dev libssh2-dev nghttp2-dev"
+makedepends="$depends_dev groff perl automake autoconf libtool"
subpackages="$pkgname-dbg $pkgname-doc $pkgname-dev libcurl"
-source="http://curl.haxx.se/download/$pkgname-$pkgver.tar.xz"
+source="http://curl.haxx.se/download/$pkgname-$pkgver.tar.xz
+ 0001-openssl-fix-build-with-libressl-2.7.patch
+ "
# secfixes:
# 7.59.0-r0:
@@ -65,6 +68,7 @@ builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
+ autoreconf -vif
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -96,4 +100,5 @@ libcurl() {
mv "$pkgdir"/usr/lib "$subpkgdir"/usr
}
-sha512sums="6982a5950b564d6b2a4f4b96296b6db3db24a096acc68aa96966821b57f66362f5a69d9f2da762b5d2b1011a4a47478ebacaf05e26604f78bb013098749dd8a6 curl-7.59.0.tar.xz"
+sha512sums="6982a5950b564d6b2a4f4b96296b6db3db24a096acc68aa96966821b57f66362f5a69d9f2da762b5d2b1011a4a47478ebacaf05e26604f78bb013098749dd8a6 curl-7.59.0.tar.xz
+20bc877c17824fe4886b10c2b90f7dd3f597968801e2f856acc5ea474b60fc3de0367e810b8593f01b5e08968499b5d7aa7e7967ddef260b86e920dccf00e21a 0001-openssl-fix-build-with-libressl-2.7.patch"