aboutsummaryrefslogtreecommitdiffstats
path: root/main/curl
diff options
context:
space:
mode:
authorValery Kartel <valery.kartel@gmail.com>2016-01-25 15:02:56 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2016-01-26 21:32:30 +0000
commitd312648c4ac76e655f817783860fe16c370d8e88 (patch)
tree6f02478f32d4b829dacd97e9e8f02459089d097b /main/curl
parent389f12ff53963834a9a3079cd6efb1775de04021 (diff)
downloadaports-d312648c4ac76e655f817783860fe16c370d8e88.tar.bz2
aports-d312648c4ac76e655f817783860fe16c370d8e88.tar.xz
main/curl: strip to subpackages and some cleanups
- remove unused patch - move libcurl and zsh completion to subpackages
Diffstat (limited to 'main/curl')
-rw-r--r--main/curl/0001-mkhelp-generate-code-for-disable-manual-as-well.patch42
-rw-r--r--main/curl/APKBUILD33
2 files changed, 25 insertions, 50 deletions
diff --git a/main/curl/0001-mkhelp-generate-code-for-disable-manual-as-well.patch b/main/curl/0001-mkhelp-generate-code-for-disable-manual-as-well.patch
deleted file mode 100644
index d23b484d3e..0000000000
--- a/main/curl/0001-mkhelp-generate-code-for-disable-manual-as-well.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 38d582ff541353d738858299d4a2b78bafac03ed Mon Sep 17 00:00:00 2001
-From: Daniel Stenberg <daniel@haxx.se>
-Date: Wed, 26 Mar 2014 13:22:10 +0100
-Subject: [PATCH] mkhelp: generate code for --disable-manual as well
-
-This allows configure --disable-manual to run and build without having
-to regenerate the src/tool_hugehelp.c file which otherwise is necessary
-since we ship tarballs with that file present.
-
-Reported-by: Remi Gacogne
-Bug: http://curl.haxx.se/bug/view.cgi?id=1350
----
- src/mkhelp.pl | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/src/mkhelp.pl b/src/mkhelp.pl
-index 444b669..7ed86f7 100644
---- a/src/mkhelp.pl
-+++ b/src/mkhelp.pl
-@@ -6,7 +6,7 @@
- # | (__| |_| | _ <| |___
- # \___|\___/|_| \_\_____|
- #
--# Copyright (C) 1998 - 2011, Daniel Stenberg, <daniel@haxx.se>, et al.
-+# Copyright (C) 1998 - 2014, Daniel Stenberg, <daniel@haxx.se>, et al.
- #
- # This software is licensed as described in the file COPYING, which
- # you should have received as part of this distribution. The terms
-@@ -256,6 +256,10 @@ foot();
-
- sub foot {
- print <<FOOT
-+#else /* !USE_MANUAL */
-+/* built-in manual is disabled, blank function */
-+#include "tool_hugehelp.h"
-+void hugehelp(void) {}
- #endif /* USE_MANUAL */
- FOOT
- ;
---
-1.9.1
-
diff --git a/main/curl/APKBUILD b/main/curl/APKBUILD
index 4962d9eba8..e34df81749 100644
--- a/main/curl/APKBUILD
+++ b/main/curl/APKBUILD
@@ -1,20 +1,20 @@
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=curl
pkgver=7.46.0
-pkgrel=1
+pkgrel=2
pkgdesc="An URL retrival utility and library"
url="http://curl.haxx.se"
arch="all"
license="MIT"
depends="ca-certificates"
depends_dev="zlib-dev openssl-dev libssh2-dev"
-makedepends="groff $depends_dev perl"
-source="http://curl.haxx.se/download/curl-$pkgver.tar.bz2"
-subpackages="$pkgname-doc $pkgname-dev"
-
-_builddir="$srcdir/$pkgname-$pkgver"
+makedepends="$depends_dev groff perl"
+source="http://curl.haxx.se/download/$pkgname-$pkgver.tar.bz2"
+subpackages="$pkgname-doc $pkgname-dev libcurl $pkgname-zsh-completion:zshcomp"
+_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
local i
cd "$_builddir"
@@ -24,17 +24,19 @@ prepare() {
esac
done
}
+
build() {
cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --mandir=/usr/share/man \
- --without-libidn \
--enable-ipv6 \
--enable-unix-sockets \
+ --without-libidn \
+ --disable-static \
--disable-ldap \
+ --with-pic \
|| return 1
make || return 1
}
@@ -44,6 +46,21 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
+libcurl() {
+ pkgdesc="The multiprotocol file transfer library"
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/lib "$subpkgdir"/usr
+}
+
+zshcomp() {
+ pkgdesc="Zsh completion for $pkgname"
+ arch="noarch"
+ depends=""
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+ mkdir -p "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/share/zsh "$subpkgdir"/usr/share
+}
+
md5sums="9979f989a2a9930d10f1b3deeabc2148 curl-7.46.0.tar.bz2"
sha256sums="b7d726cdd8ed4b6db0fa1b474a3c59ebbbe4dcd4c61ac5e7ade0e0270d3195ad curl-7.46.0.tar.bz2"
sha512sums="ff47216a2b4a2d14a2e98e0e87867897a9bf059c58d2d73aa47a69ccd94977367e2de15bea641abfb00e236a8b016ee869675c2cc702f7919da5fe612bd8b5e1 curl-7.46.0.tar.bz2"