aboutsummaryrefslogtreecommitdiffstats
path: root/main/curl
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2020-03-12 08:18:44 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2020-03-12 08:18:44 +0000
commitd74d0ed9381c47e4e76cb224d6367bb93c02c2a1 (patch)
tree5cc8d4c316f2f6e4ab1c9d65e286946e6f5b2890 /main/curl
parent7f165af95333e1d851df80482ece14f7fd65ea1c (diff)
downloadaports-d74d0ed9381c47e4e76cb224d6367bb93c02c2a1.tar.bz2
aports-d74d0ed9381c47e4e76cb224d6367bb93c02c2a1.tar.xz
main/curl: upgrade to 7.69.1
Diffstat (limited to 'main/curl')
-rw-r--r--main/curl/APKBUILD11
-rw-r--r--main/curl/revert-pause-force-drain-the-transfer-on-unpause.patch51
2 files changed, 4 insertions, 58 deletions
diff --git a/main/curl/APKBUILD b/main/curl/APKBUILD
index 92f95db1c4..7e402e6378 100644
--- a/main/curl/APKBUILD
+++ b/main/curl/APKBUILD
@@ -3,8 +3,8 @@
# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=curl
-pkgver=7.69.0
-pkgrel=1
+pkgver=7.69.1
+pkgrel=0
pkgdesc="URL retrival utility and library"
url="https://curl.haxx.se/"
arch="all"
@@ -14,9 +14,7 @@ depends_dev="openssl-dev nghttp2-dev zlib-dev"
checkdepends="python3"
makedepends="$depends_dev autoconf automake groff libtool perl"
subpackages="$pkgname-dbg $pkgname-static $pkgname-doc $pkgname-dev libcurl"
-source="https://curl.haxx.se/download/curl-$pkgver.tar.xz
- revert-pause-force-drain-the-transfer-on-unpause.patch
- "
+source="https://curl.haxx.se/download/curl-$pkgver.tar.xz"
# secfixes:
# 7.66.0-r0:
@@ -130,5 +128,4 @@ static() {
mv "$pkgdir"/usr/lib/*.a "$subpkgdir"/usr/lib
}
-sha512sums="8c151201b09c51cc1437c2f6345036fce88ea5402cd1fd62b76c093e294b87d0c1f61e1dcf6f799f508d8dcfe381589a3815001a8c8bbc085aed0fdca6f2536d curl-7.69.0.tar.xz
-4b0da7e39aa2bfb34280246478d5e8525ab45ce5b2045a3ff2704fc1c4d8aeb241cfaf8c797cbd279e03740988661ca98a4962f850891f96fdef6707c6197d1b revert-pause-force-drain-the-transfer-on-unpause.patch"
+sha512sums="dcb917ce9a6f34b30adae10e2e635d7a8c67781d69789cc5617ab2b49e898394ecfeee546453b14ab168d4b3b52baf974b2ec07e7a4b199addbc1ba57274d8fa curl-7.69.1.tar.xz"
diff --git a/main/curl/revert-pause-force-drain-the-transfer-on-unpause.patch b/main/curl/revert-pause-force-drain-the-transfer-on-unpause.patch
deleted file mode 100644
index 580cf17735..0000000000
--- a/main/curl/revert-pause-force-drain-the-transfer-on-unpause.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-source: https://github.com/curl/curl/commit/8aa04e9a24932b830bc5eaf6838dea5a3329341e
-upstream: https://github.com/curl/curl/issues/5044
-reason: breaks cargo and flatpak
-
-From 8aa04e9a24932b830bc5eaf6838dea5a3329341e Mon Sep 17 00:00:00 2001
-From: Daniel Stenberg <daniel@haxx.se>
-Date: Thu, 5 Mar 2020 23:45:36 +0100
-Subject: [PATCH] Revert "pause: force-drain the transfer on unpause"
-
-This reverts commit fa0216b294af4c7113a9040ca65eefc7fc18ac1c (from #5000)
-
-Clearly that didn't solve the problem correctly.
-
-Reported-by: Christopher Reid
-Reopens #4966
-Fixes #5044
-diff --git a/lib/easy.c b/lib/easy.c
-index 1a6912748e8..454621076ab 100644
---- a/lib/easy.c
-+++ b/lib/easy.c
-@@ -1033,7 +1033,6 @@ CURLcode curl_easy_pause(struct Curl_easy *data, int action)
- to have this handle checked soon */
- if((newstate & (KEEP_RECV_PAUSE|KEEP_SEND_PAUSE)) !=
- (KEEP_RECV_PAUSE|KEEP_SEND_PAUSE)) {
-- data->state.drain++;
- Curl_expire(data, 0, EXPIRE_RUN_NOW); /* get this handle going again */
- if(data->multi)
- Curl_update_timer(data->multi);
-diff --git a/lib/transfer.c b/lib/transfer.c
-index 827076183fc..ead8b36db9b 100644
---- a/lib/transfer.c
-+++ b/lib/transfer.c
-@@ -5,7 +5,7 @@
- * | (__| |_| | _ <| |___
- * \___|\___/|_| \_\_____|
- *
-- * Copyright (C) 1998 - 2020, Daniel Stenberg, <daniel@haxx.se>, et al.
-+ * Copyright (C) 1998 - 2019, Daniel Stenberg, <daniel@haxx.se>, et al.
- *
- * This software is licensed as described in the file COPYING, which
- * you should have received as part of this distribution. The terms
-@@ -1217,8 +1217,7 @@ CURLcode Curl_readwrite(struct connectdata *conn,
- else
- fd_write = CURL_SOCKET_BAD;
-
-- if(data->state.drain) {
-- data->state.drain--;
-+ if(conn->data->state.drain) {
- select_res |= CURL_CSELECT_IN;
- DEBUGF(infof(data, "Curl_readwrite: forcibly told to drain data\n"));
- }