aboutsummaryrefslogtreecommitdiffstats
path: root/main/dconf
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-11-21 11:19:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-21 11:20:07 +0000
commitc63718215c0617266f0e70f24fe6a12aeea09af2 (patch)
tree32eb31270b19c7e0583a78c340287bb32ba4ee8e /main/dconf
parent0d9c2d0f49e2feddeaf1a1a8605cd13ef83d490e (diff)
downloadaports-c63718215c0617266f0e70f24fe6a12aeea09af2.tar.bz2
aports-c63718215c0617266f0e70f24fe6a12aeea09af2.tar.xz
main/dconf: fix build with meson-0.52
Diffstat (limited to 'main/dconf')
-rw-r--r--main/dconf/APKBUILD11
-rw-r--r--main/dconf/build-Update-use-of-link_whole-for-meson-0.52.patch35
2 files changed, 40 insertions, 6 deletions
diff --git a/main/dconf/APKBUILD b/main/dconf/APKBUILD
index 854138e4b3..b42e830632 100644
--- a/main/dconf/APKBUILD
+++ b/main/dconf/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=dconf
pkgver=0.34.0
-pkgrel=0
+pkgrel=1
pkgdesc="A low-level configuration system."
url="https://wiki.gnome.org/Projects/dconf"
arch="all"
@@ -11,10 +11,10 @@ makedepends="glib-dev dbus-dev docbook-xsl vala gtk+3.0-dev libxml2-dev meson
py3-setuptools bash-completion"
checkdepends="dbus"
subpackages="$pkgname-dev $pkgname-doc $pkgname-bash-completion:bashcomp:noarch"
-source="https://download.gnome.org/sources/dconf/${pkgver%.*}/dconf-$pkgver.tar.xz"
+source="https://download.gnome.org/sources/dconf/${pkgver%.*}/dconf-$pkgver.tar.xz
+ build-Update-use-of-link_whole-for-meson-0.52.patch"
build() {
- cd "$builddir"
meson \
--prefix=/usr \
--localstatedir=/var \
@@ -24,12 +24,10 @@ build() {
}
check() {
- cd "$builddir"
meson test -C output -t 100
}
package() {
- cd "$builddir"
DESTDIR="$pkgdir" ninja -C output install
}
@@ -41,4 +39,5 @@ bashcomp() {
mv "$pkgdir"/usr/share/bash-completion "$subpkgdir"/usr/share
}
-sha512sums="8b28373f31fe36ba3f21f56fca84563681c3648ff595709880cd9ac49fc6b130ac375fb89fd585f1dd62b5a2f728127292ea57d18feca1147b709a93e8c4c743 dconf-0.34.0.tar.xz"
+sha512sums="8b28373f31fe36ba3f21f56fca84563681c3648ff595709880cd9ac49fc6b130ac375fb89fd585f1dd62b5a2f728127292ea57d18feca1147b709a93e8c4c743 dconf-0.34.0.tar.xz
+1f0e2e77cc8410704590586ee3f6f2cde9e82dc25a6a43ff3a2accaa43b8f26c49bcd0d080ed44d73b56308829a7bf2dc2d7c67f5029a064d7dee9dac061bc83 build-Update-use-of-link_whole-for-meson-0.52.patch"
diff --git a/main/dconf/build-Update-use-of-link_whole-for-meson-0.52.patch b/main/dconf/build-Update-use-of-link_whole-for-meson-0.52.patch
new file mode 100644
index 0000000000..a4e74044f7
--- /dev/null
+++ b/main/dconf/build-Update-use-of-link_whole-for-meson-0.52.patch
@@ -0,0 +1,35 @@
+From cc32667c5d7d9ff95e65cc21f59905d8f9218394 Mon Sep 17 00:00:00 2001
+From: Diego Escalante Urrelo <diegoe@gnome.org>
+Date: Thu, 31 Oct 2019 05:51:22 -0500
+Subject: [PATCH] build: Update use of link_whole for meson-0.52
+
+A regression in meson-0.52 caused uses of link_whole to expose scenarios
+where duplicate symbols issues could appear. In particular
+libdconf_client_dep was being link_whole'd to itself, which recursively
+already included libdconf_common which was also a link_whole.
+
+This change does not modify the available symbols in libdconf.so, and is
+compatible with meson-0.52 and 0.51.
+
+See: https://github.com/mesonbuild/meson/pull/6030
+Fixes: https://gitlab.gnome.org/GNOME/dconf/issues/59
+---
+ client/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/client/meson.build b/client/meson.build
+index f3b7122..de6387e 100644
+--- a/client/meson.build
++++ b/client/meson.build
+@@ -28,7 +28,7 @@ libdconf_client = static_library(
+
+ libdconf_client_dep = declare_dependency(
+ dependencies: gio_dep,
+- link_whole: libdconf_client,
++ link_with: libdconf_client,
+ )
+
+ libdconf = shared_library(
+--
+2.22.0
+