aboutsummaryrefslogtreecommitdiffstats
path: root/main/ddate
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-11-17 12:16:13 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-11-17 12:16:13 +0000
commit7cc06dd1c66f5f6346dc03df443b268944e5a823 (patch)
tree64c08240d29175c16563f9a446885b74a321d861 /main/ddate
parent59269e6ee0cfaf9a952a456c26fc8aafeefd5f63 (diff)
downloadaports-7cc06dd1c66f5f6346dc03df443b268944e5a823.tar.bz2
aports-7cc06dd1c66f5f6346dc03df443b268944e5a823.tar.xz
main/ddate: move from testing
Diffstat (limited to 'main/ddate')
-rw-r--r--main/ddate/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/main/ddate/APKBUILD b/main/ddate/APKBUILD
new file mode 100644
index 0000000000..2f9cb34f64
--- /dev/null
+++ b/main/ddate/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Johannes Matheis <jomat+alpinebuild@jmt.gr>
+# Maintainer: Johannes Matheis <jomat+alpinebuild@jmt.gr>
+pkgname=ddate
+pkgver=0.2.2
+pkgrel=0
+pkgdesc="Convert Gregorian dates to Discordian dates"
+url="https://github.com/bo0ts/ddate"
+arch="all"
+license="Public Domain"
+depends=""
+depends_dev=""
+makedepends="$depends_dev cmake"
+install=""
+subpackages="$pkgname-doc"
+source="${url}/archive/v${pkgver}.tar.gz"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+
+build() {
+ cd "$_builddir"
+ mkdir build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ make PREFIX="/usr"
+}
+
+package() {
+ cd "$_builddir/build"
+ make DESTDIR="${pkgdir}" install
+}
+
+md5sums="154ead3444d60806c97919b4f3d69e19 v0.2.2.tar.gz"
+sha256sums="d53c3f0af845045f39d6d633d295fd4efbe2a792fd0d04d25d44725d11c678ad v0.2.2.tar.gz"
+sha512sums="5d148e030bee392eb93c5ae519061af0736f2f75eaae916e3efaf927d9f4de8cc72afc4a5121b6fbc0264b73e9f580330a38b97bb78837d447d0b4c1fc29ec06 v0.2.2.tar.gz"