aboutsummaryrefslogtreecommitdiffstats
path: root/main/debootstrap
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-01-22 16:30:04 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2018-01-22 16:57:00 +0100
commit07d624c9616fe4c6e11433f0c8d10a8c24a24d07 (patch)
treeb110c15ce263effe3699e4e5ed9200c8321f7a37 /main/debootstrap
parent1514bc02ec9bf28d96333edf6a4b6a394565c34d (diff)
downloadaports-07d624c9616fe4c6e11433f0c8d10a8c24a24d07.tar.bz2
aports-07d624c9616fe4c6e11433f0c8d10a8c24a24d07.tar.xz
main/debootstrap: modernize APKBUILD
Diffstat (limited to 'main/debootstrap')
-rw-r--r--main/debootstrap/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/main/debootstrap/APKBUILD b/main/debootstrap/APKBUILD
index ae91294dc2..912bb041fc 100644
--- a/main/debootstrap/APKBUILD
+++ b/main/debootstrap/APKBUILD
@@ -7,6 +7,7 @@ pkgdesc="Debian/Ubuntu bootstrap scripts"
url="https://packages.qa.debian.org/d/debootstrap.html"
arch="noarch"
license="GPL-2.0"
+options="!check" # upstream doesn't have a test suite
depends="debian-archive-keyring dpkg tar"
makedepends=""
subpackages="$pkgname-doc"
@@ -15,9 +16,9 @@ builddir="$srcdir"/$pkgname-$pkgver
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
install -Dm644 $pkgname.8 \
- "$pkgdir"/usr/share/man/man8/$pkgname.8 || return 1
+ "$pkgdir"/usr/share/man/man8/$pkgname.8
}
sha512sums="42d6cdeb1efbe95d9215522648d87165326ae1b5a024608abd476a6b3889c8c04420a0f29f5eb9cfd2e57adb4aa57a606519b09e356d0442cd4a4a0f6f45f656 debootstrap_1.0.92.tar.gz"