aboutsummaryrefslogtreecommitdiffstats
path: root/main/debootstrap
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-11-10 07:44:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-10 07:44:09 +0000
commit1a6e1ca16c244aa230af319fdab99a93ddb4946e (patch)
tree8d28b9110ef12f92858add8293f05612c1560e7d /main/debootstrap
parent1afadb31117e61ad1d4c83a49367d81bff685a98 (diff)
downloadaports-1a6e1ca16c244aa230af319fdab99a93ddb4946e.tar.bz2
aports-1a6e1ca16c244aa230af319fdab99a93ddb4946e.tar.xz
main/debootstrap: add init-freedom patch
from https://git.devuan.org/d-i/debootstrap/blob/master/debian/patches/init-freedom-668001.patch
Diffstat (limited to 'main/debootstrap')
-rw-r--r--main/debootstrap/APKBUILD6
-rw-r--r--main/debootstrap/init-freedom-668001.patch40
2 files changed, 45 insertions, 1 deletions
diff --git a/main/debootstrap/APKBUILD b/main/debootstrap/APKBUILD
index 45aa7b5d34..ff9f2d5637 100644
--- a/main/debootstrap/APKBUILD
+++ b/main/debootstrap/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=debootstrap
pkgver=1.0.74
-pkgrel=0
+pkgrel=1
pkgdesc="Debian/Ubuntu bootstrap scripts"
url="http://packages.qa.debian.org/d/debootstrap.html"
arch="noarch"
@@ -12,6 +12,7 @@ makedepends=""
install=""
subpackages="$pkgname-doc"
source="ftp://ftp.debian.org/debian/pool/main/d/${pkgname}/${pkgname}_${pkgver}.tar.gz
+ init-freedom-668001.patch
makedev.sh"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -30,8 +31,11 @@ package() {
}
md5sums="4a5c047251a467033ad2fe0415513b14 debootstrap_1.0.74.tar.gz
+6338530a73af092b67da3979ff1cc642 init-freedom-668001.patch
ef5038e52173de7a18c37a0925ccf383 makedev.sh"
sha256sums="ae1d1a8d6212f7721be489608230a185721b798d114f8c56b67c4a5e123586bf debootstrap_1.0.74.tar.gz
+3544d14c4269a52c98171088a067f2cff09765c154114196290640a060248c41 init-freedom-668001.patch
3f26318b59c7697205285d04eb68a4c65905faedd7bbcb4e53e803f9ea8e5c97 makedev.sh"
sha512sums="19c2cbbe66eafab73715f0449d84a689f8f1c766ecb14496e6eb77d792a7950d181d2e1bf9b07c8b27d692f94b8e247174d0a04200fb0404a9f3b17d7a898b83 debootstrap_1.0.74.tar.gz
+8690f5f190451ff981a0c53eb2369d4bdc24a724f16bcb8154b34d3a44de2183227bd2cb4418f1310220aa7b7294d82d4c04f2f238d26d99dcc5427850d74df8 init-freedom-668001.patch
71f1dfe7d785cf5f4b2db7e4de01b5e542b33a1a49194a53665d4d68b5de47fc3c5b37ad2d1a7c37fb14d10c6758fa2fb043bd68a6fbb8b9dba90fb071a9db9c makedev.sh"
diff --git a/main/debootstrap/init-freedom-668001.patch b/main/debootstrap/init-freedom-668001.patch
new file mode 100644
index 0000000000..c9c9eaef65
--- /dev/null
+++ b/main/debootstrap/init-freedom-668001.patch
@@ -0,0 +1,40 @@
+Apply init freedom patch since Debian's maintainer is obstructing a bugfix to honor exclude directive and allow people to avoid having systemd at early stage, see bug 668001 in Debian
+--- a/debootstrap
++++ b/debootstrap
+@@ -51,7 +51,7 @@
+ DEF_MIRROR="http://httpredir.debian.org/debian"
+ DEF_HTTPS_MIRROR="https://mirrors.kernel.org/debian"
+
+-export LANG USE_COMPONENTS
++export LANG USE_COMPONENTS EXCLUDE
+ umask 022
+
+ ###########################################################################
+--- a/functions
++++ b/functions
+@@ -1181,6 +1181,8 @@
+ perl -e '
+ $prevpkg = "";
+ @d = ();
++my %exclude;
++$exclude{$_} = 1 for split(" ", $ENV{"EXCLUDE"});
+ while (<STDIN>) {
+ chomp;
+ if (/^Package: (.*)$/) {
+@@ -1197,9 +1199,13 @@
+ $in = 0 if (/^$/);
+ if ($in and (/^Depends: (.*)$/ or /^Pre-Depends: (.*)$/)) {
+ for $d (split /\s*,\s*/, $1) {
+- $d =~ s/\s*[|].*$//;
+- $d =~ s/\s*[(].*[)]\s*//;
+- push @d, $d;
++ for $p (split /\s*\|\s*/, $d) {
++ $p =~ s/\s*[(].*[)]\s*//;
++ if (!$exclude{$p}) {
++ push @d, $p;
++ last;
++ }
++ }
+ }
+ }
+ }