aboutsummaryrefslogtreecommitdiffstats
path: root/main/dejagnu
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-08-28 08:51:57 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-08-28 08:51:57 +0000
commit7670d5ebbef1f2e3a19f4d05b28b2d4ca5224726 (patch)
tree49f0436583cf804f1370488494b633f5e74363df /main/dejagnu
parent8f9a1a8da1a9186396b4c9a09025f2b9b034ed7e (diff)
downloadaports-7670d5ebbef1f2e3a19f4d05b28b2d4ca5224726.tar.bz2
aports-7670d5ebbef1f2e3a19f4d05b28b2d4ca5224726.tar.xz
main/dejagnu: moved from testing
used in 'check' of main packages
Diffstat (limited to 'main/dejagnu')
-rw-r--r--main/dejagnu/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/main/dejagnu/APKBUILD b/main/dejagnu/APKBUILD
new file mode 100644
index 0000000000..87c264a078
--- /dev/null
+++ b/main/dejagnu/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+
+pkgname=dejagnu
+pkgver=1.6
+pkgrel=1
+pkgdesc="A framework for testing other programs"
+url="https://www.gnu.org/software/dejagnu/"
+arch="noarch"
+license="GPLv3+"
+depends="expect"
+makedepends="tcl>=8.5"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+sha512sums="a494dd5cde8d275b397116049c93e183f5f1731d63660ee8d2f4263b099fc5be7fbddde927fab3ccd5f000c43d50242f94bbb4d95497b915ea53be418bc145bc dejagnu-1.6.tar.gz"