aboutsummaryrefslogtreecommitdiffstats
path: root/main/devicemaster-linux-grsec
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-11-24 16:52:39 +0200
committerTimo Teräs <timo.teras@iki.fi>2016-11-24 16:52:39 +0200
commit479095b94c04073c903df88ffacff25d7dcfedd6 (patch)
treeffc7a04269d7a604d27f9b9971bc263a7f5a622f /main/devicemaster-linux-grsec
parent90997223df3c4782c76959c59ab0131ca2304457 (diff)
downloadaports-479095b94c04073c903df88ffacff25d7dcfedd6.tar.bz2
aports-479095b94c04073c903df88ffacff25d7dcfedd6.tar.xz
main/devicemaster-linux-grsec: fix -fno-pie
Diffstat (limited to 'main/devicemaster-linux-grsec')
-rw-r--r--main/devicemaster-linux-grsec/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/main/devicemaster-linux-grsec/APKBUILD b/main/devicemaster-linux-grsec/APKBUILD
index d9ddc7b128..074ea2af7b 100644
--- a/main/devicemaster-linux-grsec/APKBUILD
+++ b/main/devicemaster-linux-grsec/APKBUILD
@@ -54,7 +54,7 @@ prepare() {
build() {
cd "$srcdir/$_realname-$_realver"
make -C /lib/modules/$_abi_release/build SUBDIRS="$PWD" modules \
- KCFLAGS="-fno-pie" V=1 || return 1
+ CC="${CC:-gcc} -fno-pie" V=1 || return 1
}
package() {