aboutsummaryrefslogtreecommitdiffstats
path: root/main/dhcp
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2018-08-03 20:48:05 -0400
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-08 09:46:19 +0000
commit23fac33a7652137d3ae308436229dd6edb9940f6 (patch)
treee2c1df4e9b45b6a34b3f2a3de02449948562d097 /main/dhcp
parent0a859defe7146331cd48ef213f5b44f5e331ab87 (diff)
downloadaports-23fac33a7652137d3ae308436229dd6edb9940f6.tar.bz2
aports-23fac33a7652137d3ae308436229dd6edb9940f6.tar.xz
main/dhcp: remove bashisms from dhclient-script
Diffstat (limited to 'main/dhcp')
-rw-r--r--main/dhcp/01-dhclient-script-fix-bare-ip.patch (renamed from main/dhcp/dhclient-script-fix-bare-ip.patch)8
-rw-r--r--main/dhcp/02-dhclient-script-remove-bashisms.patch28
-rw-r--r--main/dhcp/APKBUILD8
3 files changed, 34 insertions, 10 deletions
diff --git a/main/dhcp/dhclient-script-fix-bare-ip.patch b/main/dhcp/01-dhclient-script-fix-bare-ip.patch
index 4c8ecc2e4f..7b3165d875 100644
--- a/main/dhcp/dhclient-script-fix-bare-ip.patch
+++ b/main/dhcp/01-dhclient-script-fix-bare-ip.patch
@@ -1,13 +1,7 @@
diff --git a/client/scripts/linux b/client/scripts/linux
-index 0c42969..3214eb6 100755
+index 0c42969..3cd2a75 100755
--- a/client/scripts/linux
+++ b/client/scripts/linux
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
- # dhclient-script for Linux. Dan Halbert, March, 1997.
- # Updated for Linux 2.[12] by Brian J. Murrell, January 1999.
- # No guarantees about this. I'm a novice at the details of Linux
@@ -394,7 +394,7 @@ case "$reason" in
make_resolv_conf
else
diff --git a/main/dhcp/02-dhclient-script-remove-bashisms.patch b/main/dhcp/02-dhclient-script-remove-bashisms.patch
new file mode 100644
index 0000000000..afa10484f9
--- /dev/null
+++ b/main/dhcp/02-dhclient-script-remove-bashisms.patch
@@ -0,0 +1,28 @@
+diff --git a/client/scripts/linux b/client/scripts/linux
+index 0c42969..2e7274b 100755
+--- a/client/scripts/linux
++++ b/client/scripts/linux
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+ # dhclient-script for Linux. Dan Halbert, March, 1997.
+ # Updated for Linux 2.[12] by Brian J. Murrell, January 1999.
+ # No guarantees about this. I'm a novice at the details of Linux
+@@ -428,7 +428,7 @@ case "$reason" in
+ # Check if any IPv6 address on this interface is marked as
+ # tentative.
+ ${ip} addr show ${interface} | grep inet6 | grep tentative \
+- &> /dev/null
++ > /dev/null 2>&1
+ if [ $? -eq 0 ]; then
+ # Wait for duplicate address detection to complete or for
+ # the timeout specified as --dad-wait-time.
+@@ -437,7 +437,7 @@ case "$reason" in
+ # We're going to poll for the tentative flag every second.
+ sleep 1
+ ${ip} addr show ${interface} | grep inet6 | grep tentative \
+- &> /dev/null
++ > /dev/null 2>&1
+ if [ $? -ne 0 ]; then
+ break;
+ fi
diff --git a/main/dhcp/APKBUILD b/main/dhcp/APKBUILD
index 6c6fbd0a32..a8fb8458b8 100644
--- a/main/dhcp/APKBUILD
+++ b/main/dhcp/APKBUILD
@@ -2,7 +2,7 @@
pkgname=dhcp
pkgver=4.4.1
_realver=${pkgver/_p/-P}
-pkgrel=1
+pkgrel=2
pkgdesc="ISC Dynamic Host Configuration Protocol (DHCP)"
url="https://www.isc.org/"
arch="all"
@@ -14,7 +14,8 @@ makedepends="perl linux-headers file"
install="$pkgname.pre-install $pkgname.pre-upgrade $pkgname.post-upgrade"
subpackages="$pkgname-doc $pkgname-dev $pkgname-dbg dhclient dhcrelay"
source="http://ftp.isc.org/isc/$pkgname/${_realver}/$pkgname-$_realver.tar.gz
- dhclient-script-fix-bare-ip.patch
+ 01-dhclient-script-fix-bare-ip.patch
+ 02-dhclient-script-remove-bashisms.patch
dhcp-3.0-fix-perms.patch
dhcrelay.initd
dhcrelay.confd
@@ -88,7 +89,8 @@ dhcrelay() {
}
sha512sums="684ae349f224918c9f8cec7bd6c55cd0b83ad2b5827375b2876ca088eb05b7ff1364e50f6dc24f2485c610d9be94d4ba3020f60a0fa0ef63962349d191b887e7 dhcp-4.4.1.tar.gz
-65ddc66553f6f21184dd82baa929f2414b7374e9bafecc22f0d27a653f66796fbcb3a72d2f52af03a6993ce70e1b8dd0ab4fd630824b9a4825799bec190007fb dhclient-script-fix-bare-ip.patch
+17e2b9588ee5d1bd9acb9c2e30f7a28308d29c9e797c2be14c1feff52e6e231ce8a94535f18badff1342aff4ae4003aab986e0f0473f0cd280292fdab044b148 01-dhclient-script-fix-bare-ip.patch
+a70e4a7e80ee65c8ced6b61db80f7ccd0f35015b5cccf2e7c51705ae129230aa49ba9926bb88f7418018e7a112c2a40451f24b88e04464b590ff20091e8d8709 02-dhclient-script-remove-bashisms.patch
d5697a56fbbff25199962608986e7ffb533ed4afd3e344e3c79d2010dda73cc0b088f06c454e9f0c69eb054e09a374455fa71d3f73306e0c98fa76df4dd321b7 dhcp-3.0-fix-perms.patch
0c3eee11ee9771a3bd7f8076827e57296136a36e6c00c3149e7274fb7a479feae4dc7d744f3c66ac78ffc96f036e14a7a5a0806095495441f98d76737a34faa6 dhcrelay.initd
fd15dbaa4c61c3c26f407bf13dde859470a1adba134da064b653ccc152ce42635ee8de2fe113ae21ba8470e97e3caad8c1a47b69eb25e5e92b40e26790b96f6d dhcrelay.confd