aboutsummaryrefslogtreecommitdiffstats
path: root/main/dhcp
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2019-08-08 17:46:07 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2019-08-21 11:49:34 +0000
commitc23dcd5250df8fdb411330eeadad6c8e5cf3c8c5 (patch)
tree4cc3c9761bf9b00ca58fbc3a05b4d6e3b72a03ca /main/dhcp
parent436d016a6358eefa655743eecc472bb92f191c76 (diff)
downloadaports-c23dcd5250df8fdb411330eeadad6c8e5cf3c8c5.tar.bz2
aports-c23dcd5250df8fdb411330eeadad6c8e5cf3c8c5.tar.xz
main/dhcp: backwards compat
Diffstat (limited to 'main/dhcp')
-rw-r--r--main/dhcp/APKBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/main/dhcp/APKBUILD b/main/dhcp/APKBUILD
index 9e1c402758..305eabf33d 100644
--- a/main/dhcp/APKBUILD
+++ b/main/dhcp/APKBUILD
@@ -193,6 +193,17 @@ dhcrelay() {
mv "$pkgdir"/usr/sbin/dhcrelay "$subpkgdir"/usr/sbin/
}
+# TODO: remove when abuild is sufficiently upgraded
+libs() {
+ depends="$depends_libs"
+ default_libs
+}
+
+static() {
+ depends="$depends_static"
+ default_static || mkdir -p "$subpkgdir"
+}
+
gpg_signature_extensions="sha512.asc"
gpgfingerprints="