aboutsummaryrefslogtreecommitdiffstats
path: root/main/dhcp
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2018-09-04 19:11:58 -0400
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-08 09:46:19 +0000
commitdd87a7c1ac5343263d1a9bc8a307dc04666a65de (patch)
tree0af39cfeef5d2ebed6557691293c1dd9b5598664 /main/dhcp
parent04450f0183af6747be90e73ffb5a909f0fd3e566 (diff)
downloadaports-dd87a7c1ac5343263d1a9bc8a307dc04666a65de.tar.bz2
aports-dd87a7c1ac5343263d1a9bc8a307dc04666a65de.tar.xz
main/dhcp: dhclient-script needs coreutils, iproute2, and run-parts
coreutils: chmod/chown --reference iproute2: /sbin/ip run-parts: run-parts --list
Diffstat (limited to 'main/dhcp')
-rw-r--r--main/dhcp/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/main/dhcp/APKBUILD b/main/dhcp/APKBUILD
index 96af68a6b8..acde03cd01 100644
--- a/main/dhcp/APKBUILD
+++ b/main/dhcp/APKBUILD
@@ -8,9 +8,12 @@ url="https://www.isc.org/"
arch="all"
license="ISC"
depends=
+# busybox utils are not sufficient for dhclient
+depends_dhclient="coreutils iproute2 run-parts $depends_dhclient_optional"
+#depends_dhclient_optional="bash iputils net-tools sed util-linux"
pkgusers="dhcp"
pkggroups="dhcp"
-makedepends="perl linux-headers file"
+makedepends="perl linux-headers file $depends_dhclient $depends_dhclient_optional"
install="$pkgname.pre-install $pkgname.pre-upgrade $pkgname.post-upgrade"
subpackages="$pkgname-doc $pkgname-dev $pkgname-dbg dhclient dhcrelay"
source="http://ftp.isc.org/isc/$pkgname/${_realver}/$pkgname-$_realver.tar.gz
@@ -67,6 +70,7 @@ package() {
dhclient() {
pkgdesc="ISC dhcp client"
+ depends="$depends_dhclient"
install -d -o dhcp -g dhcp "$subpkgdir"/var/lib/dhcp
install -d -o dhcp -g dhcp "$subpkgdir"/var/run/dhcp
install -d "$subpkgdir"/usr/sbin