aboutsummaryrefslogtreecommitdiffstats
path: root/main/dhcp
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-10-27 14:01:27 +0100
committerJakub Jirutka <jakub@jirutka.cz>2019-10-27 15:03:53 +0100
commite22d898e82348cfb5d69ba71234173390b51153c (patch)
tree72378ab04eb24a0be5207ead3eed47ee4a1c7465 /main/dhcp
parent69e408728c957b8ce1c119e44b131a46eb53d447 (diff)
downloadaports-e22d898e82348cfb5d69ba71234173390b51153c.tar.bz2
aports-e22d898e82348cfb5d69ba71234173390b51153c.tar.xz
main/dhcp: change deprecated /var/run to /run
Diffstat (limited to 'main/dhcp')
-rw-r--r--main/dhcp/APKBUILD24
-rwxr-xr-xmain/dhcp/dhcpd.initd6
-rw-r--r--main/dhcp/dhcrelay.initd4
3 files changed, 17 insertions, 17 deletions
diff --git a/main/dhcp/APKBUILD b/main/dhcp/APKBUILD
index ab4c974dbe..991b5cf149 100644
--- a/main/dhcp/APKBUILD
+++ b/main/dhcp/APKBUILD
@@ -2,7 +2,7 @@
pkgname=dhcp
pkgver="4.4.1"
_realver=${pkgver/_p/-P}
-pkgrel=6
+pkgrel=7
pkgdesc="ISC Dynamic Host Configuration Protocol (DHCP)"
url="https://www.isc.org/"
arch="all"
@@ -74,12 +74,12 @@ _configure() {
--with-srv6-lease-file=/var/lib/dhcp/dhcpd6.leases \
--with-cli-lease-file=/var/lib/dhcp/dhclient.leases \
--with-cli6-lease-file=/var/lib/dhcp/dhclient6.leases \
- --with-srv-pid-file=/var/run/dhcp/dhcpd.pid \
- --with-srv6-pid-file=/var/run/dhcp/dhcpd6.pid \
- --with-cli-pid-file=/var/run/dhcp/dhclient.pid \
- --with-cli6-pid-file=/var/run/dhcp/dhclient6.pid \
- --with-relay-pid-file=/var/run/dhcp/dhcrelay.pid \
- --with-relay6-pid-file=/var/run/dhcp/dhcrelay6.pid \
+ --with-srv-pid-file=/run/dhcp/dhcpd.pid \
+ --with-srv6-pid-file=/run/dhcp/dhcpd6.pid \
+ --with-cli-pid-file=/run/dhcp/dhclient.pid \
+ --with-cli6-pid-file=/run/dhcp/dhclient6.pid \
+ --with-relay-pid-file=/run/dhcp/dhcrelay.pid \
+ --with-relay6-pid-file=/run/dhcp/dhcrelay6.pid \
--with-libbind=no \
--enable-dhcpv4o6 \
--enable-paranoia \
@@ -126,7 +126,7 @@ package() {
#install -m751 -D "$builddir"/client/scripts/linux "$pkgdir"/sbin/dhclient-script
install -m751 -D "$srcdir"/dhclient-script-alpine "$pkgdir"/sbin/dhclient-script
install -d "$pkgdir"/var/lib/dhcp
- install -d "$pkgdir"/var/run/dhcp
+ install -d "$pkgdir"/run/dhcp
}
dbg() {
@@ -182,7 +182,7 @@ dhclient() {
depends="$depends_dhclient"
install -d -o dhcp -g dhcp "$subpkgdir"/var/lib/dhcp
- install -d -o dhcp -g dhcp "$subpkgdir"/var/run/dhcp
+ install -d -o dhcp -g dhcp "$subpkgdir"/run/dhcp
install -d "$subpkgdir"/usr/sbin
install -d "$subpkgdir"/sbin
install -d "$subpkgdir"/etc/dhcp
@@ -197,7 +197,7 @@ dhcrelay() {
depends="$depends_dhcrelay"
replaces="dhcp"
- install -d "$subpkgdir"/var/run/dhcp \
+ install -d "$subpkgdir"/run/dhcp \
"$subpkgdir"/usr/sbin
mv "$pkgdir"/usr/sbin/dhcrelay "$subpkgdir"/usr/sbin/
}
@@ -225,7 +225,7 @@ sha512sums="684ae349f224918c9f8cec7bd6c55cd0b83ad2b5827375b2876ca088eb05b7ff1364
a70e4a7e80ee65c8ced6b61db80f7ccd0f35015b5cccf2e7c51705ae129230aa49ba9926bb88f7418018e7a112c2a40451f24b88e04464b590ff20091e8d8709 02-dhclient-script-remove-bashisms.patch
d5697a56fbbff25199962608986e7ffb533ed4afd3e344e3c79d2010dda73cc0b088f06c454e9f0c69eb054e09a374455fa71d3f73306e0c98fa76df4dd321b7 dhcp-3.0-fix-perms.patch
d1dce58875793316761f168e29feddc1d3454d1d917d063d43ae102b7b6aab256c3cb420478335c57ebcdb2b7c804afa4d8a1f9ab06a29a4dd23bc5d87db8df2 dhclient-script-alpine
-2fcb8e729e55d2917d309758b0a0409f4150a4088af72a5cefc58919f5d9da9d3ada1249f0d856dad71bfa6701af74cb73f08dc176ff917bf7fb8c9a80002ca3 dhcrelay.initd
+ce62693cb483616844bb6774f9046af6a1a210e35cfaa59ab3bd12f68d50176714a324e92538b35139110b78191866f65b30d6979d8a45f7b68e572e7a1e8427 dhcrelay.initd
fd15dbaa4c61c3c26f407bf13dde859470a1adba134da064b653ccc152ce42635ee8de2fe113ae21ba8470e97e3caad8c1a47b69eb25e5e92b40e26790b96f6d dhcrelay.confd
7b7a77b7826b475a4113ebeee54501ce417cc56e85754301a82a185d88b4713d198f615a366e63e0e2b0aef988c8137dcd1e18c4036d993378257079da17693d dhcpd.confd
-96ebc64e7c8a484133c23e9d1d7afe965247aaf54bc619b4fa81ed80f56b6bdb7e2c22d3f26db4c87c2a6ffd29ae2db6408954feac4c2104df712975cdfccc60 dhcpd.initd"
+1f78c4f64a891012b4de029c50934b284ad80313959e06b0f29416f33a9e4f0deca8b61e9224a683a92faf8a08e8b7c075bc6e833ab73b6305c0d6d9712d0baf dhcpd.initd"
diff --git a/main/dhcp/dhcpd.initd b/main/dhcp/dhcpd.initd
index f017a5d861..f69ae71dee 100755
--- a/main/dhcp/dhcpd.initd
+++ b/main/dhcp/dhcpd.initd
@@ -56,7 +56,7 @@ start() {
if [ -n "${chroot}" ] ; then
# the config test want's these to exist
mkdir -p \
- "${chroot}"/var/run/dhcp \
+ "${chroot}"/run/dhcp \
"${chroot}"/var/lib/dhcp \
"${chroot}"/etc/dhcp
fi
@@ -69,7 +69,7 @@ start() {
checkconfig || return 1
- checkpath -d -o dhcp:dhcp "${chroot}"/var/run/dhcp "${chroot}"/var/lib/dhcp
+ checkpath -d -o dhcp:dhcp "${chroot}"/run/dhcp "${chroot}"/var/lib/dhcp
local leasefile="$(get_var lease-file-name /var/lib/dhcp/${SVCNAME}.leases)"
checkpath -f -o dhcp:dhcp "${chroot}${leasefile}"
@@ -84,7 +84,7 @@ start() {
fi
fi
- local pidfile="$(get_var pid-file-name /var/run/dhcp/${SVCNAME}.pid)"
+ local pidfile="$(get_var pid-file-name /run/dhcp/${SVCNAME}.pid)"
ebegin "Starting ${chroot:+chrooted }${SVCNAME}"
start-stop-daemon --start --exec /usr/sbin/dhcpd \
diff --git a/main/dhcp/dhcrelay.initd b/main/dhcp/dhcrelay.initd
index 10323d065d..2dc6b56cf1 100644
--- a/main/dhcp/dhcrelay.initd
+++ b/main/dhcp/dhcrelay.initd
@@ -20,7 +20,7 @@ start() {
IFACES="${IFACES} -i ${i}"
done
- checkpath --directory --owner dhcp:dhcp /var/run/dhcp
+ checkpath --directory --owner dhcp:dhcp /run/dhcp
ebegin "Starting dhcrelay"
start-stop-daemon --start --exec /usr/sbin/dhcrelay \
@@ -30,6 +30,6 @@ start() {
stop() {
ebegin "Stopping dhcrelay"
- start-stop-daemon --stop --pidfile /var/run/dhcp/dhcrelay.pid
+ start-stop-daemon --stop --pidfile /run/dhcp/dhcrelay.pid
eend $?
}