aboutsummaryrefslogtreecommitdiffstats
path: root/main/diffutils
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-05 16:33:24 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-07 05:00:06 +0000
commit450d0f8d8648eae6bdc0ca00353d74a75d0ee697 (patch)
tree32c12449aaacd14794727e497d24b6e28fe879c4 /main/diffutils
parentfdc2da322d1870f41e3d62c2b3d8e5e27d23f7ea (diff)
downloadaports-450d0f8d8648eae6bdc0ca00353d74a75d0ee697.tar.bz2
aports-450d0f8d8648eae6bdc0ca00353d74a75d0ee697.tar.xz
main/diffutils: fix test suite
Diffstat (limited to 'main/diffutils')
-rw-r--r--main/diffutils/APKBUILD10
-rw-r--r--main/diffutils/disable-mbrtowc-test.patch10
2 files changed, 16 insertions, 4 deletions
diff --git a/main/diffutils/APKBUILD b/main/diffutils/APKBUILD
index 3a37644002..293d56205f 100644
--- a/main/diffutils/APKBUILD
+++ b/main/diffutils/APKBUILD
@@ -1,14 +1,15 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=diffutils
pkgver=3.6
-pkgrel=0
+pkgrel=1
pkgdesc="Show differences among files"
subpackages="$pkgname-doc"
url="https://www.gnu.org/software/diffutils/"
arch="all"
license="GPL-3.0-or-later"
-options="!check"
-source="http://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz"
+source="http://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz
+ disable-mbrtowc-test.patch
+ "
builddir=$srcdir/$pkgname-$pkgver
prepare() {
@@ -45,4 +46,5 @@ package() {
rmdir -p "$pkgdir"/usr/lib 2>/dev/null || true
}
-sha512sums="3c159ff1cb7c901b0a57518483566b5740ca3c45aeb8d3004089f052975481db52994cc18592c502c68b0d2a1e22f1f7830f0d8dd9a9ed86de96e28cce9f70c1 diffutils-3.6.tar.xz"
+sha512sums="3c159ff1cb7c901b0a57518483566b5740ca3c45aeb8d3004089f052975481db52994cc18592c502c68b0d2a1e22f1f7830f0d8dd9a9ed86de96e28cce9f70c1 diffutils-3.6.tar.xz
+2602dabf0ac52a273b84160032416613da7ad111541fe25466cf9d4ce1eb2630f0ba0cb0b3013967965d8359a11a5f390f0486b4526b35516d9de1c8975f720d disable-mbrtowc-test.patch"
diff --git a/main/diffutils/disable-mbrtowc-test.patch b/main/diffutils/disable-mbrtowc-test.patch
new file mode 100644
index 0000000000..1461a40939
--- /dev/null
+++ b/main/diffutils/disable-mbrtowc-test.patch
@@ -0,0 +1,10 @@
+--- diffutils-3.6/gnulib-tests/test-mbrtowc5.sh.old 2016-12-31 13:54:43.000000000 +0000
++++ diffutils-3.6/gnulib-tests/test-mbrtowc5.sh 2017-07-30 17:29:50.879924130 +0000
+@@ -1,6 +1,2 @@
+ #!/bin/sh
+-# Test whether the POSIX locale has encoding errors.
+-LC_ALL=C \
+-./test-mbrtowc${EXEEXT} 5 || exit
+-LC_ALL=POSIX \
+-./test-mbrtowc${EXEEXT} 5
++exit 77