aboutsummaryrefslogtreecommitdiffstats
path: root/main/dmidecode
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-12-15 08:28:06 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-12-15 08:29:38 +0000
commit3f3611400168d726e5b84f79fb049b06d19525b1 (patch)
tree727b15ab501f0b00b57723f2ca4abda252538624 /main/dmidecode
parentc9f91c97345006458b202aa98b35ebd0734f3f3d (diff)
downloadaports-3f3611400168d726e5b84f79fb049b06d19525b1.tar.bz2
aports-3f3611400168d726e5b84f79fb049b06d19525b1.tar.xz
main/dmidecode: moved from testing
flashrom needs it
Diffstat (limited to 'main/dmidecode')
-rw-r--r--main/dmidecode/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/main/dmidecode/APKBUILD b/main/dmidecode/APKBUILD
new file mode 100644
index 0000000000..4bd71ec26a
--- /dev/null
+++ b/main/dmidecode/APKBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Nathan Angelacos <nangel@alpinelinux.org>
+pkgname=dmidecode
+pkgver=2.9
+pkgrel=0
+pkgdesc="A utility for reporting system hardware as described by BIOS"
+url="http://www.nongnu.org/dmidecode"
+arch="x86 x86_64"
+license="GPL"
+depends=
+makedepends=
+subpackages="$pkgname-doc"
+source="http://mirror.its.uidaho.edu/pub/savannah/dmidecode/dmidecode-${pkgver}.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+ for i in "$srcdir"/*.patch; do
+ [ -f "$i" ] || continue
+ msg "Applying $i"
+ patch -p1 -i "$i" || return 1
+ done
+ sed '/^PROGRAMS !=/d' -i Makefile
+}
+
+build() {
+ cd "$_builddir"
+ make prefix=/usr || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make prefix=/usr DESTDIR="${pkgdir}" install
+}
+
+md5sums="1f804692168178c19a8ec86d147fbc77 dmidecode-2.9.tar.gz"