aboutsummaryrefslogtreecommitdiffstats
path: root/main/dnsmasq
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2018-11-16 14:24:18 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-11-16 14:24:18 +0000
commit0b0f3b1d3493fb7973f57be6e445f97594e93127 (patch)
treed1ec844c35100e991fae09b1b8eaf32c4cd61041 /main/dnsmasq
parentb42a995a6683ff97db517eadaa75cc12fdfd77fd (diff)
downloadaports-0b0f3b1d3493fb7973f57be6e445f97594e93127.tar.bz2
aports-0b0f3b1d3493fb7973f57be6e445f97594e93127.tar.xz
main/dnsmasq: add BRIDGE_ADDR_EXTRA support to initd
Diffstat (limited to 'main/dnsmasq')
-rw-r--r--main/dnsmasq/APKBUILD2
-rw-r--r--main/dnsmasq/dnsmasq.initd8
2 files changed, 6 insertions, 4 deletions
diff --git a/main/dnsmasq/APKBUILD b/main/dnsmasq/APKBUILD
index 022c712349..136453c62d 100644
--- a/main/dnsmasq/APKBUILD
+++ b/main/dnsmasq/APKBUILD
@@ -15,7 +15,7 @@
#
pkgname=dnsmasq
pkgver=2.80
-pkgrel=0
+pkgrel=1
pkgdesc="A lightweight DNS, DHCP, RA, TFTP and PXE server"
url="http://www.thekelleys.org.uk/dnsmasq/"
arch="all"
diff --git a/main/dnsmasq/dnsmasq.initd b/main/dnsmasq/dnsmasq.initd
index 2932b03e3a..141ed5b682 100644
--- a/main/dnsmasq/dnsmasq.initd
+++ b/main/dnsmasq/dnsmasq.initd
@@ -52,9 +52,11 @@ setup_bridge() {
if ! [ -d /sys/class/net/$BRIDGE ]; then
ip link add dev $BRIDGE type bridge
fi
- ip addr add ${BRIDGE_ADDR}/${BRIDGE_NETMASK} dev $BRIDGE \
- && ip link set dev $BRIDGE address ${BRIDGE_MAC} \
- && ip link set dev $BRIDGE up
+
+ ip link set dev $BRIDGE address ${BRIDGE_MAC} && \
+ for ADDR in $BRIDGE_ADDR $BRIDGE_ADDR_EXTRA; do
+ ip addr add ${ADDR}/${BRIDGE_NETMASK} dev $BRIDGE
+ done && ip link set dev $BRIDGE up
echo 1 > /proc/sys/net/ipv4/ip_forward
echo 0 > /proc/sys/net/ipv6/conf/${BRIDGE}/accept_dad || true