aboutsummaryrefslogtreecommitdiffstats
path: root/main/dnsmasq
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-14 20:36:15 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-03-14 20:36:58 +0100
commit0e6ea7ecafddbbe62b6e2773eb7d434f9b222145 (patch)
tree9b1aed275fd977f172e3cb85dbbb4787d56df971 /main/dnsmasq
parent6d270b6f0ac1f6cff19c94a359dc8e5798125682 (diff)
downloadaports-0e6ea7ecafddbbe62b6e2773eb7d434f9b222145.tar.bz2
aports-0e6ea7ecafddbbe62b6e2773eb7d434f9b222145.tar.xz
main/dnsmasq: add check() with just very basic test
Diffstat (limited to 'main/dnsmasq')
-rw-r--r--main/dnsmasq/APKBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/main/dnsmasq/APKBUILD b/main/dnsmasq/APKBUILD
index 54886b328f..5db1374063 100644
--- a/main/dnsmasq/APKBUILD
+++ b/main/dnsmasq/APKBUILD
@@ -22,6 +22,13 @@ build() {
make PREFIX=/usr CFLAGS="$CFLAGS" all || return 1
}
+# dnsmasq doesn't provide any test suite (shame on them!), so just check that
+# the binary isn't totally broken...
+check() {
+ cd "$builddir"
+ ./src/dnsmasq --help >/dev/null
+}
+
package() {
cd "$builddir"