aboutsummaryrefslogtreecommitdiffstats
path: root/main/dnsmasq
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2017-10-25 14:25:00 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2017-10-25 14:25:00 +0200
commitcedb54387820205e980d3a6155009762fc7c5ce4 (patch)
tree2bfa15f676713a657e08befe40efda27ecb92c5f /main/dnsmasq
parent5804348e91d7037ee5e54a4f1cdc882651a8ccd8 (diff)
downloadaports-cedb54387820205e980d3a6155009762fc7c5ce4.tar.bz2
aports-cedb54387820205e980d3a6155009762fc7c5ce4.tar.xz
main/dnsmasq: allow disable iptables and fix bridge
Diffstat (limited to 'main/dnsmasq')
-rw-r--r--main/dnsmasq/APKBUILD4
-rw-r--r--main/dnsmasq/dnsmasq.initd9
2 files changed, 9 insertions, 4 deletions
diff --git a/main/dnsmasq/APKBUILD b/main/dnsmasq/APKBUILD
index c18674a16c..3644d718f9 100644
--- a/main/dnsmasq/APKBUILD
+++ b/main/dnsmasq/APKBUILD
@@ -13,7 +13,7 @@
#
pkgname=dnsmasq
pkgver=2.78
-pkgrel=0
+pkgrel=1
pkgdesc="A lightweight DNS, DHCP, RA, TFTP and PXE server"
url="http://www.thekelleys.org.uk/dnsmasq/"
arch="all"
@@ -75,6 +75,6 @@ dnssec() {
}
sha512sums="980a6d836566d97cca6d744bee748ffb7bb63cca9455334cb923edefc0bf6aa24d513a9082575472f6d5762adae7b045dd48b3ae6fcee852fbda623fe6a918a5 dnsmasq-2.78.tar.gz
-b07055d71e535f753aff432124812fbef86cc2f490ff2a4704959c34b0f69caa74791a4ad08b2b8638c9126233591d3a86c188965eb1308e7e7c12dc0039d1ad dnsmasq.initd
+fe6155ff79f06d1813b5c65eb00c69ed41749882ce9f8458da95797c8d870b635aa1df04335cdab068018432c74b87e2166096fcf60597f1c4594279f31c38e6 dnsmasq.initd
9a401bfc408bf1638645c61b8ca734bea0a09ef79fb36648ec7ef21666257234254bbe6c73c82cc23aa1779ddcdda0e6baa2c041866f16dfb9c4e0ba9133eab8 dnsmasq.confd
d01077f39e1240041a6700137810f254daf683b2d58dafecb6b162e94d694992e57d45964a57993b298f97c2b589eedcf9fb1506692730a38b7f06b5f55ba8d8 uncomment-conf-dir.patch"
diff --git a/main/dnsmasq/dnsmasq.initd b/main/dnsmasq/dnsmasq.initd
index f5114fb806..a16c206a8f 100644
--- a/main/dnsmasq/dnsmasq.initd
+++ b/main/dnsmasq/dnsmasq.initd
@@ -83,14 +83,19 @@ start_pre() {
fi
setup_bridge
- setup_firewall -I -A
+ if [ -z "$DISABLE_IPTABLES" ]; then
+ setup_firewall -I -A
+ fi
command_args="$command_args --strict-order --bind-interfaces --listen-address ${BRIDGE_ADDR} --except-interface=lo --interface=$BRIDGE --dhcp-range $BRIDGE_DHCP_RANGE --dhcp-lease-max=$BRIDGE_DHCP_MAX --dhcp-no-override --dhcp-leasefile=$leasefile --dhcp-authoritative"
}
stop_post() {
if [ -n "$BRIDGE" ]; then
+ ip addr del ${BRIDGE_ADDR}/${BRIDGE_NETMASK} dev $BRIDGE
ip link set dev $BRIDGE down
- setup_firewall -D -D
+ if [ -z "$DISABLE_IPTABLES" ]; then
+ setup_firewall -D -D
+ fi
# dont destroy if there are attached interfaces
ls /sys/class/net/${BRIDGE}/brif/* > /dev/null 2>&1 || ip link delete ${BRIDGE}
fi