aboutsummaryrefslogtreecommitdiffstats
path: root/main/dnstop
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-05-28 07:34:45 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-05-28 07:34:45 +0000
commit37d1b93c8046e53ba312346bdb3cdd5893ea1c58 (patch)
tree4cfd7d86e7476f2da6f9b861e44c7f10d3c109c4 /main/dnstop
parent0fd45268fb1a536c75d0b1db1f0e7cc9f7f5fb5e (diff)
downloadaports-37d1b93c8046e53ba312346bdb3cdd5893ea1c58.tar.bz2
aports-37d1b93c8046e53ba312346bdb3cdd5893ea1c58.tar.xz
main/dnstop: moved from testing
fixes #2890
Diffstat (limited to 'main/dnstop')
-rw-r--r--main/dnstop/APKBUILD53
-rw-r--r--main/dnstop/musl-fix.patch11
2 files changed, 64 insertions, 0 deletions
diff --git a/main/dnstop/APKBUILD b/main/dnstop/APKBUILD
new file mode 100644
index 0000000000..a7277ff89f
--- /dev/null
+++ b/main/dnstop/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=dnstop
+pkgver=20121017
+pkgrel=0
+pkgdesc="A DNS traffic capture utility"
+url="http://dns.measurement-factory.com/tools/dnstop/"
+arch="all"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends="libpcap-dev ncurses-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://dns.measurement-factory.com/tools/dnstop/src/$pkgname-$pkgver.tar.gz
+ musl-fix.patch
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/bin "$pkgdir"/usr/share/man/man8
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="0407f08e5788b59268048d00cdddd5b6 dnstop-20121017.tar.gz
+a27ac0ddcc33c73d8104ca19cefc99b4 musl-fix.patch"
+sha256sums="6aed2d6037ab94244c4b802a412f902034be3448431b2118cd0e6afe1bf959f6 dnstop-20121017.tar.gz
+79442a058fd3679d01b8c5e0248a549ca2863e5522ae833a10a42f6c83d8fdd8 musl-fix.patch"
+sha512sums="efe0abdd87d14aa8bdc74dad4a5a4d613110e0a78ee7034ecf6d4a7e2037f1895c776761d70127c021ba207dffbc7e1cb551ec55f62b54f93babcd38f21cd44a dnstop-20121017.tar.gz
+8b1bcfb73f7acf8ab264f44a9fb3bb5bdc7b6beec3ea87ecf9d82898e83c5bd6e43bb12f6d72a9fe362c21210c4c2461c32bb23de03a938f20e2d7f0629f3a3d musl-fix.patch"
diff --git a/main/dnstop/musl-fix.patch b/main/dnstop/musl-fix.patch
new file mode 100644
index 0000000000..8b4cd98ea7
--- /dev/null
+++ b/main/dnstop/musl-fix.patch
@@ -0,0 +1,11 @@
+--- ./dnstop.c.orig
++++ ./dnstop.c
+@@ -69,7 +69,7 @@
+ #define ETHERTYPE_IPV6 0x86DD
+ #endif
+
+-#if defined(__linux__) || defined(__GLIBC__) || defined(__GNU__)
++#if defined(__GLIBC__) || defined(__GNU__)
+ #define uh_dport dest
+ #define uh_sport source
+ #endif