aboutsummaryrefslogtreecommitdiffstats
path: root/main/docbook2x
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2016-05-11 13:41:37 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2016-05-11 13:41:37 +0000
commit750af00abb5efcca217593cd6a3d04ebbc07ade2 (patch)
tree007f2de1afd5c9f0ce3e080dc16e78b2603c80ea /main/docbook2x
parent7b3e70f7dceb79e2cec39840f7195e3b2bdd40de (diff)
downloadaports-750af00abb5efcca217593cd6a3d04ebbc07ade2.tar.bz2
aports-750af00abb5efcca217593cd6a3d04ebbc07ade2.tar.xz
main/docbook2x: move to main
Diffstat (limited to 'main/docbook2x')
-rw-r--r--main/docbook2x/01_fix_static_datadir_evaluation.patch19
-rw-r--r--main/docbook2x/02_fix_418703_dont_use_abbreviated_sfnet_address.patch27
-rw-r--r--main/docbook2x/03_fix_420153_filename_whitespace_handling.patch43
-rw-r--r--main/docbook2x/04_fix_442782_preprocessor_declaration_syntax.patch90
-rw-r--r--main/docbook2x/05_fix_439214_error_on_missing_refentry.patch33
-rw-r--r--main/docbook2x/06_fix_man_typo.patch24
-rw-r--r--main/docbook2x/APKBUILD75
7 files changed, 311 insertions, 0 deletions
diff --git a/main/docbook2x/01_fix_static_datadir_evaluation.patch b/main/docbook2x/01_fix_static_datadir_evaluation.patch
new file mode 100644
index 0000000000..5241dc30a7
--- /dev/null
+++ b/main/docbook2x/01_fix_static_datadir_evaluation.patch
@@ -0,0 +1,19 @@
+Description:
+ 01_fix_static_datadir_evaluation.dpatch by Daniel Leidert (dale) <daniel.leidert@wgdd.de>
+ All lines beginning with `## DP:' are a description of the patch.
+ The evaluation of datadir results in "${prefix}/share" without
+ evaluation of the ${prefix} variable with autoconf 2.60.
+
+Index: docbook2X-0.8.8/configure.ac
+===================================================================
+--- docbook2X-0.8.8.orig/configure.ac
++++ docbook2X-0.8.8/configure.ac
+@@ -148,7 +148,7 @@
+ dnl they will reside and should use these static_* values.
+ dnl Ensure that all static_* are fully expanded.
+
+-eval static_datadir="$datadir"
++eval eval static_datadir="$datadir"
+
+ eval static_bindir="$bindir"
+ old_val=""
diff --git a/main/docbook2x/02_fix_418703_dont_use_abbreviated_sfnet_address.patch b/main/docbook2x/02_fix_418703_dont_use_abbreviated_sfnet_address.patch
new file mode 100644
index 0000000000..681047a0af
--- /dev/null
+++ b/main/docbook2x/02_fix_418703_dont_use_abbreviated_sfnet_address.patch
@@ -0,0 +1,27 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 02_fix_418703_dont_use_abbreviated_sfnet_address.dpatch by Daniel Leidert (dale) <daniel.leidert@wgdd.de>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Ondrej Certik reported a resolver issue: http://bugs.debian.org/418703.
+## DP: The error seems to be caused by using the abbreviated sf.net URLs. But
+## DP: it is possible, that this issue only occurs together with the issue
+## DP: described in 01_fix_static_datadir_evaluation.dpatch, because the path
+## DP: to the catalog also suffers from this issue.
+
+@DPATCH@
+diff -urNad docbook2x-0.8.8~/perl/db2x_xsltproc.pl docbook2x-0.8.8/perl/db2x_xsltproc.pl
+--- docbook2x-0.8.8~/perl/db2x_xsltproc.pl 2004-08-18 16:21:52.000000000 +0200
++++ docbook2x-0.8.8/perl/db2x_xsltproc.pl 2007-04-12 16:07:20.000000000 +0200
+@@ -110,10 +110,10 @@
+
+ if($options->{'stylesheet'} eq 'texi') {
+ $options->{'stylesheet'} =
+- "http://docbook2x.sf.net/latest/xslt/texi/docbook.xsl";
++ "http://docbook2x.sourceforge.net/latest/xslt/texi/docbook.xsl";
+ } elsif($options->{'stylesheet'} eq 'man') {
+ $options->{'stylesheet'} =
+- "http://docbook2x.sf.net/latest/xslt/man/docbook.xsl";
++ "http://docbook2x.sourceforge.net/latest/xslt/man/docbook.xsl";
+ }
+
+ if(scalar(@argv) != 1) {
diff --git a/main/docbook2x/03_fix_420153_filename_whitespace_handling.patch b/main/docbook2x/03_fix_420153_filename_whitespace_handling.patch
new file mode 100644
index 0000000000..26cdf8e1ba
--- /dev/null
+++ b/main/docbook2x/03_fix_420153_filename_whitespace_handling.patch
@@ -0,0 +1,43 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 03_fix_420153_filename_whitespace_handling.dpatch by
+## Daniel Leidert (dale) <daniel.leidert@wgdd.de>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Peter Eisentraut reported a regression in the whitespace handling of
+## DP: refentrytitle content during filename creation:
+## DP: http://bugs.debian.org/420153. The problem is, that upstream first
+## DP: replaces all spaces (but not linebreaks btw) with underlines and then
+## DP: it tries to normalize the result. This means, that a linebreak with
+## DP: additional whitespaces results in manpage names like 'foo_ ____bar.9'.
+## DP: So what we basically do in this patch is, that we first normalize the
+## DP: refentrytitle and then replace any spaces left with underlines.
+
+@DPATCH@
+diff -urNad docbook2x-0.8.8~/xslt/man/manpage.xsl docbook2x-0.8.8/xslt/man/manpage.xsl
+--- docbook2x-0.8.8~/xslt/man/manpage.xsl 2006-04-20 15:45:55.000000000 +0200
++++ docbook2x-0.8.8/xslt/man/manpage.xsl 2007-04-20 16:19:28.000000000 +0200
+@@ -30,7 +30,7 @@
+
+ <xsl:template name="manpage-filename">
+ <xsl:param name="filename" />
+- <xsl:value-of select="normalize-space(translate($filename, &quot; /&quot;, &quot;__&quot;))" />
++ <xsl:value-of select="translate(normalize-space($filename), ' /', '__')" />
+ </xsl:template>
+
+
+diff -urNad docbook2x-0.8.8~/xslt/man/refentry.xsl docbook2x-0.8.8/xslt/man/refentry.xsl
+--- docbook2x-0.8.8~/xslt/man/refentry.xsl 2006-04-21 04:39:55.000000000 +0200
++++ docbook2x-0.8.8/xslt/man/refentry.xsl 2007-04-20 16:21:53.000000000 +0200
+@@ -38,7 +38,11 @@
+ <xsl:template name="refentry-filename">
+ <xsl:param name="title" />
+
+- <xsl:variable name="title2" select="translate($title, &quot; /&quot;, &quot;__&quot;)" />
++ <xsl:variable name="title2">
++ <xsl:call-template name="manpage-filename">
++ <xsl:with-param name="filename" select="$title" />
++ </xsl:call-template>
++ </xsl:variable>
+
+ <!-- not using gentext here since man page names tend not to have
+ accented chars / non-Latin chars ...
diff --git a/main/docbook2x/04_fix_442782_preprocessor_declaration_syntax.patch b/main/docbook2x/04_fix_442782_preprocessor_declaration_syntax.patch
new file mode 100644
index 0000000000..b6ddbfa2a0
--- /dev/null
+++ b/main/docbook2x/04_fix_442782_preprocessor_declaration_syntax.patch
@@ -0,0 +1,90 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 04_fix_442782_preprocessor_declaration_syntax.dpatch by Colin Watson <cjwatson@debian.org>.
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Conventionally, preprocessor declarations should start with
+## DP: '\"
+## DP: rather than
+## DP: .\"
+## DP: Current man-db only supports the first (and recommended) syntax. So
+## DP: Colin Watson provided this patch to fix docbook2x.
+## DP:
+## DP: <URL:http://bugs.debian.org/442782>
+## DP: <URL:http://lists.gnu.org/archive/html/groff/2007-11/msg00023.html>
+
+@DPATCH@
+diff -urNad trunk~/perl/db2x_manxml.pl trunk/perl/db2x_manxml.pl
+--- trunk~/perl/db2x_manxml.pl 2006-04-22 17:21:32.000000000 +0200
++++ trunk/perl/db2x_manxml.pl 2007-11-24 01:27:37.000000000 +0100
+@@ -342,6 +342,25 @@
+ $self->{line_start} = 1;
+ }
+
++#
++# Print a comment in the output, without causing a break.
++# Params: comment - the comment text.
++# May use any characters; they need not be escaped.
++#
++sub comment_nobreak
++{
++ my ($self, $comment) = @_;
++ $self->write("\n") unless $self->{line_start};
++
++ foreach my $line (split(/\n/, $comment)) {
++ $self->write('\'\" ');
++ $self->write($line);
++ $self->write("\n");
++ }
++
++ $self->{line_start} = 1;
++}
++
+
+ #
+ # Use a roff "escape" i.e. commands embedded in text starting with \
+@@ -510,16 +529,20 @@
+
+ $self->{'adjust-stack'} = [ 'b' ];
+
+- $self->{rw}->comment($elem->attr('preprocessors'))
+- if($elem->attr('preprocessors') ne '');
+-
++ my $preprocessors = $elem->attr('preprocessors');
+ # I've dug through the Internet to see if there was any
+ # standard way to specify encoding with man pages.
+ # The following seems to be a reasonable proposal:
+ # <URL:http://mail.nl.linux.org/linux-utf8/2001-04/msg00168.html>
+ my $encoding = $self->{options}->{'encoding'};
+ $encoding =~ s#//TRANSLIT$##i;
+- $self->{rw}->comment("-*- coding: $encoding -*-");
++ $encoding = "-*- coding: $encoding -*-";
++ if ($preprocessors eq '') {
++ $preprocessors = $encoding;
++ } else {
++ $preprocessors = "$preprocessors $encoding";
++ }
++ $self->{rw}->comment_nobreak($preprocessors);
+
+ # Define escapes for switching to and from monospace fonts (groff only)
+ $self->{rw}->request(qw{ .if \n(.g .ds T< \\\\FC});
+diff -urNad trunk~/xslt/backend/db2x_manxml.xsl trunk/xslt/backend/db2x_manxml.xsl
+--- trunk~/xslt/backend/db2x_manxml.xsl 2006-04-23 16:44:52.000000000 +0200
++++ trunk/xslt/backend/db2x_manxml.xsl 2007-11-24 01:27:37.000000000 +0100
+@@ -528,7 +528,7 @@
+ <exslt:document method="text"
+ encoding="{$encoding}"
+ href="{$path}">
+- <xsl:text>.\" -*- coding: </xsl:text>
++ <xsl:text>'\" -*- coding: </xsl:text>
+ <xsl:value-of select="$encoding" />
+ <xsl:text> -*-&#10;</xsl:text>
+ <xsl:copy-of select="$content" />
+@@ -538,7 +538,7 @@
+ <saxon:output method="text"
+ encoding="{$encoding}"
+ href="{$path}">
+- <xsl:text>.\" -*- coding: </xsl:text>
++ <xsl:text>'\" -*- coding: </xsl:text>
+ <xsl:value-of select="$encoding" />
+ <xsl:text> -*-&#10;</xsl:text>
+ <xsl:copy-of select="$content" />
diff --git a/main/docbook2x/05_fix_439214_error_on_missing_refentry.patch b/main/docbook2x/05_fix_439214_error_on_missing_refentry.patch
new file mode 100644
index 0000000000..b8a493be2f
--- /dev/null
+++ b/main/docbook2x/05_fix_439214_error_on_missing_refentry.patch
@@ -0,0 +1,33 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 05_fix_439214_error_on_missing_refentry.dpatch by Daniel Leidert <daniel.leidert@wgdd.de>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: If there is no refentry element, the manpage stylesheets silently
+## DP: "ignores" this. It has been requested to print at least a
+## DP: warning.
+## DP:
+## DP: <URL:http://bugs.debian.org/439214>
+## DP: <URL:http://lists.gnu.org/archive/html/groff/2007-11/msg00023.html>
+
+@DPATCH@
+diff -urNad trunk~/xslt/man/docbook.xsl trunk/xslt/man/docbook.xsl
+--- trunk~/xslt/man/docbook.xsl 2006-04-11 21:00:19.000000000 +0200
++++ trunk/xslt/man/docbook.xsl 2008-02-05 03:31:48.000000000 +0100
+@@ -111,11 +111,15 @@
+ <xsl:when test="child::refentry">
+ <xsl:apply-templates />
+ </xsl:when>
+-
+- <xsl:otherwise>
++ <xsl:when test="descendant-or-self::refentry">
+ <manpageset>
+ <xsl:apply-templates select="descendant-or-self::refentry" />
+ </manpageset>
++ </xsl:when>
++ <xsl:otherwise>
++ <xsl:message terminate="no">
++ <xsl:text>WARNING: Sorry, but I cannot find a refentry element in your source!</xsl:text>
++ </xsl:message>
+ </xsl:otherwise>
+ </xsl:choose>
+ </xsl:template>
diff --git a/main/docbook2x/06_fix_man_typo.patch b/main/docbook2x/06_fix_man_typo.patch
new file mode 100644
index 0000000000..5be21bdf9b
--- /dev/null
+++ b/main/docbook2x/06_fix_man_typo.patch
@@ -0,0 +1,24 @@
+Author: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
+
+--- docbook2x-0.8.8.orig/doc/docbook2man.1
++++ docbook2x-0.8.8/doc/docbook2man.1
+@@ -187,7 +187,7 @@ parameter instead.
+
+ However, inside a custom stylesheet
+ (\fInot on the command-line\fR)
+-this paramter can be set to the XPath expression
++this parameter can be set to the XPath expression
+ \*(T<document('')\*(T>,
+ which will cause the custom translations
+ directly embedded inside the custom stylesheet to be read.
+--- docbook2x-0.8.8.orig/doc/docbook2texi.1
++++ docbook2x-0.8.8/doc/docbook2texi.1
+@@ -230,7 +230,7 @@ parameter instead.
+
+ However, inside a custom stylesheet
+ (\fInot on the command-line\fR)
+-this paramter can be set to the XPath expression
++this parameter can be set to the XPath expression
+ \*(T<document('')\*(T>,
+ which will cause the custom translations
+ directly embedded inside the custom stylesheet to be read.
diff --git a/main/docbook2x/APKBUILD b/main/docbook2x/APKBUILD
new file mode 100644
index 0000000000..7e29233ab9
--- /dev/null
+++ b/main/docbook2x/APKBUILD
@@ -0,0 +1,75 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=docbook2x
+pkgver=0.8.8
+pkgrel=2
+pkgdesc="DocBook converter to UNIX manpage and GNU Texinfo format"
+url="http://docbook2x.sourceforge.net"
+arch="all"
+license="MIT"
+depends="texinfo openjade docbook-xml docbook-xsl perl-xml-sax libxslt"
+depends_dev=""
+makedepends="autoconf automake"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/docbook2X-$pkgver.tar.gz
+ 01_fix_static_datadir_evaluation.patch
+ 02_fix_418703_dont_use_abbreviated_sfnet_address.patch
+ 03_fix_420153_filename_whitespace_handling.patch
+ 04_fix_442782_preprocessor_declaration_syntax.patch
+ 05_fix_439214_error_on_missing_refentry.patch
+ 06_fix_man_typo.patch"
+
+_builddir="$srcdir"/docbook2X-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1 ;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ autoreconf --install
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --program-transform-name 's/docbook2/docbook2x-/' \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="b9b76a6af198c4f44574cfd17a322f01 docbook2X-0.8.8.tar.gz
+4f30722b9a2181b9a60b0728778da59a 01_fix_static_datadir_evaluation.patch
+ee9af2ae1fa3efe01a1a9d8b63b16d12 02_fix_418703_dont_use_abbreviated_sfnet_address.patch
+dcde13abbd5aaf9b14c28ed95ba71a09 03_fix_420153_filename_whitespace_handling.patch
+b6e70bf54e21ea09afcad4473c81104e 04_fix_442782_preprocessor_declaration_syntax.patch
+6e764a5c1fa1ba990c350af65609c737 05_fix_439214_error_on_missing_refentry.patch
+98798e3045cb535723a2273c4be2bda2 06_fix_man_typo.patch"
+sha256sums="4077757d367a9d1b1427e8d5dfc3c49d993e90deabc6df23d05cfe9cd2fcdc45 docbook2X-0.8.8.tar.gz
+4eb05e5265d1f7d5b46c72c05c18bc6141e4ae38a1b0b3152b1a1717d1a96fc1 01_fix_static_datadir_evaluation.patch
+6698e421018f438009f8a2cc746bbf51274bcee6575e3ede66b633f8f045513b 02_fix_418703_dont_use_abbreviated_sfnet_address.patch
+ac5755da0dbdd67e7131284e865d86df24a56ac26cfbcdcdbe561926a54999fd 03_fix_420153_filename_whitespace_handling.patch
+0f571f0e9576ef09a07c46da76723cd3f83085ccf8daf25dee15b9921455112a 04_fix_442782_preprocessor_declaration_syntax.patch
+273eaa08cfff75bb5fab4975761d1e427e4180d82700da396901a59ed0546c0d 05_fix_439214_error_on_missing_refentry.patch
+e2ac95b462563168a74e7ce988e78800d0dcade3fdc010678a9fc3524649a8a1 06_fix_man_typo.patch"
+sha512sums="cc336017ad734fc62d96d289105e8ea154c418a03a37f3e21b0b3520063f8b466b4aae5a5aec2e0b83f6324c6c79b5557247a93338d0a9882a94a44112f6b65c docbook2X-0.8.8.tar.gz
+fc7fd3383caaf091bfc6fe313c6679b1d8858fe6e3049dce3c27afe4b974180dd51ebb2d8154288de1b26343653305a890105614355efdca514d67e0ae42bff9 01_fix_static_datadir_evaluation.patch
+060ca4c2fbcd71b620f182ffe9c999a296236779605d110e578cacf2cbb4c6c551cf8d95901546ef455a402a4747e607e8ea7b54f1109fc3ccabc43cc4a8aad2 02_fix_418703_dont_use_abbreviated_sfnet_address.patch
+3a72979c03a1b5135662ad5cedefd0d508001994e727a0820d628ff5ad2476c09befeb921b9562230fdec3db547e5eec4b301aa08430dd6c2ce2632624a1c375 03_fix_420153_filename_whitespace_handling.patch
+af88626ca61847a25ef8c4cf8a09ea27cd1dce6510952e9629b704d3637097b10d85b9727e502dd7eecea1d2152a71cd26bf6abf4a8370eb8647258faa30be45 04_fix_442782_preprocessor_declaration_syntax.patch
+ea9ed94190edb2ac2055694bb927457f94eeadf0eff340b9f5fdba6fad5b1dc0b9617829ce3470914cbe0ba0be145dfb000218d57f22ee767ebb8082d6c06bfb 05_fix_439214_error_on_missing_refentry.patch
+a563b46e7eaa8052dc2daea6ad8b0f3b12780ef063fafd37a6345ae663f6229ccb0b52be5e7b1fd6584d31e56de89af391efb856bbabfed164353578b39fb458 06_fix_man_typo.patch"