aboutsummaryrefslogtreecommitdiffstats
path: root/main/dosfstools
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-06-29 14:04:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-06-29 14:04:19 +0000
commit817a8d10612ab6129bfa50c90b1ac74bd810802e (patch)
tree7b9b8343c2d922a4c019d8ac4015ccc71e0c4eff /main/dosfstools
parente0f09410fc4dd30c52595f18a784c8b3b7b5585f (diff)
downloadaports-817a8d10612ab6129bfa50c90b1ac74bd810802e.tar.bz2
aports-817a8d10612ab6129bfa50c90b1ac74bd810802e.tar.xz
main/dosfstools: upgrade to 3.0.28
Diffstat (limited to 'main/dosfstools')
-rw-r--r--main/dosfstools/APKBUILD12
-rw-r--r--main/dosfstools/musl-fixes.patch59
2 files changed, 17 insertions, 54 deletions
diff --git a/main/dosfstools/APKBUILD b/main/dosfstools/APKBUILD
index 2f8473ed05..ccd5d50f3d 100644
--- a/main/dosfstools/APKBUILD
+++ b/main/dosfstools/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dosfstools
-pkgver=3.0.27
+pkgver=3.0.28
pkgrel=0
pkgdesc="DOS filesystem utilities"
url="https://github.com/dosfstools/dosfstools"
@@ -10,6 +10,7 @@ depends=""
makedepends="linux-headers"
subpackages="$pkgname-doc"
source="https://github.com/dosfstools/dosfstools/releases/download/v$pkgver/dosfstools-$pkgver.tar.xz
+ musl-fixes.patch
"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -36,6 +37,9 @@ package() {
install || return 1
}
-md5sums="3254566ea66b185920abb7f694df2c2a dosfstools-3.0.27.tar.xz"
-sha256sums="85768eac8bd28d3bab62efb6f6d793c65b3fb81b9b38a5fe0b73e12f5ed158a8 dosfstools-3.0.27.tar.xz"
-sha512sums="cf81a396f9e26e825f096c07576f161b77295255aa77a0dcc5c862eab2b0bb83bb3e7b1426b3fdb66afc3a45ea49340efb0be65dfa996dabc57eeb28c9420f83 dosfstools-3.0.27.tar.xz"
+md5sums="6a047a6c65186b9ebb1853709adb36db dosfstools-3.0.28.tar.xz
+1212883d87460982d9a62ed0f9825589 musl-fixes.patch"
+sha256sums="ee95913044ecf2719b63ea11212917649709a6e53209a72d622135aaa8517ee2 dosfstools-3.0.28.tar.xz
+11dcbec3639e2f1977bf1fc9eb12ee25c07c494079903a9bdf62d1cc4b6bd281 musl-fixes.patch"
+sha512sums="7325a9e05f51715b358cab0a8fa8f8096422b470f1a43eecfab2adbb954e1daf6a24003121be5b3a22de5fcb3e3adffbf1551e2158852b6663fd57a109f057ad dosfstools-3.0.28.tar.xz
+c1e4ccf8ce4ac828895f783f7c5feffacee8dc6197e62b6987498bbf016646fe88b01ca510b24eb45d63df1b6dab43247f8ed30191fccead408952c0dcb3434f musl-fixes.patch"
diff --git a/main/dosfstools/musl-fixes.patch b/main/dosfstools/musl-fixes.patch
index 236615999c..462aacfb9a 100644
--- a/main/dosfstools/musl-fixes.patch
+++ b/main/dosfstools/musl-fixes.patch
@@ -1,52 +1,11 @@
-From 94e3cad801856faa63b502b1ad745ec47fde70f7 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Tue, 4 Feb 2014 08:44:30 +0000
-Subject: [PATCH] Build fixes for musl libc
-
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
----
- src/fsck.fat.h | 1 +
- src/io.h | 2 +-
- src/mkfs.fat.c | 1 +
- 3 files changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/src/fsck.fat.h b/src/fsck.fat.h
-index 9d4bb16..e5ade5b 100644
---- a/src/fsck.fat.h
-+++ b/src/fsck.fat.h
-@@ -27,6 +27,7 @@
- #ifndef _DOSFSCK_H
- #define _DOSFSCK_H
+--- ./src/mkfs.fat.c.orig
++++ ./src/mkfs.fat.c
+@@ -1412,7 +1412,7 @@
-+#include <fcntl.h>
- #include <sys/types.h>
- #define _LINUX_STAT_H /* hack to avoid inclusion of <linux/stat.h> */
- #define _LINUX_STRING_H_ /* hack to avoid inclusion of <linux/string.h> */
-diff --git a/src/io.h b/src/io.h
-index ea0e35d..d23d07e 100644
---- a/src/io.h
-+++ b/src/io.h
-@@ -27,7 +27,7 @@
- #ifndef _IO_H
- #define _IO_H
+ gettimeofday(&create_timeval, NULL);
+ create_time = create_timeval.tv_sec;
+- volume_id = (u_int32_t) ((create_timeval.tv_sec << 20) | create_timeval.tv_usec); /* Default volume ID = creation time, fudged for more uniqueness */
++ volume_id = (uint32_t) ((create_timeval.tv_sec << 20) | create_timeval.tv_usec); /* Default volume ID = creation time, fudged for more uniqueness */
+ check_atari();
--#include <sys/types.h> /* for loff_t */
-+#include <fcntl.h> /* for loff_t */
-
- loff_t llseek(int fd, loff_t offset, int whence);
-
-diff --git a/src/mkfs.fat.c b/src/mkfs.fat.c
-index 96ba47e..604b7d0 100644
---- a/src/mkfs.fat.c
-+++ b/src/mkfs.fat.c
-@@ -49,6 +49,7 @@
- #include <fcntl.h>
- #include <linux/hdreg.h>
- #include <sys/mount.h>
-+#include <linux/fs.h>
- #include <linux/fd.h>
- #include <endian.h>
- #include <mntent.h>
---
-1.8.5.3
-
+ printf("mkfs.fat " VERSION " (" VERSION_DATE ")\n");