aboutsummaryrefslogtreecommitdiffstats
path: root/main/dtc
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2018-11-21 19:16:03 +0200
committerTimo Teräs <timo.teras@iki.fi>2018-11-21 19:16:47 +0200
commitf0e3243cbf435b49ddcc0a65ae57d023f98b171c (patch)
tree52a2795739e72cd7e509c33250207370327a7dc9 /main/dtc
parent8c2b61d9e63496c082e0bfcb8acdb83802a2ce51 (diff)
downloadaports-f0e3243cbf435b49ddcc0a65ae57d023f98b171c.tar.bz2
aports-f0e3243cbf435b49ddcc0a65ae57d023f98b171c.tar.xz
main/dtc: update to 1.4.7
Diffstat (limited to 'main/dtc')
-rw-r--r--main/dtc/APKBUILD10
-rw-r--r--main/dtc/use-tx-as-the-type-specifier-instead-of-zx.patch32
2 files changed, 7 insertions, 35 deletions
diff --git a/main/dtc/APKBUILD b/main/dtc/APKBUILD
index bcaf843f29..a6478a3946 100644
--- a/main/dtc/APKBUILD
+++ b/main/dtc/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dtc
-pkgver=1.4.4
+pkgver=1.4.7
pkgrel=0
pkgdesc="Device Tree Compiler"
url="http://devicetree.org/Device_Tree_Compiler"
@@ -23,12 +23,12 @@ prepare() {
build() {
cd "$builddir"
- make || return 1
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" PREFIX=/usr install || return 1
+ make -j1 DESTDIR="$pkgdir" PREFIX=/usr install
}
libfdt() {
@@ -37,5 +37,5 @@ libfdt() {
mv "$pkgdir"/usr/lib/libfdt* "$subpkgdir"/usr/lib/
}
-sha512sums="20689f7b0489fa945c4df4e27084dfd46fd5512a8dff9b28d60e0cd0e9e79bbd9944e4d70a1aba86a026481b35bb5441ed6b63d306a4a8f7581517f7359fa9bf dtc-1.4.4.tar.xz
-b58959a60468a7b35e007ac13f8b9fb622d28175315b89122ba21a5f100440c55b431b9699e3441754e9cbe63f13d4c75ad4a1df9f66db6abb399fff03891041 use-tx-as-the-type-specifier-instead-of-zx.patch"
+sha512sums="01e0c88aee154d8ce8a5b84a299c98d12df9698e5eff572409e5e912236028532309fd21ca6a146dffef859c665d476bbbe13c371c621c1dee4abe546e5e6ebf dtc-1.4.7.tar.xz
+6b03522fed030a6b2411bd12d1878667fec9ae9bcbfe60f7d5f82468bcbc2eab5956ae758086b8f2d5611e7a6584525ab33702df6f721b218ddb3205968da543 use-tx-as-the-type-specifier-instead-of-zx.patch"
diff --git a/main/dtc/use-tx-as-the-type-specifier-instead-of-zx.patch b/main/dtc/use-tx-as-the-type-specifier-instead-of-zx.patch
index 25349444e8..3021c13954 100644
--- a/main/dtc/use-tx-as-the-type-specifier-instead-of-zx.patch
+++ b/main/dtc/use-tx-as-the-type-specifier-instead-of-zx.patch
@@ -18,36 +18,8 @@ index 4eaade9..4dcac19 100644
p = p_struct;
while ((tag = fdt32_to_cpu(GET_CELL(p))) != FDT_END) {
-- dumpf("%04zx: tag: 0x%08x (%s)\n",
-+ dumpf("%04tx: tag: 0x%08x (%s)\n",
+- dumpf("%04zx: tag: 0x%08"PRIx32" (%s)\n",
++ dumpf("%04tx: tag: 0x%08"PRIx32" (%s)\n",
(uintptr_t)p - blob_off - 4, tag, tagname(tag));
if (tag == FDT_BEGIN_NODE) {
-@@ -138,8 +138,8 @@ static void dump_blob(void *blob, bool debug)
-
- p = PALIGN(p + sz, 4);
-
-- dumpf("%04zx: string: %s\n", (uintptr_t)s - blob_off, s);
-- dumpf("%04zx: value\n", (uintptr_t)t - blob_off);
-+ dumpf("%04tx: string: %s\n", (uintptr_t)s - blob_off, s);
-+ dumpf("%04tx: value\n", (uintptr_t)t - blob_off);
- printf("%*s%s", depth * shift, "", s);
- utilfdt_print_data(t, sz);
- printf(";\n");
-@@ -222,14 +222,14 @@ int main(int argc, char *argv[])
- if (valid_header(p, this_len))
- break;
- if (debug)
-- printf("%s: skipping fdt magic at offset %#zx\n",
-+ printf("%s: skipping fdt magic at offset %#tx\n",
- file, p - buf);
- }
- ++p;
- }
- if (!p || endp - p < sizeof(struct fdt_header))
- die("%s: could not locate fdt magic\n", file);
-- printf("%s: found fdt at offset %#zx\n", file, p - buf);
-+ printf("%s: found fdt at offset %#tx\n", file, p - buf);
- buf = p;
- } else if (!valid_header(buf, len))
- die("%s: header is not valid\n", file);