aboutsummaryrefslogtreecommitdiffstats
path: root/main/dtc
diff options
context:
space:
mode:
authorBreno Leitao <breno.leitao@gmail.com>2017-03-27 20:00:41 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-03-28 05:39:17 +0000
commitfeac8738a6d320e3f3abfc163bc860ad1575ba37 (patch)
tree830fb8a6a5eca6eb570fbe2d972939635b20812c /main/dtc
parent495054ea63175c24594a681043a16da07c08bbd2 (diff)
downloadaports-feac8738a6d320e3f3abfc163bc860ad1575ba37.tar.bz2
aports-feac8738a6d320e3f3abfc163bc860ad1575ba37.tar.xz
main/dtc: Bump to version 1.4.4
Upgrade dtc package to version 1.4.4 and rebasing the patch to fit this new version.
Diffstat (limited to 'main/dtc')
-rw-r--r--main/dtc/APKBUILD10
-rw-r--r--main/dtc/use-tx-as-the-type-specifier-instead-of-zx.patch24
2 files changed, 13 insertions, 21 deletions
diff --git a/main/dtc/APKBUILD b/main/dtc/APKBUILD
index 43916cfbdd..23ba3f34e0 100644
--- a/main/dtc/APKBUILD
+++ b/main/dtc/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dtc
-pkgver=1.4.1
+pkgver=1.4.4
pkgrel=0
pkgdesc="Device Tree Compiler"
url="http://devicetree.org/Device_Tree_Compiler"
@@ -32,9 +32,5 @@ libfdt() {
mv "$pkgdir"/usr/lib/libfdt* "$subpkgdir"/usr/lib/
}
-md5sums="2c977ced2e900a397b2db846ae68ef89 dtc-1.4.1.tar.xz
-d7178913059955f54298f3168930cbe0 use-tx-as-the-type-specifier-instead-of-zx.patch"
-sha256sums="77992ad8eac7b68f553d0ba58e5b51604ac803d126196c99e3ae38aaae28bb94 dtc-1.4.1.tar.xz
-902efc2f23ba67e33db44dd1c73dec9740320ad289ed73b83d5f3bcceab88b41 use-tx-as-the-type-specifier-instead-of-zx.patch"
-sha512sums="63df730e65f62b8c9648cfee5461809188f4198cbf98de25fbe5cb7f2f43c405266abb740501740f59847dc6faf0588bcbc734d08ae5430b05c2601e070d6d05 dtc-1.4.1.tar.xz
-693639b1eaa63d5eca598f1e35890fdc13132baf1a95ab780d5039faf79ff9bb72638096d794d73f4d2a93c69c5bba0d657985de98f97c3eff633969f5e6f8f8 use-tx-as-the-type-specifier-instead-of-zx.patch"
+sha512sums="20689f7b0489fa945c4df4e27084dfd46fd5512a8dff9b28d60e0cd0e9e79bbd9944e4d70a1aba86a026481b35bb5441ed6b63d306a4a8f7581517f7359fa9bf dtc-1.4.4.tar.xz
+b58959a60468a7b35e007ac13f8b9fb622d28175315b89122ba21a5f100440c55b431b9699e3441754e9cbe63f13d4c75ad4a1df9f66db6abb399fff03891041 use-tx-as-the-type-specifier-instead-of-zx.patch"
diff --git a/main/dtc/use-tx-as-the-type-specifier-instead-of-zx.patch b/main/dtc/use-tx-as-the-type-specifier-instead-of-zx.patch
index 9c31575bbc..25349444e8 100644
--- a/main/dtc/use-tx-as-the-type-specifier-instead-of-zx.patch
+++ b/main/dtc/use-tx-as-the-type-specifier-instead-of-zx.patch
@@ -7,15 +7,14 @@ A couple of printf() commands use "zx" as a type specifier for printing
a difference of 2 pointers. "z" means a size_t, but using "t" which is
ptrdiff_t is correct. The issue was found on s390 (32-bit) where size_t
is defined as "unsigned long" as opposed to the usual "unsigned int".
----
- fdtdump.c | 10 +++++-----
- 1 file changed, 5 insertions(+), 5 deletions(-)
+Rebased-by: Breno Leitao <breno.leitao@gmail.com>
+---
diff --git a/fdtdump.c b/fdtdump.c
-index 723770d..c5811f0 100644
+index 4eaade9..4dcac19 100644
--- a/fdtdump.c
+++ b/fdtdump.c
-@@ -95,7 +95,7 @@ static void dump_blob(void *blob, bool debug)
+@@ -98,7 +98,7 @@ static void dump_blob(void *blob, bool debug)
p = p_struct;
while ((tag = fdt32_to_cpu(GET_CELL(p))) != FDT_END) {
@@ -24,7 +23,7 @@ index 723770d..c5811f0 100644
(uintptr_t)p - blob_off - 4, tag, tagname(tag));
if (tag == FDT_BEGIN_NODE) {
-@@ -135,8 +135,8 @@ static void dump_blob(void *blob, bool debug)
+@@ -138,8 +138,8 @@ static void dump_blob(void *blob, bool debug)
p = PALIGN(p + sz, 4);
@@ -35,8 +34,8 @@ index 723770d..c5811f0 100644
printf("%*s%s", depth * shift, "", s);
utilfdt_print_data(t, sz);
printf(";\n");
-@@ -210,14 +210,14 @@ int main(int argc, char *argv[])
- fdt_off_dt_strings(p) < this_len)
+@@ -222,14 +222,14 @@ int main(int argc, char *argv[])
+ if (valid_header(p, this_len))
break;
if (debug)
- printf("%s: skipping fdt magic at offset %#zx\n",
@@ -45,13 +44,10 @@ index 723770d..c5811f0 100644
}
++p;
}
- if (!p)
+ if (!p || endp - p < sizeof(struct fdt_header))
die("%s: could not locate fdt magic\n", file);
- printf("%s: found fdt at offset %#zx\n", file, p - buf);
+ printf("%s: found fdt at offset %#tx\n", file, p - buf);
buf = p;
- }
-
---
-1.8.1.4
-
+ } else if (!valid_header(buf, len))
+ die("%s: header is not valid\n", file);