aboutsummaryrefslogtreecommitdiffstats
path: root/main/e2fsprogs
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-27 20:18:59 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-28 07:49:47 +0000
commit5ee85c4acc6b41728a0dd6408b7e8023a17668a9 (patch)
treef6c744151ea3870d03c9a32fe1bc62b79815ac18 /main/e2fsprogs
parent97c5c7eb4e84a7e51644ba3e1b4794d6bf02efb1 (diff)
downloadaports-5ee85c4acc6b41728a0dd6408b7e8023a17668a9.tar.bz2
aports-5ee85c4acc6b41728a0dd6408b7e8023a17668a9.tar.xz
main/e2fsprogs: upgrade to 1.45.1
Diffstat (limited to 'main/e2fsprogs')
-rw-r--r--main/e2fsprogs/APKBUILD6
-rw-r--r--main/e2fsprogs/gnuc-prereq.patch35
2 files changed, 2 insertions, 39 deletions
diff --git a/main/e2fsprogs/APKBUILD b/main/e2fsprogs/APKBUILD
index 20badcdb41..c4d53a4d34 100644
--- a/main/e2fsprogs/APKBUILD
+++ b/main/e2fsprogs/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=e2fsprogs
-pkgver=1.45.0
+pkgver=1.45.1
pkgrel=0
pkgdesc="Standard Ext2/3/4 filesystem utilities"
url="http://e2fsprogs.sourceforge.net"
@@ -12,7 +12,6 @@ makedepends="$depends_dev linux-headers"
checkdepends="diffutils perl"
subpackages="$pkgname-static $pkgname-dev $pkgname-doc libcom_err $pkgname-libs $pkgname-extra"
source="https://www.kernel.org/pub/linux/kernel/people/tytso/$pkgname/v$pkgver/$pkgname-$pkgver.tar.xz
- gnuc-prereq.patch
"
build() {
@@ -83,5 +82,4 @@ static() {
mv "$pkgdir"/usr/lib/*.a "$subpkgdir"/usr/lib
}
-sha512sums="208f0508dd355f29f9428758123e84d7f73d1a0bba4fcdc5abb561dc492ed1ab7e36ce369acde5c26e9efff0b980d75047d2d5910d3e49614cc68ec770dc9014 e2fsprogs-1.45.0.tar.xz
-155340b6fec21419fa9ca27ff1bd8e12f679013dd82f4dc0cd1feae2dbf143a942d6d4427a1e966e68fa37ecb282880ff5d07a3760ee8d6ac7f7c5e34a276735 gnuc-prereq.patch"
+sha512sums="2e8974d30e92d7f194ccad7f152b495d2a6e41328b1532351f13af27ceaef5ee01d52963e17801cc7317f7b5208791bd20c9028f15a9859225f0e64d175be779 e2fsprogs-1.45.1.tar.xz"
diff --git a/main/e2fsprogs/gnuc-prereq.patch b/main/e2fsprogs/gnuc-prereq.patch
deleted file mode 100644
index 95b8e50a74..0000000000
--- a/main/e2fsprogs/gnuc-prereq.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-diff --git a/lib/ext2fs/ext4_acl.h b/lib/ext2fs/ext4_acl.h
-index 8d4d974..297df1b 100644
---- a/lib/ext2fs/ext4_acl.h
-+++ b/lib/ext2fs/ext4_acl.h
-@@ -1,3 +1,11 @@
-+#ifndef __GNUC_PREREQ
-+# if defined __GNUC__ && defined __GNUC_MINOR__
-+# define __GNUC_PREREQ(maj, min) ((__GNUC__ << 16) + __GNUC_MINOR__ >= ((maj) << 16) + (min))
-+# else
-+# define __GNUC_PREREQ(maj, min) 0
-+# endif
-+#endif
-+
- /*
- * Ext4's on-disk acl format. From linux/fs/ext4/acl.h
- */
-diff --git a/lib/ext2fs/hashmap.h b/lib/ext2fs/hashmap.h
-index 228f439..fdc8e7f 100644
---- a/lib/ext2fs/hashmap.h
-+++ b/lib/ext2fs/hashmap.h
-@@ -4,6 +4,14 @@
- # include <stdlib.h>
- # include <stdint.h>
-
-+#ifndef __GNUC_PREREQ
-+# if defined __GNUC__ && defined __GNUC_MINOR__
-+# define __GNUC_PREREQ(maj, min) ((__GNUC__ << 16) + __GNUC_MINOR__ >= ((maj) << 16) + (min))
-+# else
-+# define __GNUC_PREREQ(maj, min) 0
-+# endif
-+#endif
-+
- struct ext2fs_hashmap {
- uint32_t size;
- uint32_t(*hash)(const void *key, size_t len);