aboutsummaryrefslogtreecommitdiffstats
path: root/main/e2fsprogs
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-08-24 06:44:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-24 06:45:03 +0000
commit6a3df4a4fe34ee036a58fd31c6de11ad9559fbbf (patch)
treec88fb816508271a04c09353e693dd8bee902e59c /main/e2fsprogs
parente129d95ea81ee0b1776580b20e4c3a7f79eb023d (diff)
downloadaports-6a3df4a4fe34ee036a58fd31c6de11ad9559fbbf.tar.bz2
aports-6a3df4a4fe34ee036a58fd31c6de11ad9559fbbf.tar.xz
main/e2fsprogs: upgrade to 1.44.4
Diffstat (limited to 'main/e2fsprogs')
-rw-r--r--main/e2fsprogs/APKBUILD9
-rw-r--r--main/e2fsprogs/gnuc-prereq.patch35
2 files changed, 40 insertions, 4 deletions
diff --git a/main/e2fsprogs/APKBUILD b/main/e2fsprogs/APKBUILD
index 7cdc935879..ebebf939bf 100644
--- a/main/e2fsprogs/APKBUILD
+++ b/main/e2fsprogs/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=e2fsprogs
-pkgver=1.44.3
+pkgver=1.44.4
pkgrel=0
pkgdesc="Standard Ext2/3/4 filesystem utilities"
url="http://e2fsprogs.sourceforge.net"
@@ -13,6 +13,7 @@ options="!check"
makedepends="$depends_dev linux-headers"
subpackages="$pkgname-dev $pkgname-doc libcom_err $pkgname-libs $pkgname-extra"
source="https://www.kernel.org/pub/linux/kernel/people/tytso/$pkgname/v$pkgver/$pkgname-$pkgver.tar.xz
+ gnuc-prereq.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -28,14 +29,13 @@ build () {
--disable-uuidd \
--disable-libuuid \
--disable-libblkid \
- --disable-tls \
--disable-nls
make
}
package() {
cd "$builddir"
- make -j1 LDCONFIG=: DESTDIR="$pkgdir" install install-libs
+ make -j1 MKDIR_P="install -d" DESTDIR="$pkgdir" install install-libs
mv "$pkgdir"/sbin/* "$pkgdir"/usr/sbin/
local i; for i in e2fsck mke2fs mkfs.* fsck.*; do
mv "$pkgdir"/usr/sbin/$i "$pkgdir"/sbin/
@@ -66,4 +66,5 @@ extra() {
mv "$pkgdir"/usr "$subpkgdir"/
}
-sha512sums="38fdf918762a8ef8b49f04fe229bbb226a22d084bbfd21bd2d5fe5579f5b40eaa1b769cd3112d540f6460ed6d5b2a49ddf72128d1458c8b733193998a079e0be e2fsprogs-1.44.3.tar.xz"
+sha512sums="52e39565dee30997b9c245b5d8791844067a903a570082f3a5ff9d9ef96624535322617bb21029056c88259fef46416eb1181bd7aec419e64fc021830887ec8f e2fsprogs-1.44.4.tar.xz
+155340b6fec21419fa9ca27ff1bd8e12f679013dd82f4dc0cd1feae2dbf143a942d6d4427a1e966e68fa37ecb282880ff5d07a3760ee8d6ac7f7c5e34a276735 gnuc-prereq.patch"
diff --git a/main/e2fsprogs/gnuc-prereq.patch b/main/e2fsprogs/gnuc-prereq.patch
new file mode 100644
index 0000000000..95b8e50a74
--- /dev/null
+++ b/main/e2fsprogs/gnuc-prereq.patch
@@ -0,0 +1,35 @@
+diff --git a/lib/ext2fs/ext4_acl.h b/lib/ext2fs/ext4_acl.h
+index 8d4d974..297df1b 100644
+--- a/lib/ext2fs/ext4_acl.h
++++ b/lib/ext2fs/ext4_acl.h
+@@ -1,3 +1,11 @@
++#ifndef __GNUC_PREREQ
++# if defined __GNUC__ && defined __GNUC_MINOR__
++# define __GNUC_PREREQ(maj, min) ((__GNUC__ << 16) + __GNUC_MINOR__ >= ((maj) << 16) + (min))
++# else
++# define __GNUC_PREREQ(maj, min) 0
++# endif
++#endif
++
+ /*
+ * Ext4's on-disk acl format. From linux/fs/ext4/acl.h
+ */
+diff --git a/lib/ext2fs/hashmap.h b/lib/ext2fs/hashmap.h
+index 228f439..fdc8e7f 100644
+--- a/lib/ext2fs/hashmap.h
++++ b/lib/ext2fs/hashmap.h
+@@ -4,6 +4,14 @@
+ # include <stdlib.h>
+ # include <stdint.h>
+
++#ifndef __GNUC_PREREQ
++# if defined __GNUC__ && defined __GNUC_MINOR__
++# define __GNUC_PREREQ(maj, min) ((__GNUC__ << 16) + __GNUC_MINOR__ >= ((maj) << 16) + (min))
++# else
++# define __GNUC_PREREQ(maj, min) 0
++# endif
++#endif
++
+ struct ext2fs_hashmap {
+ uint32_t size;
+ uint32_t(*hash)(const void *key, size_t len);