aboutsummaryrefslogtreecommitdiffstats
path: root/main/e2fsprogs
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-04 23:06:41 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-05 19:00:13 +0000
commitf0c01e04ac67e91f17e090d38eac4da97d68b750 (patch)
tree8eb2c41cbf22a6eb6ff045253a0fde5d37cfdcec /main/e2fsprogs
parent6f880fa5fe8ec8eb45a1f43d0db22c787e318c09 (diff)
downloadaports-f0c01e04ac67e91f17e090d38eac4da97d68b750.tar.bz2
aports-f0c01e04ac67e91f17e090d38eac4da97d68b750.tar.xz
main/e2fsprogs: enable check
Diffstat (limited to 'main/e2fsprogs')
-rw-r--r--main/e2fsprogs/APKBUILD17
1 files changed, 14 insertions, 3 deletions
diff --git a/main/e2fsprogs/APKBUILD b/main/e2fsprogs/APKBUILD
index 572cecd8c6..46744cc2ae 100644
--- a/main/e2fsprogs/APKBUILD
+++ b/main/e2fsprogs/APKBUILD
@@ -7,17 +7,16 @@ pkgdesc="Standard Ext2/3/4 filesystem utilities"
url="http://e2fsprogs.sourceforge.net"
arch="all"
license="GPL-2.0-or-later LGPL-2.0 BSD-3-Clause MIT"
-depends=""
depends_dev="util-linux-dev"
-options="!check"
makedepends="$depends_dev linux-headers"
+checkdepends="diffutils perl"
subpackages="$pkgname-dev $pkgname-doc libcom_err $pkgname-libs $pkgname-extra"
source="https://www.kernel.org/pub/linux/kernel/people/tytso/$pkgname/v$pkgver/$pkgname-$pkgver.tar.xz
gnuc-prereq.patch
"
builddir="$srcdir/$pkgname-$pkgver"
-build () {
+build() {
cd "$builddir"
./configure \
--build=$CBUILD \
@@ -33,6 +32,18 @@ build () {
make
}
+check() {
+ cd "$builddir"
+
+ # Disable failing test
+ rm -rf tests/m_offset*
+
+ # Failing on CI
+ rm -rf tests/f_bigalloc_orphan_list*
+
+ make check
+}
+
package() {
cd "$builddir"
make -j1 MKDIR_P="install -d" DESTDIR="$pkgdir" install install-libs