aboutsummaryrefslogtreecommitdiffstats
path: root/main/ebtables
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-05-21 07:38:51 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-05-21 07:39:37 +0000
commitfb228c4f93d8fe9217bf329087c4f16b8d54b709 (patch)
tree12f5838e16014626fe60dd59bfd25178b36b229e /main/ebtables
parenta8fe31ad9e06b312b24d2d65b3844b971f3c2c94 (diff)
downloadaports-fb228c4f93d8fe9217bf329087c4f16b8d54b709.tar.bz2
aports-fb228c4f93d8fe9217bf329087c4f16b8d54b709.tar.xz
main/ebtables: fix extension initialization (on arm especially)
fixes #5388
Diffstat (limited to 'main/ebtables')
-rw-r--r--main/ebtables/APKBUILD12
-rw-r--r--main/ebtables/fix-extension-init.patch249
2 files changed, 257 insertions, 4 deletions
diff --git a/main/ebtables/APKBUILD b/main/ebtables/APKBUILD
index 6810726e47..b09102ac2e 100644
--- a/main/ebtables/APKBUILD
+++ b/main/ebtables/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ebtables
pkgver=2.0.10.4
_realver=v${pkgver%.[0-9]}-${pkgver##*.}
-pkgrel=1
+pkgrel=2
pkgdesc="Ethernet bridge tables - Linux Ethernet filter for the Linux bridge."
url="http://ebtables.sourceforge.net/"
arch="all"
@@ -16,6 +16,7 @@ source="http://downloads.sourceforge.net/$pkgname/$pkgname-$_realver.tar.gz
ebtables.initd
ebtables.confd
musl-fixes.patch
+ fix-extension-init.patch
"
prepare() {
@@ -54,12 +55,15 @@ package() {
md5sums="506742a3d44b9925955425a659c1a8d0 ebtables-v2.0.10-4.tar.gz
197852fae4bbac2fe75f81b36b6af852 ebtables.initd
285089ba2d846e72e321a12e3da3cc96 ebtables.confd
-d443749e0a7bf542baec328b4520b36b musl-fixes.patch"
+d443749e0a7bf542baec328b4520b36b musl-fixes.patch
+9b7470d60e7496e898428724e8fe653a fix-extension-init.patch"
sha256sums="dc6f7b484f207dc712bfca81645f45120cb6aee3380e77a1771e9c34a9a4455d ebtables-v2.0.10-4.tar.gz
893615d9f18eedd8e6d30252d6545b4ecaeca3f44219768f39c576ca949ec59a ebtables.initd
fa8dedd95f1a6834022e409754e1e41219a7671a1bbb99b2094356239135730d ebtables.confd
-5d2cefaa945acce3fbe19568002a26b405d7d91cb213655b5db38ca90ad73919 musl-fixes.patch"
+5d2cefaa945acce3fbe19568002a26b405d7d91cb213655b5db38ca90ad73919 musl-fixes.patch
+dda93ff229e921d91efecb8667ed7dde2359fe5f13060fcd863a4acc54f7c750 fix-extension-init.patch"
sha512sums="a6832453812eaede3fcbb5b4cab5902ea1ea752a80a259eed276a01b61e2afaa6cf07d3d023d86a883f9a02505aecc44a1c6e0d27b3a61f341002e4c051cd60a ebtables-v2.0.10-4.tar.gz
c8fccc96610ddc24a3a0c7c2c9f2460b87e582424e338beeb20d77726b27324f89906ef853680e62912ed3544c967469870d78aa6e39de11efda072dd8a4a836 ebtables.initd
b24afd1f5c2f200a1eec6ed7fd63500237dc168bfb9cc1297ffc288d12d30224a1ee84a7f61663daf408c42457dd7deac7594a23e448218806798294e9a1018d ebtables.confd
-d72e606381a8790a11228a7cf25fd5acfeb036742ca8dbc8603d3b7baec7cc77846c2fe4b4cde698fb1bd8f272cd5d2e260db4363f2e3e69f29a88c95e156608 musl-fixes.patch"
+d72e606381a8790a11228a7cf25fd5acfeb036742ca8dbc8603d3b7baec7cc77846c2fe4b4cde698fb1bd8f272cd5d2e260db4363f2e3e69f29a88c95e156608 musl-fixes.patch
+d43ee171000c4a41063ba82a3659b0624654075d961711df45071a551a1e83f6aa3f51b4d537dc8c3b8001447fc8d6a6aeddf55569839c364c4c8471198b9383 fix-extension-init.patch"
diff --git a/main/ebtables/fix-extension-init.patch b/main/ebtables/fix-extension-init.patch
new file mode 100644
index 0000000000..4812b4de2d
--- /dev/null
+++ b/main/ebtables/fix-extension-init.patch
@@ -0,0 +1,249 @@
+--- ebtables-v2.0.10-4.orig/extensions/Makefile
++++ ebtables-v2.0.10-4/extensions/Makefile
+@@ -11,13 +11,13 @@
+ EXT_LIBSI+=$(foreach T,$(EXT_TABLES), -lebtable_$(T))
+
+ extensions/ebt_%.so: extensions/ebt_%.o
+- $(CC) $(LDFLAGS) -shared -o $@ -lc $< -nostartfiles
++ $(CC) $(LDFLAGS) -shared -o $@ -lc $<
+
+ extensions/libebt_%.so: extensions/ebt_%.so
+ mv $< $@
+
+ extensions/ebtable_%.so: extensions/ebtable_%.o
+- $(CC) $(LDFLAGS) -shared -o $@ -lc $< -nostartfiles
++ $(CC) $(LDFLAGS) -shared -o $@ -lc $<
+
+ extensions/libebtable_%.so: extensions/ebtable_%.so
+ mv $< $@
+--- ebtables-v2.0.10-4.orig/extensions/ebt_802_3.c
++++ ebtables-v2.0.10-4/extensions/ebt_802_3.c
+@@ -141,7 +141,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_match(&_802_3_match);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_among.c
++++ ebtables-v2.0.10-4/extensions/ebt_among.c
+@@ -491,7 +491,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_match(&among_match);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_arp.c
++++ ebtables-v2.0.10-4/extensions/ebt_arp.c
+@@ -362,7 +362,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_match(&arp_match);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_arpreply.c
++++ ebtables-v2.0.10-4/extensions/ebt_arpreply.c
+@@ -133,7 +133,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_target(&arpreply_target);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_ip.c
++++ ebtables-v2.0.10-4/extensions/ebt_ip.c
+@@ -338,7 +338,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_match(&ip_match);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_ip6.c
++++ ebtables-v2.0.10-4/extensions/ebt_ip6.c
+@@ -556,7 +556,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_match(&ip6_match);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_limit.c
++++ ebtables-v2.0.10-4/extensions/ebt_limit.c
+@@ -212,7 +212,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_match(&limit_match);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_log.c
++++ ebtables-v2.0.10-4/extensions/ebt_log.c
+@@ -217,7 +217,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_watcher(&log_watcher);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_mark.c
++++ ebtables-v2.0.10-4/extensions/ebt_mark.c
+@@ -172,7 +172,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_target(&mark_target);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_mark_m.c
++++ ebtables-v2.0.10-4/extensions/ebt_mark_m.c
+@@ -121,7 +121,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_match(&mark_match);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_nat.c
++++ ebtables-v2.0.10-4/extensions/ebt_nat.c
+@@ -231,7 +231,7 @@
+ .extra_ops = opts_d,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_target(&snat_target);
+ ebt_register_target(&dnat_target);
+--- ebtables-v2.0.10-4.orig/extensions/ebt_nflog.c
++++ ebtables-v2.0.10-4/extensions/ebt_nflog.c
+@@ -166,7 +166,7 @@
+ .extra_ops = nflog_opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_watcher(&nflog_watcher);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_pkttype.c
++++ ebtables-v2.0.10-4/extensions/ebt_pkttype.c
+@@ -125,7 +125,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_match(&pkttype_match);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_redirect.c
++++ ebtables-v2.0.10-4/extensions/ebt_redirect.c
+@@ -108,7 +108,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_target(&redirect_target);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_standard.c
++++ ebtables-v2.0.10-4/extensions/ebt_standard.c
+@@ -84,7 +84,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_target(&standard);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_stp.c
++++ ebtables-v2.0.10-4/extensions/ebt_stp.c
+@@ -337,7 +337,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_match(&stp_match);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_ulog.c
++++ ebtables-v2.0.10-4/extensions/ebt_ulog.c
+@@ -180,7 +180,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_watcher(&ulog_watcher);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebt_vlan.c
++++ ebtables-v2.0.10-4/extensions/ebt_vlan.c
+@@ -181,7 +181,7 @@
+ .extra_ops = opts,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_match(&vlan_match);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebtable_broute.c
++++ ebtables-v2.0.10-4/extensions/ebtable_broute.c
+@@ -23,7 +23,7 @@
+ .help = print_help,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_table(&table);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebtable_filter.c
++++ ebtables-v2.0.10-4/extensions/ebtable_filter.c
+@@ -29,7 +29,7 @@
+ .help = print_help,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_table(&table);
+ }
+--- ebtables-v2.0.10-4.orig/extensions/ebtable_nat.c
++++ ebtables-v2.0.10-4/extensions/ebtable_nat.c
+@@ -30,7 +30,7 @@
+ .help = print_help,
+ };
+
+-void _init(void)
++__attribute__((constructor)) static void extension_init(void)
+ {
+ ebt_register_table(&table);
+ }