aboutsummaryrefslogtreecommitdiffstats
path: root/main/ell
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-04-04 23:58:40 +0200
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-04-05 12:45:38 +0000
commita8484721682e1cc9bea6254f9b89d2bac0bfd9e8 (patch)
tree7c930d5b373aba3233a51440f1d09b56129a0318 /main/ell
parentf23237c3ff3ce318fbc29bbd2035fd19f8e0fc56 (diff)
downloadaports-a8484721682e1cc9bea6254f9b89d2bac0bfd9e8.tar.bz2
aports-a8484721682e1cc9bea6254f9b89d2bac0bfd9e8.tar.xz
main/ell: upgrade to 0.18
remove fix-utf8.patch, applied upstream
Diffstat (limited to 'main/ell')
-rw-r--r--main/ell/APKBUILD12
-rw-r--r--main/ell/fix-utf8.patch13
2 files changed, 5 insertions, 20 deletions
diff --git a/main/ell/APKBUILD b/main/ell/APKBUILD
index 6d40ecda59..027be69b7d 100644
--- a/main/ell/APKBUILD
+++ b/main/ell/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Milan P. Stanić <mps@arvanta.net>
# Maintainer: Milan P. Stanić <mps@arvanta.net>
pkgname=ell
-pkgver=0.17
-pkgrel=1
+pkgver=0.18
+pkgrel=0
pkgdesc="Linux library for embedded development"
url="https://01.org/ell"
arch="all"
@@ -12,8 +12,7 @@ makedepends="glib-dev linux-headers"
checkdepends="dbus"
subpackages="$pkgname-dev"
source="https://mirrors.edge.kernel.org/pub/linux/libs/ell/$pkgname-${pkgver}.tar.gz
- musl-fixes-testsuite.patch
- fix-utf8.patch"
+ musl-fixes-testsuite.patch"
builddir="$srcdir/$pkgname-${pkgver}"
build() {
@@ -39,6 +38,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="2f35214283bc2b0d17b27a096a0457679747966cad284e3bc581b9414909f98eb3bae9c33d30e62992dccf2331886af505a07e6a73df4c54d3ac476f6791da56 ell-0.17.tar.gz
-ee93edab6618343bec00db9c4a5279a8f4cbb6ecf6ae62cac99c688377bb4ca4f04d5bc6a32a702071d16e8988f4c0eff2291fb04e91b8f9ed909ce88329f67f musl-fixes-testsuite.patch
-6973f65fff8b281d56b25b0abc1dd3673953ae6c1c234da94608148937afc783417398300cc090f841668cf1a898d2780b6f109539ce108949258cac1edfcd4c fix-utf8.patch"
+sha512sums="8ac57d4b0c5c061a99d85152550e91786ae32bfe61d2250a9943b5aa15d9036419e08a8bad0ade1a638e3bf73af807a82f1883ef2960ebfa294dcc354bae0372 ell-0.18.tar.gz
+ee93edab6618343bec00db9c4a5279a8f4cbb6ecf6ae62cac99c688377bb4ca4f04d5bc6a32a702071d16e8988f4c0eff2291fb04e91b8f9ed909ce88329f67f musl-fixes-testsuite.patch"
diff --git a/main/ell/fix-utf8.patch b/main/ell/fix-utf8.patch
deleted file mode 100644
index 9d4a520240..0000000000
--- a/main/ell/fix-utf8.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/ell/utf8.c b/ell/utf8.c
-index e9998f7..b1e8440 100644
---- a/ell/utf8.c
-+++ b/ell/utf8.c
-@@ -93,7 +93,7 @@ LIB_EXPORT int l_utf8_get_codepoint(const char *str, size_t len, wchar_t *cp)
- if (len == 0)
- return 0;
-
-- if (str[0] > 0) {
-+ if ((signed char)str[0] > 0) {
- *cp = str[0];
- return 1;
- }