aboutsummaryrefslogtreecommitdiffstats
path: root/main/ell
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-10-11 17:03:45 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-10-12 19:36:12 +0000
commitd590e319a5f320c863ad617546c8496a5229d2bf (patch)
tree350b059dc2190d20224b7a55b1164ff1c7de96cc /main/ell
parentd89be7ee6e382de2517f153fb4d08136322fbdd0 (diff)
downloadaports-d590e319a5f320c863ad617546c8496a5229d2bf.tar.bz2
aports-d590e319a5f320c863ad617546c8496a5229d2bf.tar.xz
main/ell: upgrade to 0.24
remove musl-fixes-testsuite.patch, applied upstream Closes !412
Diffstat (limited to 'main/ell')
-rw-r--r--main/ell/APKBUILD10
-rw-r--r--main/ell/musl-fixes-testsuite.patch45
2 files changed, 3 insertions, 52 deletions
diff --git a/main/ell/APKBUILD b/main/ell/APKBUILD
index 415b22d348..5aaec504af 100644
--- a/main/ell/APKBUILD
+++ b/main/ell/APKBUILD
@@ -1,19 +1,16 @@
# Contributor: Milan P. Stanić <mps@arvanta.net>
# Maintainer: Milan P. Stanić <mps@arvanta.net>
pkgname=ell
-pkgver=0.23
+pkgver=0.24
pkgrel=0
pkgdesc="Linux library for embedded development"
url="https://01.org/ell"
arch="all"
license="GPL-2.0-only"
-depends=""
makedepends="glib-dev linux-headers"
checkdepends="dbus"
subpackages="$pkgname-dev"
-source="https://mirrors.edge.kernel.org/pub/linux/libs/ell/$pkgname-${pkgver}.tar.gz
- musl-fixes-testsuite.patch
- "
+source="https://mirrors.edge.kernel.org/pub/linux/libs/ell/$pkgname-${pkgver}.tar.gz"
builddir="$srcdir/$pkgname-${pkgver}"
@@ -40,5 +37,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="955a235f37bd3208df8ecbb9d070cab98961b4b848ccc8b5ae8ef574f9016b0826679507a04d7d944ed150c7b98bae206a8cd1e739c5fe71448831bb2c05a9e4 ell-0.23.tar.gz
-ee93edab6618343bec00db9c4a5279a8f4cbb6ecf6ae62cac99c688377bb4ca4f04d5bc6a32a702071d16e8988f4c0eff2291fb04e91b8f9ed909ce88329f67f musl-fixes-testsuite.patch"
+sha512sums="c97b174a59aa6b4bbafd317fec47140e46f7aa383f09a4053c2d719d64430e99dff95fa07292fff76183a6a0d770089ac3dbed62d6bdc40062f0799f84af155c ell-0.24.tar.gz"
diff --git a/main/ell/musl-fixes-testsuite.patch b/main/ell/musl-fixes-testsuite.patch
deleted file mode 100644
index 5b951f50a8..0000000000
--- a/main/ell/musl-fixes-testsuite.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff --git a/unit/test-dbus-message-fds.c b/unit/test-dbus-message-fds.c
-index d6d0b38..217bc70 100644
---- a/unit/test-dbus-message-fds.c
-+++ b/unit/test-dbus-message-fds.c
-@@ -37,6 +37,10 @@
- #include <ell/ell.h>
- #include "ell/dbus-private.h"
-
-+#ifndef WAIT_ANY
-+#define WAIT_ANY (-1)
-+#endif
-+
- #define TEST_BUS_ADDRESS "unix:path=/tmp/ell-test-bus"
-
- static pid_t dbus_daemon_pid = -1;
-diff --git a/unit/test-dbus-properties.c b/unit/test-dbus-properties.c
-index f91ba73..b6fa776 100644
---- a/unit/test-dbus-properties.c
-+++ b/unit/test-dbus-properties.c
-@@ -34,6 +34,10 @@
- #include <ell/ell.h>
- #include "ell/dbus-private.h"
-
-+#ifndef WAIT_ANY
-+#define WAIT_ANY (-1)
-+#endif
-+
- #define TEST_BUS_ADDRESS "unix:path=/tmp/ell-test-bus"
-
- static pid_t dbus_daemon_pid = -1;
-diff --git a/unit/test-dbus.c b/unit/test-dbus.c
-index d5bd8c5..f63a281 100644
---- a/unit/test-dbus.c
-+++ b/unit/test-dbus.c
-@@ -31,6 +31,10 @@
-
- #include <ell/ell.h>
-
-+#ifndef WAIT_ANY
-+#define WAIT_ANY (-1)
-+#endif
-+
- #define TEST_BUS_ADDRESS "unix:path=/tmp/ell-test-bus"
-
- static pid_t dbus_daemon_pid = -1;