aboutsummaryrefslogtreecommitdiffstats
path: root/main/fakeroot
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-06 11:04:51 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-06 11:06:30 +0000
commit72776eb5090d6a59056e220278d5d6b38950ee1a (patch)
treed493c7fd11ca9719ef624140603e4fed7503e0de /main/fakeroot
parent0c3bccdda5e5b537c5b2af064505e05d772df70f (diff)
downloadaports-72776eb5090d6a59056e220278d5d6b38950ee1a.tar.bz2
aports-72776eb5090d6a59056e220278d5d6b38950ee1a.tar.xz
main/fakeroot: fix musl build, support cross compiling
Diffstat (limited to 'main/fakeroot')
-rw-r--r--main/fakeroot/APKBUILD22
-rw-r--r--main/fakeroot/fakeroot-no64.patch17
2 files changed, 35 insertions, 4 deletions
diff --git a/main/fakeroot/APKBUILD b/main/fakeroot/APKBUILD
index d4d1ef208c..63c3cd5ab9 100644
--- a/main/fakeroot/APKBUILD
+++ b/main/fakeroot/APKBUILD
@@ -7,28 +7,39 @@ arch="all"
license='GPL'
url="http://fakeroot.alioth.debian.org/"
depends=
-makedepends="libcap-dev"
+makedepends_host="libcap-dev"
+makedepends="$makedepends_host"
subpackages="$pkgname-doc"
source="http://ftp.debian.org/debian/pool/main/f/$pkgname/${pkgname}_${pkgver}.orig.tar.bz2
busybox-getopt.patch
+ fakeroot-no64.patch
fakeroot-stdint.patch
fakeroot-uclibc.patch"
prepare() {
cd $startdir/src/$pkgname-$pkgver
+ update_config_sub || return 1
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+
+ if [ "$CLIBC" = "musl" ]; then
+ # overrides wrong symbol for musl, so hack the config script
+ sed -e 's/for WRAPPED in __${PRE}x${FUNC} _${PRE}x${FUNC} __${PRE}${FUNC}13 ${PRE}${FUNC}; do/for WRAPPED in ${PRE}${FUNC}; do/' \
+ -i configure
+ fi
}
build() {
cd $startdir/src/$pkgname-$pkgver
- # musl does not have _STAT_VER, it's really not used for
- # anything, so define it as zero (just like uclibc does)
- [ "${CHOST#*musl}" != "$CHOST" ] && CFLAGS="-D_STAT_VER=0 $CFLAGS"
+ if [ "$CLIBC" = "musl" ]; then
+ # musl does not have _STAT_VER, it's really not used for
+ # anything, so define it as zero (just like uclibc does)
+ export CFLAGS="-D_STAT_VER=0 $CFLAGS"
+ fi
CONFIG_SHELL=/bin/sh \
./configure \
@@ -48,13 +59,16 @@ package() {
md5sums="3a00a1264cb31a815552050ef0c2468b fakeroot_1.19.orig.tar.bz2
bdbf1db14f2cfdff0f5b4c35da78b9fe busybox-getopt.patch
+3fc66a8ffb365fcf2acd652d33f101a2 fakeroot-no64.patch
50a899380cfd5eae8ce3aaf878fb17b2 fakeroot-stdint.patch
7a54ab51fdb90bc44e366e0a66811bfe fakeroot-uclibc.patch"
sha256sums="eafa6885535ff57a42248aec090fe17cfa5ca85b62cefa0d13637c9de8996868 fakeroot_1.19.orig.tar.bz2
e915ce6cf414da590d39c735e1e522725717f43bfe6da77bd62cd1be365a06ec busybox-getopt.patch
+3420da0789caef582fcfc890c657da4136b3b06d1205443f4409cdf85ab02a46 fakeroot-no64.patch
8739c0b79c3f2b0e46cd0dffa8b73d946efbe994f61f69f7d1115c2dcec22df1 fakeroot-stdint.patch
e325ad9aad310caa71002adea220795f706c621c5794093f16c0f319b3d58977 fakeroot-uclibc.patch"
sha512sums="ff3f50cdf168deafab337d3d98299ccd4129ed2a9befa5f28171d92c2ddfa08c8f42424f32b3fbcbb1f83c16f22952e571946f4152246d08b0d18bab77c458e9 fakeroot_1.19.orig.tar.bz2
3a3cfcddbfe6685111d2a9dd93ebe5816bacab664aa19004cc39e18c00b5ef8045cb153755f66cabb204f17e2495ce38e2fb37fdc8da01cc69ec62e4694e3001 busybox-getopt.patch
+7a832e6bed3838c7c488e0e12ba84b8d256e84bbb06d6020247452a991de505fa5c6bd7bcb84dce8753eb242e0fcab863b5461301cd56695f2b003fe8d6ff209 fakeroot-no64.patch
ed7a58b0d201139545420f9e5429f503c00e00f36dea84473e77ea99b23bb8d421da1a8a8ce98ff90e72e378dff4cb9ea3c1a863a969899a5f50dfac3b9c5fac fakeroot-stdint.patch
783ceaf00c6c1c190327dbc3f67761488aaeb23e40b3a249bcaf301f99334721a864f8a730abfb0e17467bad24f5db9127d83379dea3ef24b6f708ff7dfb3f98 fakeroot-uclibc.patch"
diff --git a/main/fakeroot/fakeroot-no64.patch b/main/fakeroot/fakeroot-no64.patch
new file mode 100644
index 0000000000..ff95f96a9b
--- /dev/null
+++ b/main/fakeroot/fakeroot-no64.patch
@@ -0,0 +1,17 @@
+--- a/libfakeroot.c
++++ b/libfakeroot.c
+@@ -81,12 +81,14 @@
+ #define SEND_STAT64(a,b,c) send_stat64(a,b,c)
+ #define SEND_GET_STAT(a,b) send_get_stat(a,b)
+ #define SEND_GET_STAT64(a,b) send_get_stat64(a,b)
++#define SEND_GET_XATTR(a,b,c) send_get_xattr(a,b,c)
+ #define SEND_GET_XATTR64(a,b,c) send_get_xattr64(a,b,c)
+ #else
+ #define SEND_STAT(a,b,c) send_stat(a,b)
+ #define SEND_STAT64(a,b,c) send_stat64(a,b)
+ #define SEND_GET_STAT(a,b) send_get_stat(a)
+ #define SEND_GET_STAT64(a,b) send_get_stat64(a)
++#define SEND_GET_XATTR(a,b,c) send_get_xattr(a,b)
+ #define SEND_GET_XATTR64(a,b,c) send_get_xattr64(a,b)
+ #endif
+