aboutsummaryrefslogtreecommitdiffstats
path: root/main/fetchmail
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-10-04 19:09:13 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-10-10 12:04:09 +0000
commitbe6e288a64e22462f06dc6da872c1832f76c75a5 (patch)
tree23bb01150aaf0b5ae99ddf3488115f5293bfe316 /main/fetchmail
parent1923297b68e86705e5b01865fcbe7d67e6d4afe3 (diff)
downloadaports-be6e288a64e22462f06dc6da872c1832f76c75a5.tar.bz2
aports-be6e288a64e22462f06dc6da872c1832f76c75a5.tar.xz
main/fetchmail: rebuild against libressl
Diffstat (limited to 'main/fetchmail')
-rw-r--r--main/fetchmail/APKBUILD18
-rw-r--r--main/fetchmail/libressl.patch71
2 files changed, 83 insertions, 6 deletions
diff --git a/main/fetchmail/APKBUILD b/main/fetchmail/APKBUILD
index 155ff3c8d1..f1ca687dea 100644
--- a/main/fetchmail/APKBUILD
+++ b/main/fetchmail/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fetchmail
pkgver=6.3.26
-pkgrel=9
+pkgrel=10
pkgdesc="A remote-mail retrieval and forwarding utility"
url="http://www.fetchmail.info/"
arch="all"
@@ -10,21 +10,24 @@ license="GPL"
depends=
pkgusers="fetchmail"
pkggroups="fetchmail"
-makedepends="openssl-dev python"
+makedepends="libressl-dev python autoconf automake gettext-dev"
install="fetchmail.pre-install"
subpackages="$pkgname-doc fetchmailconf"
source="http://downloads.sourceforge.net/project/${pkgname}/branch_6.3/${pkgname}-${pkgver}.tar.xz
+ libressl.patch
$pkgname.initd
$pkgname.confd"
-_builddir="$srcdir/$pkgname-$pkgver"
+builddir="$srcdir/$pkgname-$pkgver"
prepare() {
- cd "$_builddir"
+ cd "$builddir"
update_config_sub || return 1
+ default_prepare || return 1
+ autoreconf -vif
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
@@ -40,7 +43,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install
install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
install -Dm644 "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
@@ -59,11 +62,14 @@ fetchmailconf() {
}
md5sums="61b66faad044afa26e142bb1791aa2b3 fetchmail-6.3.26.tar.xz
+51e8f36f2c3e3d5682b69470a7f96714 libressl.patch
6a448e0f2b34f58e0007a660b0f8c343 fetchmail.initd
0203136e64395c8411b01d75407d1adc fetchmail.confd"
sha256sums="79b4c54cdbaf02c1a9a691d9948fcb1a77a1591a813e904283a8b614b757e850 fetchmail-6.3.26.tar.xz
+84f036fd07ce197811191bf2a330d13e8327403cf907e1538d80baca8905179f libressl.patch
5eaaba09c253b4d8ff9ea217597c6c531f66417beca7057cb2ea6ffe16cfd134 fetchmail.initd
6343137640a25b115f015f41640bb498a6ebba471caa9374718364616aef3f85 fetchmail.confd"
sha512sums="8e0a2484e60eaf6c0231e2599e10fec6d207fa1c0fa02ec99b3ef9aea00b6d87275434e79470a25f06e358cdd4a293f9c46a82dd128fe733a99c85144e6caa63 fetchmail-6.3.26.tar.xz
+296900f7eb7bc7dd33d166ac1abad72646b153c880fc702cd1e0c4da27ce153a9fcf40ef763532030ca54e7f33526199c0a93aa9e5a0945e74a0ad71a0aab31c libressl.patch
9520ec6616f4004d091b1c908d3ea38e104ad8f6595959a3cd3ef7544d05e3b75854631289e167ead08479250d04584d3f1855668a7a0ebd16a1ee9106f3b0b3 fetchmail.initd
6f031ec6bd4a3ae53cd04fbd8470f4d10bd46ca29cabffa634a6801aa2e7707169855fbc045ced3c9a69523e694511a3f076b611678143e49339c8ccac98074e fetchmail.confd"
diff --git a/main/fetchmail/libressl.patch b/main/fetchmail/libressl.patch
new file mode 100644
index 0000000000..b2a6b98760
--- /dev/null
+++ b/main/fetchmail/libressl.patch
@@ -0,0 +1,71 @@
+From a2ae6f8d15d7caf815d7bdd13df833fd1b2af5cc Mon Sep 17 00:00:00 2001
+From: Matthias Andree <matthias.andree@gmx.de>
+Date: Fri, 16 Jan 2015 20:48:46 +0100
+Subject: [PATCH] Permit build on SSLv3-disabled OpenSSL,
+
+providing that these also omit the declaration of SSLv3_client_method().
+Related to Debian Bug#775255.
+Version report lists -SSLv3 on +SSL builds that omit SSLv3_client_method().
+Version report lists -SSLv2 on +SSL builds that omit SSLv2_client_method().
+---
+ NEWS | 6 ++++++
+ configure.ac | 1 +
+ fetchmail.c | 6 ++++++
+ po/de.po | 23 ++++++++++++++---------
+ socket.c | 7 ++++++-
+ 5 files changed, 33 insertions(+), 10 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index bdcbb20..9248b26 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -803,6 +803,7 @@ fi
+
+ case "$LIBS" in *-lssl*)
+ AC_CHECK_DECLS([SSLv2_client_method],,,[#include <openssl/ssl.h>])
++ AC_CHECK_DECLS([SSLv3_client_method],,,[#include <openssl/ssl.h>])
+ ;;
+ esac
+
+diff --git a/fetchmail.c b/fetchmail.c
+index 5f31d6e..be0e9ab 100644
+--- a/fetchmail.c
++++ b/fetchmail.c
+@@ -263,6 +263,12 @@ int main(int argc, char **argv)
+ #ifdef SSL_ENABLE
+ "+SSL"
+ #endif
++#if HAVE_DECL_SSLV2_CLIENT_METHOD + 0 == 0
++ "-SSLv2"
++#endif
++#if HAVE_DECL_SSLV3_CLIENT_METHOD + 0 == 0
++ "-SSLv3"
++#endif
+ #ifdef OPIE_ENABLE
+ "+OPIE"
+ #endif /* OPIE_ENABLE */
+diff --git a/socket.c b/socket.c
+index 58a8e15..91a21c2 100644
+--- a/socket.c
++++ b/socket.c
+@@ -910,11 +910,16 @@ int SSLOpen(int sock, char *mycert, char *mykey, const char *myproto, int certck
+ #if HAVE_DECL_SSLV2_CLIENT_METHOD + 0 > 0
+ _ctx[sock] = SSL_CTX_new(SSLv2_client_method());
+ #else
+- report(stderr, GT_("Your operating system does not support SSLv2.\n"));
++ report(stderr, GT_("Your OpenSSL version does not support SSLv2.\n"));
+ return -1;
+ #endif
+ } else if(!strcasecmp("ssl3",myproto)) {
++#if HAVE_DECL_SSLV3_CLIENT_METHOD + 0 > 0
+ _ctx[sock] = SSL_CTX_new(SSLv3_client_method());
++#else
++ report(stderr, GT_("Your OpenSSL version does not support SSLv3.\n"));
++ return -1;
++#endif
+ } else if(!strcasecmp("tls1",myproto)) {
+ _ctx[sock] = SSL_CTX_new(TLSv1_client_method());
+ } else if (!strcasecmp("ssl23",myproto)) {
+--
+libgit2 0.24.0
+