aboutsummaryrefslogtreecommitdiffstats
path: root/main/fftw
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-02-08 17:55:08 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-02-08 17:55:08 +0100
commit2ac534f12687225e97720dc8f7c3590aee64cb06 (patch)
tree017e199808debe5246a23f7701e6a8b573fa5a5b /main/fftw
parent3c6150845f9fb6e24c5b6d705d9cd3414e389668 (diff)
downloadaports-2ac534f12687225e97720dc8f7c3590aee64cb06.tar.bz2
aports-2ac534f12687225e97720dc8f7c3590aee64cb06.tar.xz
main/fftw: improve abuild
Diffstat (limited to 'main/fftw')
-rw-r--r--main/fftw/APKBUILD34
1 files changed, 18 insertions, 16 deletions
diff --git a/main/fftw/APKBUILD b/main/fftw/APKBUILD
index 7f0ad073ae..881ed5d644 100644
--- a/main/fftw/APKBUILD
+++ b/main/fftw/APKBUILD
@@ -5,6 +5,8 @@ pkgver=3.3.6p2
pkgrel=2
pkgdesc="fastest fourier transform in the west"
url="http://www.fftw.org/"
+# s390x: hangs on container and KVM
+arch="all !s390x"
license="GPL-2.0+"
makedepends="texinfo"
# order of the libs split functions are important because of lib naming
@@ -13,34 +15,34 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-single-libs:single
srcpkgver=${pkgver//p/-pl}
source="http://www.fftw.org/$pkgname-$srcpkgver.tar.gz
cycle.h.patch"
-# s390x: hangs on container and KVM
-arch="all !s390x"
-_precision="single double long-double"
-
builddir="$srcdir/$pkgname-$srcpkgver"
+_precision="single double long-double"
+
prepare() {
- cd "$builddir"
default_prepare
- for i in $_precision; do
+
+ cd "$builddir"
+ local i; for i in $_precision; do
cp -r "$builddir" $srcdir/$i
done
}
build() {
local _openmp=
- for i in $_precision; do
+
+ local i; for i in $_precision; do
case "$i" in
- single)_cf="--enable-single";;
- double)_cf="";;
- long-double)_cf="--enable-long-double";;
+ single) _cf="--enable-single";;
+ double) _cf="";;
+ long-double) _cf="--enable-long-double";;
esac
case "$i--$CARCH" in
- single--x86_64 | double--x86_64)
- _cf="$_cf --enable-sse2 --enable-avx";;
- single--arm* | single--aarch64)
- _cf="$_cf --enable-neon";;
+ single--x86_64 | double--x86_64)
+ _cf="$_cf --enable-sse2 --enable-avx";;
+ single--arm* | single--aarch64)
+ _cf="$_cf --enable-neon";;
esac
msg "Building for $i precision ($_cf)"
@@ -61,14 +63,14 @@ build() {
}
check() {
- for i in $_precision; do
+ local i; for i in $_precision; do
cd "$srcdir"/$i
make check
done
}
package() {
- for i in $_precision; do
+ local i; for i in $_precision; do
cd "$srcdir"/$i
make DESTDIR="$pkgdir" install
done