aboutsummaryrefslogtreecommitdiffstats
path: root/main/file
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-23 18:24:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-23 18:24:11 +0000
commit2d2ddf507bf1ae2f4cc595b23b8e018398cbe8dd (patch)
treea63d3b3b1c89018b5419358eed5c2bb0acf1cd92 /main/file
parente374901731eb35599bd6735de4dd38560e3a79b8 (diff)
downloadaports-2d2ddf507bf1ae2f4cc595b23b8e018398cbe8dd.tar.bz2
aports-2d2ddf507bf1ae2f4cc595b23b8e018398cbe8dd.tar.xz
move core/* to main/
added maintainer to several packages as well
Diffstat (limited to 'main/file')
-rw-r--r--main/file/APKBUILD22
-rw-r--r--main/file/nocxx.patch15
2 files changed, 37 insertions, 0 deletions
diff --git a/main/file/APKBUILD b/main/file/APKBUILD
new file mode 100644
index 0000000000..7754f6ced6
--- /dev/null
+++ b/main/file/APKBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=file
+pkgver=5.03
+pkgrel=0
+pkgdesc="File type identification utility"
+url="http://www.darwinsys.com/file/"
+license="custom"
+depends="uclibc zlib"
+source="ftp://ftp.astron.com/pub/file/file-$pkgver.tar.gz
+ nocxx.patch"
+subpackages="$pkgname-dev $pkgname-doc"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ patch configure < ../nocxx.patch || return 1
+ ./configure --prefix=/usr --datadir=/usr/share/misc
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+md5sums="d05f08a53e5c2f51f8ee6a4758c0cc53 file-5.03.tar.gz
+28513788ba4d556ccd538867dc6205ab nocxx.patch"
diff --git a/main/file/nocxx.patch b/main/file/nocxx.patch
new file mode 100644
index 0000000000..beb1ab9006
--- /dev/null
+++ b/main/file/nocxx.patch
@@ -0,0 +1,15 @@
+--- a/configure 2004-12-07 21:34:23.205172545 +0000
++++ b/configure 2004-12-07 21:37:17.726654782 +0000
+@@ -5148,10 +5148,8 @@
+ :
+ else
+ { { echo "$as_me:$LINENO: error: C++ preprocessor \"$CXXCPP\" fails sanity check
+-See \`config.log' for more details." >&5
+-echo "$as_me: error: C++ preprocessor \"$CXXCPP\" fails sanity check
+-See \`config.log' for more details." >&2;}
+- { (exit 1); exit 1; }; }
++See \`config.log' for more details." >&5;}
++ { echo "C++ sucks, ignoring ..." >&5; }; }
+ fi
+
+ ac_ext=cc