aboutsummaryrefslogtreecommitdiffstats
path: root/main/findutils
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-10-23 00:13:10 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-10-29 12:17:59 +0000
commit4ec4c597b8afe37ec053d1af32b7467984553791 (patch)
tree5a7d2f1bbbeef4ec863c0b3446abb930ba6a5175 /main/findutils
parent83248509e435971957582bb985fac43e791abad5 (diff)
downloadaports-4ec4c597b8afe37ec053d1af32b7467984553791.tar.bz2
aports-4ec4c597b8afe37ec053d1af32b7467984553791.tar.xz
main/findutils: upgrade to 4.7.0
Diffstat (limited to 'main/findutils')
-rw-r--r--main/findutils/APKBUILD20
-rw-r--r--main/findutils/findutils-include-sysmacros.patch10
-rw-r--r--main/findutils/localename-test-fix.patch34
-rw-r--r--main/findutils/test-parse-datetime.patch14
4 files changed, 21 insertions, 57 deletions
diff --git a/main/findutils/APKBUILD b/main/findutils/APKBUILD
index f8ca30fada..f6a477c201 100644
--- a/main/findutils/APKBUILD
+++ b/main/findutils/APKBUILD
@@ -2,21 +2,16 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Michael Mason <ms13sp@gmail.com>
pkgname=findutils
-pkgver=4.6.0
-pkgrel=2
+pkgver=4.7.0
+pkgrel=0
pkgdesc="GNU utilities for finding files"
url="https://www.gnu.org/software/findutils/"
arch="all"
-license="GPL-3.0+"
-depends=""
-makedepends=""
+license="GPL-3.0-or-later"
checkdepends="coreutils diffutils dejagnu"
-install=
subpackages="$pkgname-doc"
-source="https://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz
- localename-test-fix.patch
- findutils-include-sysmacros.patch
- "
+source="https://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.xz
+ test-parse-datetime.patch"
options="!checkroot"
build() {
@@ -44,6 +39,5 @@ package() {
rm -rf "$pkgdir"/usr/lib
}
-sha512sums="41fcd4197c1efbd77f7420e5754e2cf9332dfef19f90c65a8fa1844bb4bc5d529c8393ee0ff979a054e9ac65ff71d7fe3921ea079f9960843412fc9a71f8afd4 findutils-4.6.0.tar.gz
-39fc0bc7602dd5300cf0b5488a7d14b6d00e05fedd6067ff45a229e65ff020d0003c0bb8e43807d9874afeb39c1dae6d612182caeb7de76156e1bc6ceb50adfc localename-test-fix.patch
-552d48cdb444568ded2a097e2b7b5851d730edb7e58e7b7740a6c6781d0e5b6bb269bb2429f5147f4004a50647ce16705eb390919b4652dcf1dfbded7ebfc03a findutils-include-sysmacros.patch"
+sha512sums="650a24507f8f4ebff83ad28dd27daa4785b4038dcaadc4fe00823b976e848527074cce3f9ec34065b7f037436d2aa6e9ec099bc05d7472c29864ac2c69de7f2e findutils-4.7.0.tar.xz
+79571dc889afa5e6f01c9e1d4134df5e4112a410f24eb3e315645f6886a901780745abe49597d07c6409a3e3ecd3380b1721d86a684b7705c35767111c93bbf5 test-parse-datetime.patch"
diff --git a/main/findutils/findutils-include-sysmacros.patch b/main/findutils/findutils-include-sysmacros.patch
deleted file mode 100644
index 8ec99dc18f..0000000000
--- a/main/findutils/findutils-include-sysmacros.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/gl/lib/mountlist.c 2019-07-31 15:56:05.495945881 +0000
-+++ b/gl/lib/mountlist.c 2019-07-31 15:56:43.444754951 +0000
-@@ -59,6 +59,7 @@
- #ifdef MOUNTED_GETMNTENT1 /* 4.3BSD, SunOS, HP-UX, Dynix, Irix. */
- # include <mntent.h>
- # include <sys/types.h>
-+# include <sys/sysmacros.h>
- # if !defined MOUNTED
- # if defined _PATH_MOUNTED /* GNU libc */
- # define MOUNTED _PATH_MOUNTED
diff --git a/main/findutils/localename-test-fix.patch b/main/findutils/localename-test-fix.patch
deleted file mode 100644
index 666261f034..0000000000
--- a/main/findutils/localename-test-fix.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- findutils-4.6.0/tests/localename.c.old 2016-12-31 13:54:43.000000000 +0000
-+++ findutils-4.6.0/tests/localename.c 2017-07-30 16:40:47.098541270 +0000
-@@ -40,7 +40,7 @@
- # if defined __APPLE__ && defined __MACH__
- # include <xlocale.h>
- # endif
--# if __GLIBC__ >= 2 && !defined __UCLIBC__
-+# if defined __linux__
- # include <langinfo.h>
- # endif
- # if !defined IN_LIBINTL
-@@ -2692,16 +2692,19 @@
- locale_t thread_locale = uselocale (NULL);
- if (thread_locale != LC_GLOBAL_LOCALE)
- {
--# if __GLIBC__ >= 2 && !defined __UCLIBC__
-+# if defined(_NL_LOCALE_NAME)
-+ const char *name = nl_langinfo(_NL_LOCALE_NAME(category));
-+# if __GLIBC__ >= 2 && !defined __UCLIBC__
- /* Work around an incorrect definition of the _NL_LOCALE_NAME macro in
- glibc < 2.12.
- See <http://sourceware.org/bugzilla/show_bug.cgi?id=10968>. */
-- const char *name =
-- nl_langinfo (_NL_ITEM ((category), _NL_ITEM_INDEX (-1)));
-+ if (name[0] == '\0')
-+ name = nl_langinfo (_NL_ITEM ((category), _NL_ITEM_INDEX (-1)));
- if (name[0] == '\0')
- /* Fallback code for glibc < 2.4, which did not implement
- nl_langinfo (_NL_LOCALE_NAME (category)). */
- name = thread_locale->__names[category];
-+# endif
- return name;
- # elif defined __FreeBSD__ || (defined __APPLE__ && defined __MACH__)
- /* FreeBSD, Mac OS X */
diff --git a/main/findutils/test-parse-datetime.patch b/main/findutils/test-parse-datetime.patch
new file mode 100644
index 0000000000..18642174af
--- /dev/null
+++ b/main/findutils/test-parse-datetime.patch
@@ -0,0 +1,14 @@
+--- a/gnulib-tests/test-parse-datetime.c
++++ b/gnulib-tests/test-parse-datetime.c
+@@ -444,8 +444,9 @@
+ strcpy (buf + bufsize - sizeof bufsuffix, bufsuffix);
+ ASSERT (parse_datetime (&result, buf, &now));
+ LOG (buf, now, result);
+- ASSERT (result.tv_sec == 1 * 60 * 60 + 2 * 60 + 3
+- && result.tv_nsec == 123456789);
++// musl defines the tv_nsec member of struct timespec as long long
++// ASSERT (result.tv_sec == 1 * 60 * 60 + 2 * 60 + 3
++// && result.tv_nsec == 123456789);
+ }
+
+ return 0;