aboutsummaryrefslogtreecommitdiffstats
path: root/main/findutils
diff options
context:
space:
mode:
authorValery Kartel <valery.kartel@gmail.com>2016-01-20 23:27:03 +0200
committerTimo Teräs <timo.teras@iki.fi>2016-01-21 06:32:10 +0000
commita89173062dc1fc9b72657be2979e7fb9244bf2d2 (patch)
treea2276343427d32495544604a81744714d0b4e247 /main/findutils
parent89209ade4acd6741aae257f8c38c5d22ab664f85 (diff)
downloadaports-a89173062dc1fc9b72657be2979e7fb9244bf2d2.tar.bz2
aports-a89173062dc1fc9b72657be2979e7fb9244bf2d2.tar.xz
main/findutils: upgrade to 4.6.0
remove upstreamed patch
Diffstat (limited to 'main/findutils')
-rw-r--r--main/findutils/APKBUILD31
-rw-r--r--main/findutils/fix-gnulib-freadahead.patch38
2 files changed, 8 insertions, 61 deletions
diff --git a/main/findutils/APKBUILD b/main/findutils/APKBUILD
index c4e074871c..f6fe091738 100644
--- a/main/findutils/APKBUILD
+++ b/main/findutils/APKBUILD
@@ -1,8 +1,9 @@
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Michael Mason <ms13sp@gmail.com>
pkgname=findutils
-pkgver=4.4.2
-pkgrel=3
+pkgver=4.6.0
+pkgrel=0
pkgdesc="GNU utilities for finding files"
url="http://www.gnu.org/software/findutils/"
arch="all"
@@ -11,22 +12,10 @@ depends=""
makedepends=""
install=
subpackages="$pkgname-doc"
-source="http://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz
- fix-gnulib-freadahead.patch
- "
+source="http://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
_builddir="$srcdir"/findutils-$pkgver
-prepare() {
- cd "$_builddir"
- update_config_sub || return 1
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
build() {
cd "$_builddir"
@@ -45,14 +34,10 @@ build() {
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install
- rm -rf "$pkgdir"/usr/lib/charset.alias
- rmdir -p "$pkgdir"/usr/lib 2>/dev/null
+ rm -rf "$pkgdir"/usr/lib
return 0
}
-md5sums="351cc4adb07d54877fa15f75fb77d39f findutils-4.4.2.tar.gz
-1d96ac5e44f302e23c03bb55347e9a79 fix-gnulib-freadahead.patch"
-sha256sums="434f32d171cbc0a5e72cfc5372c6fc4cb0e681f8dce566a0de5b6fccd702b62a findutils-4.4.2.tar.gz
-4a83686438d95859ea0ed9cafa8119a7b788e3d7ef2b1eee52ee3f0391d23dc9 fix-gnulib-freadahead.patch"
-sha512sums="262d0a8301158e6541b9f24e4e043d8d8c1b196b18dbe59c3bedcf17b50c95708e33ab23a07e3bfb947ad495faafffdca3c296fb525794ca60f2dfd682f228c1 findutils-4.4.2.tar.gz
-86797a218ff6b4425f0c2df353b7863b521e5c08c282f6885f55b942149c32bc65e25491f156dbf3622e14d8108d508d86000dfd38c79d1302bbef91f68c9cfc fix-gnulib-freadahead.patch"
+md5sums="9936aa8009438ce185bea2694a997fc1 findutils-4.6.0.tar.gz"
+sha256sums="ded4c9f73731cd48fec3b6bdaccce896473b6d8e337e9612e16cf1431bb1169d findutils-4.6.0.tar.gz"
+sha512sums="41fcd4197c1efbd77f7420e5754e2cf9332dfef19f90c65a8fa1844bb4bc5d529c8393ee0ff979a054e9ac65ff71d7fe3921ea079f9960843412fc9a71f8afd4 findutils-4.6.0.tar.gz"
diff --git a/main/findutils/fix-gnulib-freadahead.patch b/main/findutils/fix-gnulib-freadahead.patch
deleted file mode 100644
index adcfdd4186..0000000000
--- a/main/findutils/fix-gnulib-freadahead.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- findutils-4.4.2.orig/gnulib/lib/freadahead.c
-+++ findutils-4.4.2/gnulib/lib/freadahead.c
-@@ -19,6 +19,7 @@
- /* Specification. */
- #include "freadahead.h"
-
-+#ifndef HAVE___FREADAHEAD
- size_t
- freadahead (FILE *fp)
- {
-@@ -64,3 +65,4 @@
- #error "Please port gnulib freadahead.c to your platform! Look at the definition of fflush, fread on your system, then report this to bug-gnulib."
- #endif
- }
-+#endif
---- findutils-4.4.2.orig/gnulib/lib/freadahead.h
-+++ findutils-4.4.2/gnulib/lib/freadahead.h
-@@ -29,7 +29,20 @@
-
- STREAM must not be wide-character oriented. */
-
-+#if HAVE___FREADAHEAD || (defined(__linux__) && !defined(__GLIBC__) && !defined(__UCLIBC__)) /* musl libc */
-+
-+#ifndef HAVE___FREADAHEAD
-+#define HAVE___FREADAHEAD 1
-+#endif
-+
-+# include <stdio_ext.h>
-+# define freadahead(stream) __freadahead (stream)
-+
-+#else
-+
- extern size_t freadahead (FILE *stream);
-+
-+#endif
-
- #ifdef __cplusplus
- }