aboutsummaryrefslogtreecommitdiffstats
path: root/main/findutils
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-05 18:14:39 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-07 06:22:04 +0000
commitd8fff2952c63eeee6307679b80ede8a22a0ec2f0 (patch)
tree1463be97f8ac0b3eb1d027a4406458943dae0e60 /main/findutils
parent28e510980f8736b03bf02ea0e572cb7925643cfd (diff)
downloadaports-d8fff2952c63eeee6307679b80ede8a22a0ec2f0.tar.bz2
aports-d8fff2952c63eeee6307679b80ede8a22a0ec2f0.tar.xz
main/findutils: add tests, modernise, fix license
Diffstat (limited to 'main/findutils')
-rw-r--r--main/findutils/APKBUILD33
-rw-r--r--main/findutils/localename-test-fix.patch34
2 files changed, 52 insertions, 15 deletions
diff --git a/main/findutils/APKBUILD b/main/findutils/APKBUILD
index 5b28dd6e83..a3d55e9e66 100644
--- a/main/findutils/APKBUILD
+++ b/main/findutils/APKBUILD
@@ -3,41 +3,44 @@
# Maintainer: Michael Mason <ms13sp@gmail.com>
pkgname=findutils
pkgver=4.6.0
-pkgrel=0
+pkgrel=1
pkgdesc="GNU utilities for finding files"
url="https://www.gnu.org/software/findutils/"
arch="all"
-license="GPL"
+license="GPL-3.0+"
depends=""
makedepends=""
+checkdepends="dejagnu"
install=
subpackages="$pkgname-doc"
-source="http://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
-
-_builddir="$srcdir"/findutils-$pkgver
+source="http://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz
+ localename-test-fix.patch
+ "
build() {
- cd "$_builddir"
+ cd "$builddir"
- CFLAGS="$CFLAGS -D_FORTIFY_SOURCE=0" ./configure \
+ ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/share/man \
- --infodir=/usr/share/info \
- || return 1
- make || return 1
+ --infodir=/usr/share/info
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install
rm -rf "$pkgdir"/usr/lib
- return 0
}
-md5sums="9936aa8009438ce185bea2694a997fc1 findutils-4.6.0.tar.gz"
-sha256sums="ded4c9f73731cd48fec3b6bdaccce896473b6d8e337e9612e16cf1431bb1169d findutils-4.6.0.tar.gz"
-sha512sums="41fcd4197c1efbd77f7420e5754e2cf9332dfef19f90c65a8fa1844bb4bc5d529c8393ee0ff979a054e9ac65ff71d7fe3921ea079f9960843412fc9a71f8afd4 findutils-4.6.0.tar.gz"
+sha512sums="41fcd4197c1efbd77f7420e5754e2cf9332dfef19f90c65a8fa1844bb4bc5d529c8393ee0ff979a054e9ac65ff71d7fe3921ea079f9960843412fc9a71f8afd4 findutils-4.6.0.tar.gz
+39fc0bc7602dd5300cf0b5488a7d14b6d00e05fedd6067ff45a229e65ff020d0003c0bb8e43807d9874afeb39c1dae6d612182caeb7de76156e1bc6ceb50adfc localename-test-fix.patch"
diff --git a/main/findutils/localename-test-fix.patch b/main/findutils/localename-test-fix.patch
new file mode 100644
index 0000000000..666261f034
--- /dev/null
+++ b/main/findutils/localename-test-fix.patch
@@ -0,0 +1,34 @@
+--- findutils-4.6.0/tests/localename.c.old 2016-12-31 13:54:43.000000000 +0000
++++ findutils-4.6.0/tests/localename.c 2017-07-30 16:40:47.098541270 +0000
+@@ -40,7 +40,7 @@
+ # if defined __APPLE__ && defined __MACH__
+ # include <xlocale.h>
+ # endif
+-# if __GLIBC__ >= 2 && !defined __UCLIBC__
++# if defined __linux__
+ # include <langinfo.h>
+ # endif
+ # if !defined IN_LIBINTL
+@@ -2692,16 +2692,19 @@
+ locale_t thread_locale = uselocale (NULL);
+ if (thread_locale != LC_GLOBAL_LOCALE)
+ {
+-# if __GLIBC__ >= 2 && !defined __UCLIBC__
++# if defined(_NL_LOCALE_NAME)
++ const char *name = nl_langinfo(_NL_LOCALE_NAME(category));
++# if __GLIBC__ >= 2 && !defined __UCLIBC__
+ /* Work around an incorrect definition of the _NL_LOCALE_NAME macro in
+ glibc < 2.12.
+ See <http://sourceware.org/bugzilla/show_bug.cgi?id=10968>. */
+- const char *name =
+- nl_langinfo (_NL_ITEM ((category), _NL_ITEM_INDEX (-1)));
++ if (name[0] == '\0')
++ name = nl_langinfo (_NL_ITEM ((category), _NL_ITEM_INDEX (-1)));
+ if (name[0] == '\0')
+ /* Fallback code for glibc < 2.4, which did not implement
+ nl_langinfo (_NL_LOCALE_NAME (category)). */
+ name = thread_locale->__names[category];
++# endif
+ return name;
+ # elif defined __FreeBSD__ || (defined __APPLE__ && defined __MACH__)
+ /* FreeBSD, Mac OS X */