aboutsummaryrefslogtreecommitdiffstats
path: root/main/flac
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-14 15:38:20 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-14 15:42:55 -0300
commit81633f00dd52212d62c630bbf6f6c8a9bc1f29cd (patch)
tree8c4c8d6cf86d750385b57d31192a030b65f7ef02 /main/flac
parent297f593732904d02593169850509404a244aa1f7 (diff)
downloadaports-81633f00dd52212d62c630bbf6f6c8a9bc1f29cd.tar.bz2
aports-81633f00dd52212d62c630bbf6f6c8a9bc1f29cd.tar.xz
main/*: remove invalid options and modernize
Diffstat (limited to 'main/flac')
-rw-r--r--main/flac/APKBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/main/flac/APKBUILD b/main/flac/APKBUILD
index df6145f56d..d358fe2167 100644
--- a/main/flac/APKBUILD
+++ b/main/flac/APKBUILD
@@ -6,7 +6,7 @@ pkgdesc="Free Lossless Audio Codec"
url="https://xiph.org/flac/"
arch="all"
license="custom:Xiph LGPL GPL FDL"
-options="!checkroot !check" # Tests are infinite
+options="!check" # Tests are infinite
subpackages="$pkgname-dev $pkgname-doc"
makedepends="libogg-dev !libiconv"
source="http://downloads.xiph.org/releases/flac/flac-$pkgver.tar.xz"
@@ -17,10 +17,8 @@ source="http://downloads.xiph.org/releases/flac/flac-$pkgver.tar.xz"
build() {
- cd "$builddir"
-
local _arch_conf
- case "${CARCH}" in
+ case "$CARCH" in
ppc*) _arch_conf="--enable-altivec" ;;
x86_64) _arch_conf="--enable-sse" ;;
x86) _arch_conf="--disable-sse" ;;
@@ -40,12 +38,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -Dm0644 COPYING.Xiph \