aboutsummaryrefslogtreecommitdiffstats
path: root/main/flite
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-03-11 09:23:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-03-15 15:53:12 +0000
commit818921171db12d24c2fd9a6375e4100752773017 (patch)
tree36d0898170d4e9685c0db1d7a26ad38d0e0ac1cd /main/flite
parent7021cfcb0a53e6ba91a07729719aa4d4740bf3d6 (diff)
downloadaports-818921171db12d24c2fd9a6375e4100752773017.tar.bz2
aports-818921171db12d24c2fd9a6375e4100752773017.tar.xz
main/flite: upgrade to 2.1, modernize
Diffstat (limited to 'main/flite')
-rw-r--r--main/flite/APKBUILD38
1 files changed, 12 insertions, 26 deletions
diff --git a/main/flite/APKBUILD b/main/flite/APKBUILD
index 2bfb001473..57c379462f 100644
--- a/main/flite/APKBUILD
+++ b/main/flite/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=flite
-pkgver=2.0.0
+pkgver=2.1
pkgrel=0
pkgdesc="Small, fast speech synthesis engine (text-to-speech)"
-url="http://www.speech.cs.cmu.edu/flite/"
+url="http://www.speech.cs.cmu.edu/flite"
arch="all"
license="MIT"
depends=
@@ -12,44 +12,32 @@ depends_dev=
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev"
-source="http://www.festvox.org/flite/packed/flite-${pkgver%.*}/flite-$pkgver-release.tar.bz2"
-
-_builddir="$srcdir"/flite-$pkgver-release
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+source="http://www.festvox.org/$pkgname/packed/$pkgname-$pkgver/$pkgname-$pkgver-release.tar.bz2"
+builddir="$srcdir/$pkgname-$pkgver-release"
build() {
- cd "$_builddir"
+ cd "$builddir"
CFLAGS="$CFLAGS -fPIC" ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--enable-shared \
- --localstatedir=/var \
- || return 1
+ --localstatedir=/var
# work around parallel build issue
make -C include
make -C src
make -C lang
make -C tools
- make -j1 || return 1
+ make -j1
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make install INSTALLBINDIR="$pkgdir"/usr/bin \
INSTALLLIBDIR="$pkgdir"/usr/lib \
- INSTALLINCDIR="$pkgdir"/usr/include/flite \
- || return 1
+ INSTALLINCDIR="$pkgdir"/usr/include/flite
# remove relative rpaths
- scanelf -R -r --fix "$pkgdir" || return 1
+ scanelf -R -r --fix "$pkgdir"
mkdir -p "$pkgdir"/usr/lib/pkgconfig
cat > "$pkgdir"/usr/lib/pkgconfig/flite.pc <<EOF
prefix=/usr
@@ -60,13 +48,11 @@ includedir=\${prefix}/include
Name: flite
Description: a text to speech library
Requires:
-Version: 2.0.0
+Version: 2.1
Libs: -L\${libdir} -lflite -lflite_cmu_grapheme_lang -lflite_cmu_grapheme_lex -lflite_cmu_indic_lang -lflite_cmu_indic_lex -lflite_cmulex -lflite_cmu_time_awb -lflite_cmu_us_awb -lflite_cmu_us_kal16 -lflite_cmu_us_kal -lflite_cmu_us_rms -lflite_cmu_us_slt -lflite_usenglish
Libs.private: -lm
Cflags: -I\${includedir}/flite/
EOF
}
-md5sums="645db96ffc296cbb6d37f231cc1cc6b2 flite-2.0.0-release.tar.bz2"
-sha256sums="678c3860fd539402b5d1699b921239072af6acb4e72dc4720494112807cae411 flite-2.0.0-release.tar.bz2"
-sha512sums="e2b353721d0316fbd7948f90f9c9561d080eebd50e8dd0449a9c803ffbdb060a469385fadd63f535ade8d627cba37928d8e72ac61d5bcf98f73ca5ebb66549f8 flite-2.0.0-release.tar.bz2"
+sha512sums="e9ef9ca4b6920178634d94bbe6e21a8b0ec471b010b07e6cc961ed2d120acb944c8e1d268fe26188f7dfe43fb7bd4bdff7fa53b2d2f12029d37e08d0316620d2 flite-2.1-release.tar.bz2"