aboutsummaryrefslogtreecommitdiffstats
path: root/main/fossil
diff options
context:
space:
mode:
authortcely <tcely@users.noreply.github.com>2018-02-05 04:49:47 -0500
committerTimo Teräs <timo.teras@iki.fi>2018-02-05 19:19:32 +0000
commit4e0974895b1624bbfb1dfbb05b5a81ecaba16ffd (patch)
treedd035f32602b60f083b6e613fd2a137df21c3ecf /main/fossil
parentb5bcde92112be1f1a978f7437c6d2ae3e4064c29 (diff)
downloadaports-4e0974895b1624bbfb1dfbb05b5a81ecaba16ffd.tar.bz2
aports-4e0974895b1624bbfb1dfbb05b5a81ecaba16ffd.tar.xz
main/fossil: Upgrade to 2.4
Diffstat (limited to 'main/fossil')
-rw-r--r--main/fossil/APKBUILD28
1 files changed, 24 insertions, 4 deletions
diff --git a/main/fossil/APKBUILD b/main/fossil/APKBUILD
index fb71634b64..1f437eba61 100644
--- a/main/fossil/APKBUILD
+++ b/main/fossil/APKBUILD
@@ -1,14 +1,14 @@
# Contributor: Paul Onyschuk <blink@bojary.koba.pl>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fossil
-pkgver=2.3
-pkgrel=1
+pkgver=2.4
+pkgrel=0
pkgdesc="Simple, high-reliability, distributed software configuration management"
url="http://www.fossil-scm.org"
arch="all"
license="BSD"
depends=""
-makedepends="libressl-dev zlib-dev sqlite-dev"
+makedepends="libressl-dev sqlite-dev tcl-dev zlib-dev"
source="http://www.fossil-scm.org/index.html/uv/$pkgname-src-$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
@@ -23,9 +23,29 @@ build() {
make TCC="${CC:-gcc} $CFLAGS"
}
+# The tests don't have all the dependencies they want
+# Even with these dependencies, roughly a dozen of them
+# are broken anyway.
+#
+# ***** Final results: 11 errors out of 34909 tests
+# ***** Considered failures: pre-commit-warnings-fossil-1
+# test-framework-json test-framework-set-manifest th1-checkout-1
+# th1-checkout-2 th1-header-2 th1-artifact-3 th1-artifact-7
+# th1-globalState-1 th1-globalState-8 th1-encode64-3
+# ***** Ignored results: 5 ignored errors out of 34909 tests
+# ***** Ignored failures: merge5-sqlite3-issue stash-1-diff
+# stash-WY-1-CODE stash-3-2 stash-3-2-show-1
+#
+check() {
+ return 0
+
+ cd "$builddir"
+ make test
+}
+
package() {
cd "$builddir"
install -Dm 755 $pkgname "$pkgdir"/usr/bin/$pkgname
}
-sha512sums="41f87a9f79b87895b1972d2866b27205da34076eb35200b60fd38f1921162bf9099a71caac4063c04b919484208b39c7184dff661dc0b5ca7716d8edd11462cc fossil-src-2.3.tar.gz"
+sha512sums="de7f2321677df7f6dc2a3a20e58f456602d938f40125ef33d401f28cdaa93e38d3db10e109547df269bc95a2ac8669ade05b6fd6fad39e6633f15ffdd91c499f fossil-src-2.4.tar.gz"