aboutsummaryrefslogtreecommitdiffstats
path: root/main/frotz/Makefile.patch
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2015-09-21 14:52:47 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2015-09-21 14:52:47 +0200
commite7e9a1cfb9e52fb060cd0c01bb34e9567a04abbc (patch)
treec6b816e7ba8f9b659e1be415ebf1dac4262c3b82 /main/frotz/Makefile.patch
parent452d447d89b3a3775b7f602d7352a8cfe8a0f9d4 (diff)
downloadaports-e7e9a1cfb9e52fb060cd0c01bb34e9567a04abbc.tar.bz2
aports-e7e9a1cfb9e52fb060cd0c01bb34e9567a04abbc.tar.xz
testing/*: move to main
Diffstat (limited to 'main/frotz/Makefile.patch')
-rw-r--r--main/frotz/Makefile.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/main/frotz/Makefile.patch b/main/frotz/Makefile.patch
new file mode 100644
index 0000000000..ead06f88d0
--- /dev/null
+++ b/main/frotz/Makefile.patch
@@ -0,0 +1,49 @@
+--- src/frotz-2.43d/Makefile 2012-01-03 08:32:58.000000000 +0000
++++ ../Makefile 2014-12-01 13:08:50.390040011 +0000
+@@ -14,19 +14,19 @@
+ #-malign-jumps=2
+
+ # Define where you want Frotz installed. Usually this is /usr/local
+-PREFIX = /usr/local
++PREFIX = /usr
+
+-MAN_PREFIX = $(PREFIX)
+-#MAN_PREFIX = /usr/local/share
++#MAN_PREFIX = $(PREFIX)
++MAN_PREFIX = /usr/share
+
+-CONFIG_DIR = $(PREFIX)/etc
+-#CONFIG_DIR = /etc
++#CONFIG_DIR = $(PREFIX)/etc
++CONFIG_DIR = /etc
+
+ # Define where you want Frotz to look for frotz.conf.
+ #
+-CONFIG_DIR = /usr/local/etc
+-#CONFIG_DIR = /etc
+-#CONFIG_DIR = /usr/pkg/etc
++#CONFIG_DIR = /usr/local/etc
++#CONFIG_DIR = /etc
++#CONFIG_DIR = /usr/pkg/etc
+ #CONFIG_DIR =
+
+ # Uncomment this if you want color support. Most, but not all curses
+@@ -73,15 +73,15 @@
+ # curses library won't work, comment out the first option and uncomment
+ # the second.
+ #
+-CURSES = -lcurses
+-#CURSES = -lncurses
++#CURSES = -lcurses
++CURSES = -lncurses
+
+ # Uncomment this if your need to use ncurses instead of the
+ # vendor-supplied curses library. This just tells the compile process
+ # which header to include, so don't worry if ncurses is all you have
+ # (like on Linux). You'll be fine.
+ #
+-#CURSES_DEF = -DUSE_NCURSES_H
++CURSES_DEF = -DUSE_NCURSES_H
+
+ # Uncomment this if you're compiling Unix Frotz on a machine that lacks
+ # the memmove(3) system call. If you don't know what this means, leave it