aboutsummaryrefslogtreecommitdiffstats
path: root/main/fuse3
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-19 21:54:22 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-20 01:38:13 +0000
commit272545fd1927a3717d68253524bc8188cb625715 (patch)
treeb53d2c0bb60382b4ef6393cfe7cb999b21ea54f7 /main/fuse3
parentd68428681222ced860cddb1afdfa885370ff16c4 (diff)
downloadaports-272545fd1927a3717d68253524bc8188cb625715.tar.bz2
aports-272545fd1927a3717d68253524bc8188cb625715.tar.xz
main/fuse3: upgrade to 3.9.1
Diffstat (limited to 'main/fuse3')
-rw-r--r--main/fuse3/APKBUILD11
-rw-r--r--main/fuse3/add-includes.patch12
2 files changed, 5 insertions, 18 deletions
diff --git a/main/fuse3/APKBUILD b/main/fuse3/APKBUILD
index dd8d78da62..99949c9a53 100644
--- a/main/fuse3/APKBUILD
+++ b/main/fuse3/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fuse3
_pkgname=fuse
-pkgver=3.9.0
-pkgrel=2
+pkgver=3.9.1
+pkgrel=0
pkgdesc="The reference implementation of the Linux FUSE (Filesystem in Userspace) interface"
url="https://github.com/libfuse/libfuse"
arch="all"
@@ -14,8 +14,8 @@ checkdepends="py3-pytest"
subpackages="$pkgname-dev $pkgname-doc fuse-common:_common fuse-openrc:_openrc $pkgname-libs"
source="https://github.com/libfuse/libfuse/releases/download/fuse-$pkgver/fuse-$pkgver.tar.xz
fix-realpath.patch
- add-includes.patch
- fuse.initd"
+ fuse.initd
+ "
options="suid !check" # check is currently broken: https://github.com/libfuse/libfuse/issues/293
builddir="$srcdir"/$_pkgname-$pkgver
@@ -70,7 +70,6 @@ _openrc() {
install_if="openrc fuse-common=$pkgver-r$pkgrel"
}
-sha512sums="0c96df5db4d0ceb7885ddb6f6c05b523ee7e179f8f411ad0614caecb9fa0f5fd682ab9bf4dfdaa3aff9d90c18b8947a122ee376328535e49fa6091d784aa0cb7 fuse-3.9.0.tar.xz
+sha512sums="295bb62274264789c977a1fee78c6c122a2f227ae85d750b8519cafbdcf6551499b77cf021d83cc8261831e29761c166d84a4e50bdebb4191c76bcad1d15d329 fuse-3.9.1.tar.xz
1a9e1d1e8a7b0778ffde328e4322c73b5d57ec98d52767c846d755cce861ab27989823a75b6c5f994432ddb77fa351dfa4a8f948c9467c5f7d5f471e4608358b fix-realpath.patch
-45da040bc5baf6ffd78e5a43ed070042f845b0829edfa5591f3304503f2ffaa6c642e18eb46aa0b661a0284a0505892f1ce4097530696f1739ffaf85c422ac13 add-includes.patch
7f6a503ef23cfa8b809c544375c2d83ad56525269b48ad1a7dff0ce36f4bf2f2a3fafed9dc70a71ff6281b261db5f01829e16c06f041921a5d8c8d715a04a8c1 fuse.initd"
diff --git a/main/fuse3/add-includes.patch b/main/fuse3/add-includes.patch
deleted file mode 100644
index a84e468d9a..0000000000
--- a/main/fuse3/add-includes.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/example/passthrough_hp.cc b/example/passthrough_hp.cc
-index 974551e..61ab685 100644
---- a/example/passthrough_hp.cc
-+++ b/example/passthrough_hp.cc
-@@ -67,6 +67,7 @@
- #include <time.h>
- #include <unistd.h>
- #include <pthread.h>
-+#include <limits.h>
-
- // C++ includes
- #include <cstddef>