aboutsummaryrefslogtreecommitdiffstats
path: root/main/fuse3
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2019-08-28 10:33:06 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-08-28 10:33:09 +0000
commit5738daad4098ce30c8602f8b4b27fb1ec54e8e2b (patch)
tree03a1a452e2b120e233b35a3fa31b9638030beff7 /main/fuse3
parenta99a746a16f9442a37d2cd27e5f6216a358c721c (diff)
downloadaports-5738daad4098ce30c8602f8b4b27fb1ec54e8e2b.tar.bz2
aports-5738daad4098ce30c8602f8b4b27fb1ec54e8e2b.tar.xz
main/fuse3: attempt to fix build on ppc64le
Diffstat (limited to 'main/fuse3')
-rw-r--r--main/fuse3/APKBUILD4
-rw-r--r--main/fuse3/add-includes.patch12
2 files changed, 15 insertions, 1 deletions
diff --git a/main/fuse3/APKBUILD b/main/fuse3/APKBUILD
index 637b2498a8..0e4e47ce23 100644
--- a/main/fuse3/APKBUILD
+++ b/main/fuse3/APKBUILD
@@ -2,7 +2,7 @@
pkgname=fuse3
_pkgname=fuse
pkgver=3.6.2
-pkgrel=0
+pkgrel=1
pkgdesc="The reference implementation of the Linux FUSE (Filesystem in Userspace) interface"
url="https://github.com/libfuse/libfuse"
arch="all"
@@ -14,6 +14,7 @@ checkdepends="py3-pytest"
subpackages="$pkgname-dev $pkgname-doc fuse-common:_common fuse-openrc:_openrc $pkgname-libs"
source="https://github.com/libfuse/libfuse/releases/download/fuse-$pkgver/fuse-$pkgver.tar.xz
fix-realpath.patch
+ add-includes.patch
fuse.initd"
options="suid !check" # check is currently broken: https://github.com/libfuse/libfuse/issues/293
@@ -74,4 +75,5 @@ _openrc() {
sha512sums="e5eb10c66e8585d47430e289d059a3a58ebf3823304fa35e9be413c8d194401ff5093fac82c7c6911b3c5afde6c1c156aa671d333b193d2d739a7ed1632c4bd8 fuse-3.6.2.tar.xz
1a9e1d1e8a7b0778ffde328e4322c73b5d57ec98d52767c846d755cce861ab27989823a75b6c5f994432ddb77fa351dfa4a8f948c9467c5f7d5f471e4608358b fix-realpath.patch
+85c78b15633cfadee19cdb2cbae74e3b4853f6a27cc83460f4a9e6de0526fa411d3c457f3f0518579b16e81fc77292ea1772e370f82fcdbe0fd9785204b41104 add-includes.patch
7f6a503ef23cfa8b809c544375c2d83ad56525269b48ad1a7dff0ce36f4bf2f2a3fafed9dc70a71ff6281b261db5f01829e16c06f041921a5d8c8d715a04a8c1 fuse.initd"
diff --git a/main/fuse3/add-includes.patch b/main/fuse3/add-includes.patch
new file mode 100644
index 0000000000..5310b52a9e
--- /dev/null
+++ b/main/fuse3/add-includes.patch
@@ -0,0 +1,12 @@
+diff --git a/example/passthrough.c b/example/passthrough.c
+index 6de9fc1..ef4056e 100644
+--- a/example/passthrough.c
++++ b/example/passthrough.c
+@@ -44,6 +44,7 @@
+ #include <sys/stat.h>
+ #include <dirent.h>
+ #include <errno.h>
++#include <limits.h>
+ #ifdef __FreeBSD__
+ #include <sys/socket.h>
+ #include <sys/un.h>