aboutsummaryrefslogtreecommitdiffstats
path: root/main/gamin
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-27 14:07:36 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-27 14:22:24 +0000
commita1a836b089573752c1b0da7d144c0948b04e8ea8 (patch)
tree4e6af4ae2c6910311cd5066cec0bcfe3c664a65a /main/gamin
parent8d2c903bee89abe26bbedcb9c87d9b4977ca5887 (diff)
downloadaports-a1a836b089573752c1b0da7d144c0948b04e8ea8.tar.bz2
aports-a1a836b089573752c1b0da7d144c0948b04e8ea8.tar.xz
main/gamin: fix non portable mutex type usage (fixes musl build)
Diffstat (limited to 'main/gamin')
-rw-r--r--main/gamin/APKBUILD15
-rw-r--r--main/gamin/fix-pthread-mutex.patch11
2 files changed, 23 insertions, 3 deletions
diff --git a/main/gamin/APKBUILD b/main/gamin/APKBUILD
index b13fe04779..feabda412d 100644
--- a/main/gamin/APKBUILD
+++ b/main/gamin/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gamin
pkgver=0.1.10
-pkgrel=9
+pkgrel=10
pkgdesc="Gamin is a file and directory monitoring system defined to be a subset of the FAM (File Alteration Monitor) system."
url="http://www.gnome.org/~veillard/gamin"
arch="all"
@@ -10,11 +10,13 @@ subpackages="$pkgname-dev py-$pkgname:py"
depends=
makedepends="pkgconfig glib-dev python-dev"
source="http://www.gnome.org/~veillard/$pkgname/sources/$pkgname-$pkgver.tar.gz
- fix-deprecated-const.patch"
+ fix-deprecated-const.patch
+ fix-pthread-mutex.patch"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
+ update_config_sub || return 1
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -54,4 +56,11 @@ py() {
}
md5sums="b4ec549e57da470c04edd5ec2876a028 gamin-0.1.10.tar.gz
-f679aeb48fe9dd376c8828cc9b6941ab fix-deprecated-const.patch"
+f679aeb48fe9dd376c8828cc9b6941ab fix-deprecated-const.patch
+f05a8d9fe30b6ce2871795c06d74edc4 fix-pthread-mutex.patch"
+sha256sums="28085f0ae8be10eab582ff186af4fb0be92cc6c62b5cc19cd09b295c7c2899a1 gamin-0.1.10.tar.gz
+33af6c9a94b459506fc48892c169d89cb4ad7c68e160f0c4bc74475f19ce5a2f fix-deprecated-const.patch
+bfd5ee42e385367718a4dac8ab318f9a5881ab8b669e4020f87aacaef16a2f8e fix-pthread-mutex.patch"
+sha512sums="21bfe6fcf8fb3117cd5a08c8ce3b8d0d1dd23e478e60a95b76c20d02cc29b050dde086578d81037990484ff891c3e104d2cbbf3d294b4a79346b14a0cae075bb gamin-0.1.10.tar.gz
+c4c10bee70c7231db395cbfe5bdf513ade6be599a11a9d35888ddfaca42d619fe2b5e87c2b2bab469ea98ba718bc01711252313ba5f53c392379b669f5b2902b fix-deprecated-const.patch
+70628fc39521ea8bc4a40b009d0881f6ee540334a31b2f0cb67dde0f75808c69feb78088ad24c3c4a0dec9fa59e87960fd81d1a2e56963ce9268d0a5e14f88e8 fix-pthread-mutex.patch"
diff --git a/main/gamin/fix-pthread-mutex.patch b/main/gamin/fix-pthread-mutex.patch
new file mode 100644
index 0000000000..c8c5b0005c
--- /dev/null
+++ b/main/gamin/fix-pthread-mutex.patch
@@ -0,0 +1,11 @@
+--- gamin-0.1.10.orig/libgamin/gam_data.c
++++ gamin-0.1.10/libgamin/gam_data.c
+@@ -470,7 +470,7 @@
+ }
+ if (is_threaded > 0) {
+ pthread_mutexattr_init(&attr);
+-#if defined(linux) || defined(PTHREAD_MUTEX_RECURSIVE_NP)
++#if defined(linux) && defined(PTHREAD_MUTEX_RECURSIVE_NP)
+ pthread_mutexattr_settype(&attr, PTHREAD_MUTEX_RECURSIVE_NP);
+ #else
+ pthread_mutexattr_settype(&attr, PTHREAD_MUTEX_RECURSIVE);