aboutsummaryrefslogtreecommitdiffstats
path: root/main/gc
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-30 14:08:04 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-30 14:08:04 +0000
commitcd8870218ef28dab192ae4507698575a33fd91cd (patch)
tree7e98bbc4eba6e894b7233e1a7183537d99f95fd8 /main/gc
parent2a459269ce32598411253ae323fa8cc2f71821fd (diff)
downloadaports-cd8870218ef28dab192ae4507698575a33fd91cd.tar.bz2
aports-cd8870218ef28dab192ae4507698575a33fd91cd.tar.xz
main/gc: fix musl build
Diffstat (limited to 'main/gc')
-rw-r--r--main/gc/APKBUILD12
-rw-r--r--main/gc/fix-boehm-gc.patch11
2 files changed, 19 insertions, 4 deletions
diff --git a/main/gc/APKBUILD b/main/gc/APKBUILD
index 29fb2783ad..3ccf6e513a 100644
--- a/main/gc/APKBUILD
+++ b/main/gc/APKBUILD
@@ -10,6 +10,7 @@ depends=
makedepends=
subpackages="$pkgname-dev $pkgname-doc libgc++:libgccpp"
source="http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc-$pkgver.tar.gz
+ fix-boehm-gc.patch
"
# getcontext.patch
@@ -19,7 +20,7 @@ prepare() {
update_config_sub || return 1
for i in $source; do
case $i in
- *.patch) msg $; patch -p1 -i "$srcdir"/$i || return 1;;
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
}
@@ -47,6 +48,9 @@ libgccpp() {
mv "$pkgdir"/usr/lib/libgccpp.* "$subpkgdir"/usr/lib/
}
-md5sums="91340b28c61753a789eb6077675d87d2 gc-7.2d.tar.gz"
-sha256sums="d9fe0ae8650d43746a48bfb394cab01a319f3809cee19f8ebd16aa985b511c5e gc-7.2d.tar.gz"
-sha512sums="5b342754a1efeef0cf78983b7a0e48a36495beac04fc881ab356b26dc153b343e940ec7af070f4fc875be44adc559f7be995919fe9229f68d2e0237cdbeaabcc gc-7.2d.tar.gz"
+md5sums="91340b28c61753a789eb6077675d87d2 gc-7.2d.tar.gz
+2580315e6df59bb167b8292c351f82f5 fix-boehm-gc.patch"
+sha256sums="d9fe0ae8650d43746a48bfb394cab01a319f3809cee19f8ebd16aa985b511c5e gc-7.2d.tar.gz
+da9ffdb4e7abc3deaaa19ef9de118311a8cf67268df36085c80412b1a60307d1 fix-boehm-gc.patch"
+sha512sums="5b342754a1efeef0cf78983b7a0e48a36495beac04fc881ab356b26dc153b343e940ec7af070f4fc875be44adc559f7be995919fe9229f68d2e0237cdbeaabcc gc-7.2d.tar.gz
+f2b533f0a96dabf8ed33316c393ea2878cb3968879e50155c71fbb50bf0cad3fe08836847dcc5c2bc32ad2dae64b8607bf92fa863224e3ca407ef62d61b663bb fix-boehm-gc.patch"
diff --git a/main/gc/fix-boehm-gc.patch b/main/gc/fix-boehm-gc.patch
new file mode 100644
index 0000000000..88ffc99d79
--- /dev/null
+++ b/main/gc/fix-boehm-gc.patch
@@ -0,0 +1,11 @@
+--- gc-7.2.orig/os_dep.c
++++ gc-7.2/os_dep.c
+@@ -26,7 +26,7 @@
+ # define __KERNEL__
+ # include <asm/signal.h>
+ # undef __KERNEL__
+-# else
++# elif defined(__GLIBC__)
+ /* Kernels prior to 2.1.1 defined struct sigcontext_struct instead of */
+ /* struct sigcontext. libc6 (glibc2) uses "struct sigcontext" in */
+ /* prototypes, so we have to include the top-level sigcontext.h to */