aboutsummaryrefslogtreecommitdiffstats
path: root/main/gc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-08-08 07:42:36 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-08-08 07:42:51 +0000
commitd7fa5477a15f227015cd3fdf1e08a825bebbc351 (patch)
tree574a4453a07eb62334959f5087ce29e0520e921c /main/gc
parente043807b4812291900d4b2093dfe55a1c0cac755 (diff)
downloadaports-d7fa5477a15f227015cd3fdf1e08a825bebbc351.tar.bz2
aports-d7fa5477a15f227015cd3fdf1e08a825bebbc351.tar.xz
main/gc: upgrade to 7.2d
Diffstat (limited to 'main/gc')
-rw-r--r--main/gc/APKBUILD18
-rw-r--r--main/gc/getcontext.patch10
2 files changed, 10 insertions, 18 deletions
diff --git a/main/gc/APKBUILD b/main/gc/APKBUILD
index dbf6630235..5db186532b 100644
--- a/main/gc/APKBUILD
+++ b/main/gc/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gc
-pkgver=7.2
-pkgrel=1
+pkgver=7.2d
+pkgrel=0
pkgdesc="A garbage collector for C and C++"
url="http://www.hpl.hp.com/personal/Hans_Boehm/gc/"
arch="all"
@@ -10,11 +10,12 @@ depends=
makedepends=
subpackages="$pkgname-dev $pkgname-doc libgc++:libgccpp"
source="http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc-$pkgver.tar.gz
- getcontext.patch
"
+# getcontext.patch
+_builddir="$srcdir"/gc-${pkgver%[a-z]}
prepare() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
for i in $source; do
case $i in
*.patch) msg $; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -23,7 +24,7 @@ prepare() {
}
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -35,7 +36,7 @@ build() {
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
rm "$pkgdir"/usr/lib/*.la
}
@@ -45,5 +46,6 @@ libgccpp() {
mv "$pkgdir"/usr/lib/libgccpp.* "$subpkgdir"/usr/lib/
}
-md5sums="d17aecedef3d73e75387fb63558fa4eb gc-7.2.tar.gz
-4f77dfa0098f982ce42dc1580d31bf47 getcontext.patch"
+md5sums="91340b28c61753a789eb6077675d87d2 gc-7.2d.tar.gz"
+sha256sums="d9fe0ae8650d43746a48bfb394cab01a319f3809cee19f8ebd16aa985b511c5e gc-7.2d.tar.gz"
+sha512sums="5b342754a1efeef0cf78983b7a0e48a36495beac04fc881ab356b26dc153b343e940ec7af070f4fc875be44adc559f7be995919fe9229f68d2e0237cdbeaabcc gc-7.2d.tar.gz"
diff --git a/main/gc/getcontext.patch b/main/gc/getcontext.patch
deleted file mode 100644
index df3e45a055..0000000000
--- a/main/gc/getcontext.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./include/private/gcconfig.h.orig
-+++ ./include/private/gcconfig.h
-@@ -2483,6 +2483,7 @@
- #if ((defined(UNIX_LIKE) && (defined(DARWIN) || defined(HURD) \
- || defined(OPENBSD) || defined(ARM32) \
- || defined(MIPS) || defined(AVR32))) \
-+ || defined(__UCLIBC__) \
- || (defined(LINUX) && (defined(SPARC) || defined(M68K))) \
- || (defined(RTEMS) && defined(I386))) && !defined(NO_GETCONTEXT)
- # define NO_GETCONTEXT